Lanmark Controls Inc. has prepared this document for use by its personnel, licensees, and potential licensees. Lanmark Controls Inc. reserves the right to change any products described in this document as well as information included herein without prior notice. Although the information presented in this document has been tested and reviewed, this document does not convey any license or warrantee beyond the terms and conditions set forth in the written contracts and license agreements between Lanmark Controls Inc. and its customers.

The software described in this document is licensed from and is a trade secret of Lanmark Controls Inc. Refer to your License Agreement for restrictions on use, duplication, or disclosure.

Copyright © 2010 Lanmark Controls Inc. - All rights reserved under the copyright laws of the United States of America.

Government users and prime contractors are also governed by the following restricted rights legend:

RESTRICTED RIGHTS LEGEND. Use, duplication, or disclosure by the U.S. Government is subject to the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013 © (1) (ii) (Oct. 1988) and FAR 52.227-19 © (June 1987) or other agency provision is as applicable. Copyright Lanmark Controls Inc.

WinLase, Lanmark and Lanmarker are registered trademarks of Lanmark Controls Inc. in the United States and other countries. Other brands mentioned are trademarks or registered trademarks of their respective holders.

There is no implied warranty of fitness for a particular purpose, and Lanmark Controls Inc. is not responsible for consequential damages. Individual components and/or software modules manufactured by Lanmark Controls Inc. or others may be covered by their own warranties. Refer to the appropriate manuals for this information.
# Contents

1 **Introduction**
   - System Elements  1-2
   - Software Tools  1-4
   - Technical Support  1-4
   - About this Manual  1-4
   - Manufacturer  1-5
   - Revision History  1-6

2 **Getting Started**
   - Software Installation  2-1
   - HASP Key (Dongle) Installation  2-3
   - Safety Considerations  2-4

3 **WinLase LAN Basics**
   - Quick Start Guide  3-1
   - Selecting the Display Language  3-2
   - User Interface  3-4
   - Security Settings  3-21

4 **Working with the LEC-1**
   - Connectivity Options  4-1
   - Choosing Laser, Lens and Motion Settings  4-13
   - Controlling the LEC-1 Remotely  4-28
   - Control Signal Options  4-35
   - Diagnostic Tools  4-39
   - Firmware Updates  4-43
5 Job Editing
Setting up the Workspace 5-1
Opening, Closing and Saving Jobs 5-4
Assigning Jobs to an LEC-1 device 5-11
Stand-Alone Job Considerations 5-14
Managing Job Entities 5-16
Managing Profiles 5-28
Managing Fonts 5-38
Using the Motion Manager 5-42
Using the Dimension Tool 5-46
Using the Align Tool 5-53
Using the Grid and Guidelines 5-54
Using the Zoom Tools 5-60
Printing Jobs 5-62

6 Job Entities
Working with Job Entities 6-1
Mark Entities 6-5
Automation Objects 6-85
Template Object 6-115

7 Marking Jobs
Using PreviewMark 7-1
Using the QuickMark Feature 7-4
Running Jobs 7-6
Running Stand-Alone Jobs 7-24
Controlling WinLase LAN Remotely 7-28

8 The Marking Field and Lens
Understanding Field Distortions 8-1
Correcting for Mechanical Alignment Tolerances 8-8
9 Connecting to Lasers
   Working with the Laser Driver Wizard  9-1
   Using a Visible Pointer  9-23
   Laser Diagnostics  9-26

10 Motion Configuration
   Intelligent motion control  10-1
   Pro-Dex OMS motion controller  10-17

11 Warranty
Congratulations on selecting the WinLase LAN Software Suite, a powerful collection of laser marking software modules and libraries for OEM laser marking system integrators.

The WinLase LAN Software Suite includes the following:

- The **WinLase Graphical User Interface**, which includes a software command API
- Lanmark Controls Inc. **COM Automation Server API** object interface library
- WinLase LAN Host Programming Interface
- The **TCP/IP Test Client** tool
- The **LEC Remote Admin** tool
INTRODUCTION

System Elements

SYSTEM ELEMENTS

SYSTEM ARCHITECTURE

WinLase LAN offers a rich feature set and industry-leading capabilities by providing the complete software/controller solution from the User Interface to the firmware resident on the LEC-1 card.

WINLASE LAN LASER MARKING SOFTWARE

WinLase LAN elements include:

- Supports LEC-1 Ethernet controller cards
- Runs on Windows XP Professional and Windows Vista Business
• Easy configuration of laser parameters for specific lasers
• Supports TrueType, OpenType and Laser fonts
• Supports graphic file import of DXF (versions 13, 14, 2000, 2004, 2007) DWG (versions 13, 14, 2000), PLT, EMF, WMF, EX2, MCL, BMP, JPG, GIF, PCX
• Supports linear barcode types Code 39, CodaBar, Code 93, Code 128, Interleaved 2 of 5, POSTNET, UPC A, UPC E, EAN 8, EAN 13, BookLan
• Supports 2D barcode types DataMatrix, Denso QR Code, PDF417
• Extensive array of Automation objects: Wait for Input, Set Output, Time Delay, MessageBox, XY Motion, Rotary Motion, Linear Motion, Serial Communication, Run Application, Alignment Tool, Laser Control
• Interfaces with intelligent motion controllers for multiple motion axis control
• Regional language support for: Chinese (Simplified), Chinese (Traditional), English (United States), French (France), German (Germany), Italian, Japanese, Korean, Spanish (Spain)
• Marker Library functionality is exposed in a COM Automation server interface (IAutomatic and ILec)
• Host Interface control via RS-232 or Ethernet

WinLase LAN contains all of the elements of a multi-element Job Editor, automation sequencing tool (simplified ladder logic), and password-protected Operator's Interface. Most procedures can be efficiently served entirely from within the program.

COM AUTOMATION SERVER LIBRARY
WinLase LAN exposes a COM Automation server, which offers external programs the ability to communicate with and control WinLase LAN. For detailed information on the COM Automation server interface, please refer to the document package WinLase COM Automation Server Interface Manual available separately from Lanmark Controls Inc.

HOST PROGRAMMING INTERFACE
The Host Programming Interface provides a remote program, written by the customer, the ability to take control of WinLase LAN. In addition, the Fieldbus interface provides a means for controlling WinLase LAN, and reading status back from WinLase LAN to the Master controller.
SOFTWARE TOOLS

TCP/IP TEST CLIENT
WinLase LAN has a built-in server, ready to respond to requests for information from other programs over an Ethernet network. The TCP/IP Test Client is a utility program, which allows simple testing and debugging of the server interface from the same computer or from a remote computer.

LEC REMOTE ADMIN TOOL
The LEC Remote Admin Tool is a utility program which allows communication directly with an LEC-1 control card. Please refer to the LEC-1 documentation regarding the use of the Remote API.

TECHNICAL SUPPORT
If you are experiencing problems using WinLase LAN and you need help, you should:

1. Retry the action, carefully following the instructions given for that task in this manual.
2. Check the Troubleshooting section of this manual for troubleshooting information.
3. Try to reproduce the problem and document the exact scenario in which it occurs. If possible, save screen captures of all error/event messages.
4. Try to determine the nature of the problem. By eliminating variables, the problem can be narrowed down. If it appears to be hardware problems, check the documentation that came with your hardware for maintenance or hardware-related issues. Contact your hardware representative if necessary.

ABOUT THIS MANUAL
The WinLase LAN User's Manual contains detailed information about the WinLase LAN tools and commands. The manual is intended for use as a reference tool in everyday work with the WinLase LAN software Suite. This manual assumes a working knowledge of computers and their operating conventions, including how to use a mouse and standard menus and commands. To review these techniques, see the documentation that came with the computer system.
MANUFACTURER

Lanmark Controls Inc.
1740 Massachusetts Avenue
Boxborough, MA 01719 USA
http://www.lanmarkcontrols.com
## Revision History

<table>
<thead>
<tr>
<th>Revision</th>
<th>Date</th>
<th>Changes from previous revision</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>11/04/09</td>
<td>Original release</td>
</tr>
<tr>
<td>1.1</td>
<td>12/20/09</td>
<td>Corrections throughout</td>
</tr>
<tr>
<td>1.2</td>
<td>02/04/10</td>
<td>Added details on Mark on the Fly when using Run Job Remote tool</td>
</tr>
<tr>
<td>1.3</td>
<td>04/05/10</td>
<td>Added %i Custom String specifier, typo corrections</td>
</tr>
<tr>
<td>1.4</td>
<td>06/18/10</td>
<td>Added %F Custom String specifier</td>
</tr>
<tr>
<td>1.5</td>
<td>08/12/10</td>
<td>Added new configuration file feature changes. Added details on manually entered calibration data.</td>
</tr>
</tbody>
</table>
GETTING STARTED

Before you begin working with WinLase LAN, take a few moments to review installation tips, how to get help, and safety considerations.

SOFTWARE INSTALLATION

This section gives the system requirements and steps needed to install WinLase LAN.

SYSTEM REQUIREMENTS

The following hardware is required:

• Intel Pentium Computers running Windows XP Professional with Service Pack 3 or higher or Windows 7 Professional.
• DVD and/or CD-ROM drive for software installation.
• 128 MB RAM in addition to the memory required by other applications. A total of 512 MB or more is recommended.
• 50 MB of local disk space available

HOW THE OPERATING SYSTEM DICTATES SECURITY SETTINGS

• When installing the software, an account with Administrative privileges is required.
• In order to make any changes to configurations such as laser calibration, lens calibration, etc., the same account that installed the software must be logged on.
• Users with logon privileges less that Administrative will not be allowed to make configuration changes. When attempting to make changes, the following message box will be displayed:

![Windows XP Security]

This function requires local Administrator permissions. Consult your Systems Administrator for details.

OK
GETTING STARTED
Software Installation

INSTALLING THE SOFTWARE

To install WinLase LAN

1. Do not plug the Hardlock into a USB port at this time.
2. Power up the computer and log on as an Administrator. The logon account must have administrator rights to install the software.
3. Insert the WinLase LAN Installation CD in the CD-ROM or DVD drive.
4. The installation program will start automatically.
5. Follow the instructions on the screen to complete the installation.
HASP KEY (DONGLE) INSTALLATION

WinLase LAN requires the included HASP (dongle). A HASP is a security device attached to the computer's USB port.

| NOTE | Some features of WinLase LAN may not be available if a HASP key is not installed. |

To install the USB HASP version

- Plug the HASP device into an available USB port after completing the software installation procedure.

If starting WinLase LAN from the Windows Startup Folder

- If starting WinLase LAN from the Startup folder, changes must be made to the HASP driver configuration, to insure the HASP device is enabled before WinLase LAN starts. These changes are made in the Windows Registry.

| WARNING | You must have Administrator privileges to modify the Registry. Exercise extreme caution when making changes in the Registry, as incorrect settings could cause Windows to become unstable. |

1. Open the Registry Editor. If using Windows XP, click the Start button, then click Run. Type regedit in the Open box and click OK. If using Windows 7, click the Start button, and type regedit in the search box then press the Enter key.
2. Browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services
3. For the HASP, select the hasplms key in the left pane of the Registry editor. For a Hardlock, select the hardlock key in the left pane. The settings for the key will appear in the right pane.
4. Right-click the Start value in the right pane and select Modify.
5. In the Value data field, enter 0 (zero) and click OK.
6. Close the Registry Editor.
SAFETY CONSIDERATIONS

It is important to observe laser safety while working with any laser product. Anyone who may come into contact with lasers or laser systems while they are operating must be aware of the warnings provided in this chapter and throughout the document. In addition, the system operator must be familiar with all cautions and notes throughout this manual.

NOTE
- This safety information is provided as a reference to the user. Please consult your Laser System User documentation for details on the safety requirements appropriate for your particular laser system.

DANGER
- Never stare into the beam of a laser or laser system, even if wearing protective eye wear. Severe injury may result to personnel from failure to observe this safety precaution.

INTRODUCTION

Individuals, who maintain, troubleshoot, or otherwise service a laser system must comply with all applicable regulations associated with laser operation and maintenance to ensure their own safety and that of others. This chapter introduces government safety policies and regulations. Specific information regarding these policies and regulations can be obtained by contacting your plant safety representative and by reading the references cited at the end of this section.

WARNING
- Severe injury to personnel or damage to equipment may result from failure to observe the most common safety precautions.

The hazards associated with laser operation include both lethal high voltage and those of potential severe eye or skin damage from exposure to the invisible radiation from a direct or reflected infrared laser beam. To minimize these hazards, personnel should exercise caution at all times when operating, maintaining or troubleshooting the system.

SAFETY POLICIES AND REGULATIONS

Local/municipal, state/provincial, and federal/national governments legislate safety policies for laser operation. Government policies and regulations for the safe operation of lasers take priority over plant and any general guidelines presented. Refer to your plant safety representative for specific government policies and regulations that apply to safe laser system operation at your site. In the United States of America, the Center for Devices and Radiological Health (CDRH) verifies compliance with Federal standards.
LASER HAZARDS

**WARNING**
- All maintenance/service actions on a laser or laser system must be performed within the safety guidelines discussed in this chapter on System Safety, and following the Control Measures listed in ANSI Z136.1-1993, American National Standard for the Safe Use of Lasers. Laser safety eye wear, with a minimum optical density (OD) 0.7 for the appropriate wavelength, must be worn when a laser or laser system is energized. **UNDER NO CIRCUMSTANCES SHOULD YOU ALLOW YOURSELF TO BE EXPOSED TO A DIRECT LASER BEAM.**

HAZARD ZONES AND OPTICAL BEAM PATH

**WARNING**
- The beam produced by most industrial lasers is invisible. To protect operators from the effects of the laser emissions, the operator must be aware of the hazard zones of the laser, the potential for severe eye or skin damage, and the electrical hazards associated with the equipment.

EYE DAMAGE

Corneal or retinal burns (or both), depending upon laser wavelength, are possible from direct or indirect exposure to a laser beam. Because most industrial laser beams are not visible to the naked eye, it is possible to unknowingly be exposed to the laser light. For this reason, safety eye wear must always be worn when operating the system as a Class IV laser or when working on the laser with the laser cover removed. For details about safety eye wear, see Laser Safety Eye wear.

**NOTE**
- Failure to use the specified safety eye wear can result in burns to the cornea and retina, most likely resulting in loss or impairment of eyesight

**DANGER**
- Never stare into the beam of a laser or laser system, even if wearing protective safety eye wear. Severe injury may result to personnel from failure to observe this safety precaution.

SKIN BURNS

Skin burns are possible from direct contact with high levels of optical radiation from laser beams. Skin burns are also possible from acute exposure to high levels of indirect optical radiation. To prevent skin damage, a Class I enclosure, laser cover, and beam tubes (for more information, see Section 2.3.4.2 Beam Tubes) should be in place when operating a laser or laser system.
GETTING STARTED
Safety Considerations

DEVICES TO REDUCE LASER HAZARD RISKS
To reduce the risks of potential hazards of the laser, the following safety devices should be used as directed.

LASER SAFETY EYE WEAR
Laser safety eye wear with a minimum optical density (OD) of 7 for light at the appropriate wavelength must be worn by everyone in the area whenever the laser is operational.

BEAM TUBES
Beam tubes (or rubber bellows) placed in the laser or laser system between the mirrors, apertures, and other laser components:
• reduce the eye hazard if the laser or laser system cover were to be removed
• limit direct access to the raw laser beam, and
• protect optical surfaces from dust and contamination.

FURTHER READING
For more information on laser safety issues, consult the following sources:
Laser Safety Guide and other safety publications, Laser Institute of America
12424 Research Parkway, Suite 125, Orlando, FL 32826
Tel. 1-800-34LASER or (407) 380-1553. FAX (407) 380-5588

American National Standard for the Safe Use of Lasers,

Laser Technology and Safety Training Aids, Rockwell Laser Industries.
Tel. (513) 271-1568.
QUICK START GUIDE

Follow these steps to quickly get your WinLase LAN software and your LEC-1 controller card up and running:

- Become familiar with the WinLase LAN user interface. See “User Interface”.
- Determine the IP addressing scheme to use. See “Connectivity Options” on page 4-1.
- Connect the cables between the PC and the LEC-1
- Establish a network connection with the LEC-1 device from WinLase LAN. See “Making a Connection” on page 4-6.
- Configure the LEC-1 with the appropriate laser and lens settings. See “Choosing Laser, Lens and Motion Settings” on page 4-13.
- Add a system entity to a job. See “Adding a System Entity” on page 5-16.
- Assign the job to the LEC-1 device. See “Assigning Jobs to an LEC-1 device” on page 5-11.
- Mark a sample in streaming mode by using the QuickMark feature. See “Using the QuickMark Feature” on page 7-4.

NOTE

- Some features of WinLase LAN may not be available if a Hardlock key is not installed.
SELECTING THE DISPLAY LANGUAGE

WinLase LAN can be configured to use any one of the provided local display languages. Currently, these languages are: Chinese (Simplified), Chinese (Traditional), English (United States), French (France), German (Germany), Italian, Japanese, Korean, and Spanish (Spain). Most of the Asian languages will not be available unless the version of Windows supports that language, or has been specially configured. WinLase LAN. After installing WinLase LAN, the default language is English (United States).

To change the Default Language

1. From the Main menu, select System > Preferences.
2. Click on Languages tab. The Languages page appears.
3. Select the desired language that will be used to display text throughout WinLase LAN.
4. Click the Set as Default button. The Restart Application window displays.
5. Click the OK button.
6 Close WinLase LAN and then restart to apply the changes.

Local language display
USER INTERFACE

There are three interfaces available in which to interact with the software:

- The Job Editor Workspace, where all editing and full controls are available to the Job programmer.
- The Operator interface, a limited interface, which only allows loading and running of Jobs. Job editing is not allowed.
- The Touch screen interface, a specialized interface with large buttons and text boxes, designed for use with touch screens. This interface can be used with mouse input as well.

JOB EDITOR WORKSPACE

When WinLase LAN is started for the first time, the Job Editor Workspace is displayed by default. The Job Editor Workspace provides all editing functions and the full control set. Every function provided in the Job Editor Workspace can also be password protected by using the Permissions feature. See “Security Settings”. In the Job Editor Workspace, the window within the WinLase LAN program represents the physical marking field which is referred to as the Page size, which can be customized in the Job settings. See “Customizing the Page Size” on page 5-2.

To switch to the Job Editor Workspace

1. From the Main menu, select System > Security > User Access. The Access Levels window appears.
2 Click the All editing functions radio button.

The Job Editor Workspace
- **Title Bar**
- **Main Menu**
- **Toolbars**
- **Laser System Viewer**
- **Rulers**
- **Work Area**
- **Object Manager**
- **Status Bar**
- **Profile Manager**
- **Motion Manager**
SETTING THE UNITS OF MEASURE

All marking objects placed in the marking field have their dimensions and positions specified internally in bits. See “Coordinate System Conventions” on page 5-1. To display an object’s position and size in real world dimensions such as millimeters, WinLase LAN needs to use a scale factor to convert from bits into millimeters. This scale factor is provided by the Lens Correction file. Different Lens Correction files have different scale factors. As a result, the physical size and position of an object in real world dimensions will change when the Lens Correction file is changed, although their position and size in bits will not.

To change the Units of Measure

1. From the Main menu, select View. The View menu appears.

2. The current units are indicated with a dot to the left of the units. Select the desired units.
To change the Units display accuracy

1. From the Main menu, select System > Preferences.
2. Click the Workspace tab. The Workspace page appears.

The Workspace settings page

- A Select the units used throughout the interface
- B Select the number of decimal places used when displaying inches
- C Select the number of decimal places used when displaying millimeters
- D Select the number of decimal places used when displaying degrees
- E Select the offset applied to an object when the keyboard nudge feature is used
**THE TOP TOOLBAR**

The Top Toolbar consists of shortcuts to often used functions, menus, and other tools used to edit a Job. Place the cursor on a tool in the Toolbar to display the function of that tool in a hint window. The Top Toolbar location is below the Main menu.

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Add a new job to the workspace" /></td>
<td>Add a new job to the workspace</td>
</tr>
<tr>
<td><img src="image" alt="Open a job file" /></td>
<td>Open a job file</td>
</tr>
<tr>
<td><img src="image" alt="Save the current job" /></td>
<td>Save the current job</td>
</tr>
<tr>
<td><img src="image" alt="Save the current job with a new name" /></td>
<td>Save the current job with a new name</td>
</tr>
<tr>
<td><img src="image" alt="Print the current job" /></td>
<td>Print the current job</td>
</tr>
<tr>
<td><img src="image" alt="Cut the current selection to the Clipboard" /></td>
<td>Cut the current selection to the Clipboard</td>
</tr>
<tr>
<td><img src="image" alt="Copy the current selection to the Clipboard" /></td>
<td>Copy the current selection to the Clipboard</td>
</tr>
<tr>
<td><img src="image" alt="Paste the current selection from the Clipboard" /></td>
<td>Paste the current selection from the Clipboard</td>
</tr>
<tr>
<td><img src="image" alt="Delete the current selection" /></td>
<td>Delete the current selection</td>
</tr>
<tr>
<td><img src="image" alt="Undo the last action" /></td>
<td>Undo the last action</td>
</tr>
<tr>
<td><img src="image" alt="Import a file" /></td>
<td>Import a file</td>
</tr>
<tr>
<td><img src="image" alt="Export a graphic image to a PLT or WLO file" /></td>
<td>Export a graphic image to a PLT or WLO file</td>
</tr>
<tr>
<td><img src="image" alt="Minimize laser power" /></td>
<td>Minimize laser power</td>
</tr>
<tr>
<td><img src="image" alt="Control Guide laser" /></td>
<td>Control Guide laser</td>
</tr>
<tr>
<td><img src="image" alt="Open QuickMark window" /></td>
<td>Open QuickMark window</td>
</tr>
<tr>
<td><img src="image" alt="Open Run Process window" /></td>
<td>Open Run Process window</td>
</tr>
</tbody>
</table>
THE LEFT TOOLBAR

The Left Toolbar consists of shortcuts to add objects to the job and often used drawing functions. Place the cursor on a tool in the Toolbar to display the function of that tool in a hint window. The Left Toolbar location is down the left side of the screen.

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Open Globals toolbox" /></td>
<td>Open Globals toolbox</td>
</tr>
<tr>
<td><img src="image" alt="Bold" /></td>
<td>Apply Bold attribute to the selected text</td>
</tr>
<tr>
<td><img src="image" alt="Italics" /></td>
<td>Apply Italics attribute to the selected text</td>
</tr>
<tr>
<td><img src="image" alt="Left justify" /></td>
<td>Left justify the selected paragraph text</td>
</tr>
<tr>
<td><img src="image" alt="Center justify" /></td>
<td>Center justify the selected paragraph text</td>
</tr>
<tr>
<td><img src="image" alt="Right justify" /></td>
<td>Right justify the selected paragraph text</td>
</tr>
<tr>
<td><img src="image" alt="Change user access level" /></td>
<td>Change user access level</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Arrow pointer" /></td>
<td>Arrow pointer</td>
</tr>
<tr>
<td><img src="image" alt="Zoom in tool" /></td>
<td>Zoom in tool</td>
</tr>
<tr>
<td><img src="image" alt="Zoom out tool" /></td>
<td>Zoom out tool</td>
</tr>
<tr>
<td><img src="image" alt="Show full workspace" /></td>
<td>Show full workspace</td>
</tr>
<tr>
<td><img src="image" alt="New Line" /></td>
<td>New Line</td>
</tr>
<tr>
<td><img src="image" alt="New Rectangle" /></td>
<td>New Rectangle</td>
</tr>
<tr>
<td><img src="image" alt="New Rounded Rectangle" /></td>
<td>New Rounded Rectangle</td>
</tr>
<tr>
<td><img src="image" alt="New Polygon" /></td>
<td>New Polygon</td>
</tr>
<tr>
<td>Button</td>
<td>Function</td>
</tr>
<tr>
<td>--------------</td>
<td>---------------------------</td>
</tr>
<tr>
<td></td>
<td>New Text</td>
</tr>
<tr>
<td></td>
<td>New Barcode</td>
</tr>
<tr>
<td></td>
<td>New Automation</td>
</tr>
<tr>
<td></td>
<td>New Point array</td>
</tr>
<tr>
<td></td>
<td>Show Guidelines</td>
</tr>
<tr>
<td></td>
<td>Snap to Guidelines</td>
</tr>
<tr>
<td></td>
<td>Show Grid</td>
</tr>
<tr>
<td></td>
<td>Snap to Grid</td>
</tr>
<tr>
<td></td>
<td>Open Alignment tool</td>
</tr>
<tr>
<td></td>
<td>Open Dimension tool</td>
</tr>
</tbody>
</table>
DISPLAYING THE RULERS
The Rulers display on the top and left sides of the work area, and visually indicate the physical size of the marking area. Change the ruler settings to Millimeters, Inches, or Bits by selecting the Display Units of Measure. See “Setting the Units of Measure”. By default, the rulers are displayed.

To display or hide the Rulers
- Select View > Rulers. The rulers appear or disappear around the work area.

CUSTOMIZING THE TOOLS MENU ITEM
WinLase LAN provides the ability to customize a special Tools menu by adding menu items that start external programs.

To add a program to the Tools menu
1. From the Main menu, select Tools > Configure Tools. The Configure Tools window appears.

The Configure Tools window
A  Displays the list of available configured programs.
B  Opens the Add tool window to add a new program to the list.
C  Removes a program from the list.
D  Opens the Edit tool window.
E  Moves the programs up or down in the Tools list with the Arrow buttons.
Click the Add button. The Edit Tool window appears.

The Edit Tool window
A. The name of the program as displayed in the Tools menu.
B. The path to the executable file that will run when the tool item is selected in the Tools menu.
C. Optional command line switch parameters. Consult the documentation for the program to be run to see if there are any parameters required.
D. Opens the Browse dialog to locate the executable file to run.

To edit an existing Tool
1. From the main menu, select Tools > Configure Tools. The Configure Tools window appears.

2. In the Tools list, select the tool to edit and click the Edit button. The Edit Tool window appears.

To delete a Tool
1. From the main menu, select Tools > Configure Tools. The Configure Tools window appears.

2. In the Tools list, select the tool to delete and click the Delete button. The tool is removed from the list.
**THE OPEN JOBS TAB**
The open Job Tab control provides a visual indication of the currently loaded Jobs and the Active Job.

![The open Jobs tab control, showing the Active Job is Job1.wlj.](image)

**LASER SYSTEM VIEWER**
The Laser System Viewer shows the local area network, and any LEC-1 devices detected on that network. Open jobs are displayed in the Viewer as either assigned to the Offline configuration, or assigned to an LEC-1 device.

![The Laser System Viewer](image)

- A The Local Area Network connection
- B A detected LEC-1 device
- C Jobs assigned to an LEC-1 device
- D Close button

**To display or hide the Laser System Viewer**

1. Select View > Laser System Viewer. The Laser System Viewer appears or disappears at the left side of the work area.

2. Clicking on the Close button in the upper right corner of the Laser System Viewer will also close the Laser System Viewer.
OBJECT MANAGER

The Object Manager displays the Job Entities that are contained in the current job. The objects are listed in the order in which they will mark/process. If more than one object appears in the Object list, the up and down blue arrows (at the bottom of the Object Panel) become enabled. Use these buttons to move objects up and down relative to each other in the list. The number of objects within a Job is displayed to the right of the Objects title. A particular object can be selected by entering the object Index in the Index box. Use the Mark object and Mark fill check boxes to toggle the outline marking and fill marking features. Objects can also be selected and grouped from the Object list. See “Managing Job Entities” on page 5-16 for more details.

The Object Manager
A Object title with number of objects in parentheses
B Objects contained in the job (three shown)
C Index of the selected object within the job
D Select this option to enable marking the outline of the object
E Select this option to mark fill (only available if fill has been enabled. See “Fill (Hatching)” on page 6-7)
F Close button
G Up / down arrows used to move an object within the list
To display or hide the Object Manager

1. Select View > Object Manager. The Object Manager appears or disappears at the left side of the work area.

2. Clicking on the Close button in the upper right corner of the Object Manager will also close the Object Manager.

PROFILES PANEL

The Profile Manager displays a hierarchical view of the Profiles the user has saved. These Profiles can be organized into groups of folders, and applied to marking objects in the Job. Profiles can be added to objects or groups of objects from within the Profile Manager by right clicking on the Profile and selecting the desired item from the popup context menu. Profiles can be viewed and edited by double clicking on the specific Profile. See “Profiles” on page 6-9 for more information.

The Profiles Panel

A. Click to add a profile to the Profile library
B. Click to organize the profiles in the library
C. A profile folder
D. Individual profiles contained in a folder
E. The Default profile, which is applied to all new objects when they are first created. See “The Default Profile” on page 5-28.
F. Close button

To display the Profile Manager

1. Select View > Profile Manager. The Profile Manager appears or disappears at the right side of the Work area.
2 Clicking on the Close button in the upper right corner of the Profile Manager will also close the Profile Manager.

**MOTION MANAGER**
The Motion Manager provides a tool for direct control of installed motion devices. See “Using the Motion Manager” on page 5-42 for more information.

To display or hide the Motion Manager:
1. Select View > Motor Manager. The Motion Manager appears or disappears at the right side of the work area.
2. Clicking on the Close button in the upper right corner of the Motion Manager will also close the Motion Manager.
**OPERATOR INTERFACE**

The Operator Interface is intended for use in applications where the operator is restricted from making any changes to the Job. The Operator Interface provides the minimum controls necessary to execute pre-saved Jobs, and to close the application. When configured in the User Access settings, the Operator Interface becomes available.

**To switch to Operator Interface mode**

1. From the main menu, select System > Security > User Access. The Access Levels window appears.
2. Click the Operator interface only radio button.
3. Click the OK button. The screen switches to Operator Interface mode.

**The Operator Interface**

- **A** Limited Main menu
- **B** Limited Toolbar

**To switch to the Job Editor Workspace**

1. From the main menu, select System > Security > User Access. The Access Levels window appears.
2. Select the All editing functions radio button, then click OK.
TOUCHSCREEN INTERFACE
The Touch Screen Interface is intended for use in applications where the operator is restricted from making any changes to the Job. The Touch Screen Interface provides the minimum controls necessary to execute pre-saved Jobs, and close the application. The design of the Touch Screen Interface facilitates using a Touch Screen display panel, although a mouse driven interface is also possible. When configured in the User Access settings, the Touch Screen Interface becomes available.

NOTE • This feature is available only if a Hardlock key is installed.

To switch to Touch Screen Interface mode
1 From the Main menu, select System > Security > User Access. The Access Levels window appears.
2 Click the Touch screen interface radio button.
3 Click the OK button. The screen switches to the Touch Screen mode

The Touchscreen Interface
A Loads a Job from the Touchscreen Job folder location. See “To edit the Default Open and Save behavior” on page 5-10. Jobs are loaded by clicking on the drop down list and selecting an available Job.
B  Starts execution of the loaded Job. Clicking this button is equivalent to selecting Job > Run from the main menu, and then clicking the Go button in the Run Process dialog.

C  Displays the objects within the Job in relation to the mark field.

D  Immediately stops execution of the running Job

E  Displays the status of Interlocks 1 through 4. These interlock panels can be customized to display customized strings to represent each interlock port. See "To configure the Interlocks" on page 4-36.

F  Shut down Windows directly with this button.

G  Click this button to see a secondary menu, which has selections for Global settings, and to return to the full editing interface.

H  Display an on-screen keyboard
To switch to the Job Editor Workspace

1. Click the OPTIONS button. The OPTIONS window appears.

![Options window]

2. Click the FULL ACCESS button. The full access interface is restored. If a password is set, the system will prompt for the password.

![User Password required]

3. Enter the password and click OK.

4. The full access interface is restored.
SECURITY SETTINGS

To control access to user interface elements as well as Job editing functions, WinLase Professional has fully integrated password protection available. System Security involves working with:

- Permissions
- Login levels
- Passwords
- User interface access levels

WORKING WITH PERMISSIONS

WinLase LAN offers four levels of permissions:

- Administrator
- Technician
- User
- No password required

Every individual function within WinLase LAN can be assigned a Permission Level and each Permission Level can be assigned a unique password. These assignments are done through an initialization file.
WORKING WITH THE PERMISSIONS FILE

WinLase LAN uses an external file to configure the Permission levels for all protected tasks. This file can be found in the `\marker\bin` folder. The file is named `permissions.ini`. The following is a partial representation of the file loaded into notepad for editing.

```
permissions.ini · Notepad
File Edit Format View Help
SYSTEM_PREFERENCES=0
SWITCH_TO_EDIT_MODE=1
SWITCH_TO_OPERATIONAL_MODE=1
SWITCH_TO_LOGOVERRIDE_MODE=0
LASER_DIAGNOSTICS=0
SCRIPT_GLOBALS=0
CHANGE_SPELLING_OPTIONS=0
LASERFORM_CALIBRATION=0
SCANHEAD_CALIBRATION=0
ADD_PROFILE=0
ORGANIZE_PROFILES=0
ASSIGN_TO_MODE=0
JOB_SETTINGS=0
LOCATE_DIAGNOSTICS=0
SELECT_TOOL=0
MANAGE_CORRECTIONS=0
RUN_FROM_HOST=0
SYSTEM_BACKUP=0
SYSTEM_RESTORE=0
CONNECT_TO_MACHINE=0
DISCONNECT_NODE=0
DELETE_OBJECT=0
SAVE_FILE=0
SAVE_FILE_AS=0
PRINT_JOB=0
COPY_OBJECT=0
COPY_OBJECT_ID=0
PASTE_OBJECT=0
IMPORT_GRAPHIC=0
EXPORT_GRAPHIC=0
OFFICE_BASIC=0
RUN_XBIN=0
FONT_STYLES_CHANGE=0
MOVE_OBJECT_IN_LIST=0
```

The `permissions.ini` file

Each line in the file represents a specific task description followed by the Permission Level to assign this task.

The **Permission Levels** are defined as follows:

- **0** = No password required
- **1** = User password required
- **2** = Technician password required
- **3** = Administrator password required

For example, in the first line from the example above, `SYSTEM_PREFERENCES=2`, in order to make System Preference changes, the user has to know the Technician password to complete the task.
To change Permission Levels

1 Locate and open the permissions.ini file in a text editor such as notepad.
2 Change the assigned permission after the equals (=) sign using the Permission Levels defined above.
3 WARNING: Do not delete or add lines to the file. ONLY make a change to the Permission Level after the equals (=) sign. If the file is not in the correct format, WinLase Professional will ignore ALL Permission Levels and use No Password Required.

USING THE LOGIN LEVEL

WinLase LAN supports the concept of a current Login Level. The Login Level allows a user to set the current permission level within WinLase LAN, so that any tasks that require the current Login Level or below will be granted permission to execute the task without prompting for a password. Permissions are granted using the following rules:

• When the user attempts to execute a protected task, a permission check is performed
• The Permission Level for that particular task is determined from the initialization file.
• If the Permission Level is less than or equal to the current Login Level, permission is granted without prompting for a password.
• If the task requires a higher Permission Level than the current Login Level, a password challenge for the higher Permission Level is displayed. If there is no password set for the higher Permission Level, permission is granted without prompting for a password.

To change the current Login Level

1 From the menu bar, select System > Security > Login Level. The Login Level menu appears.
2 The current Login Level is checked.
3 Select the new Login. If necessary, the password challenge window appears.

4 Enter the correct password and click OK. The current Login Level has been changed.

**CHANGING AND DELETING PASSWORDS**

There are three unique passwords that correspond to the three Permission Levels within WinLase LAN.

**To change a password**

1. From the menu bar, select System > Security > Change Password. The Change Password menu appears.
2. Select the desired Permission Level password to set. The Change Password window appears.
3. From the New password field, type in the new password.
4. From the Confirm password field, type in the same password as typed for the new password.
5. Click OK. The Change Password window closes, and a password for the selected Permission Level is now enabled.
To delete a password

1. From the menu bar, select System > Security > Change Password. The Change Password menu appears.
2. Select the desired Permission Level password to delete. The Change Password window appears.
3. From the New password field, delete the password from the edit box so that it is blank.
4. Click OK. The password is deleted, and password protection is disabled for the selected Permission Level.

ASSIGNING USER ACCESS

To control access to user interface elements as well as Job editing functions during the current session, WinLase LAN supports the concept of Access modes. Note that Access modes override specific permission levels on tasks. For example, operator mode does not allow editing of a job, no matter what the permission levels are for those job editing tasks. The following Access modes are available:

- **Full access** where all operations are available to the User.
- **Operator interface only** is for Users that are only allowed to load Jobs, run Jobs, and close the application.
- **Touch screen** is a large button format screen is displayed and is ideal for use with a touch screen, although a mouse can be used with this interface as well.

To assign user access

1. From the menu bar, select System > Security > User Access. The Access Levels window displays the access levels available.
2. Enable the desired user access level. By default, the user has all editing functions available.
3. Click OK to close the window.
CONTROLLING ACCESS LEVEL AT STARTUP
Using the Startup Options menu item, you can control what Access Level WinLase LAN will initialize in. This Access Level is not dependent on the current access level when WinLase LAN is closed. The following Startup Access modes are available:

- **Full access** where all operations are available to the User
- **Operator interface only** is for Users that are only allowed to load Jobs, run Jobs, and close the application
- **Touch screen** is a large button format screen is displayed and is ideal for use with a touch screen, although a mouse can be used with this interface as well

To control the Startup Access mode

1. From the menu bar, select System > Security > Startup Options. The Startup Options window displays the available options.

2. Select the desired startup access level.

3. Click OK to close the window.

The next time WinLase LAN starts, it will use the selected access mode.
WORKING WITH THE LEC-1

The LEC-1, in conjunction with WinLase LAN, controls a laser system's galvanometer motors, accurately positioning deflection mirrors affixed to these motors in synchronization with laser control signals. The motion sequence, the operation speed/s, the laser power used, and any synchronization with external ancillary equipment is determined by marking jobs created and formatted by WinLase LAN. This chapter covers the basics of using an LEC-1 controller card, and includes:

• Connectivity options, which configure the WinLase LAN software and an LEC-1 controller card so they may communicate with each other

• A section on Laser, Lens and Motion settings, which are configuration files that contain the necessary information for the LEC-1 to interface with lasers, scan heads and motion systems

• A section on configuring the LEC-1 for Stand-Alone Mode operation, where jobs created and edited in WinLase LAN are saved on the LEC-1. At run-time these jobs can be executed directly on the LEC-1 without using WinLase LAN.

CONNECTIVITY OPTIONS

In order for WinLase LAN to correctly detect and connect to available LEC-1 devices, WinLase LAN, the local PC, and the LEC-1 device must be configured correctly. Also, a valid hardlock license key must be installed on the local PC. If no hardlock key is detected, the Laser System Viewer will be disabled, as shown in the following screenshot.

Detection disabled - no Hardlock key detected

The LEC-1 is designed to constantly broadcast its Device name and MAC address on the connected network. That network could be a Local Area Network, or a PC directly connected to the LEC-1 controller card. When WinLase LAN detects a broadcast from an
LEC-1 controller card, it displays the available LEC-1, as an icon with *Device name (MAC address)*, in the Laser System Viewer.

Things to consider when configuring for communication:

- Assigning a unique *Device name* to each LEC-1 on a local area network to make it easier to identify LEC-1 device in the Laser System Viewer.
- The *IP Addressing scheme*, which determines whether the connected resources will have fixed IP addresses, or be assigned an IP address dynamically (DHCP).
- Connecting the PC to the LEC-1 with a *Direct connection*.
- Connecting the PC and the LEC-1 to a *Local Area Network*.
- Selecting the *default Network Adapter* in WinLase LAN.

**DEVICE NAME**

The device name is displayed throughout WinLase LAN to represent an LEC-1 controller card on the network. The MAC address of the device is appended to the device name to create a unique identifier (two devices could have the same device name).

**To change the Device name**

- There must be an active connection to an LEC-1 device. Renaming an LEC-1 will require the LEC-1 to be restarted.
- In the Laser System viewer, right-click on a connected LEC-1 controller card and select *Settings*. 

An available LEC-1 device
2 Click the Network tab.

3 In the Name field, enter the desired device name and click OK.

4 The Restart dialog is displayed. Click Yes to continue.

- The new device name appears in the Laser System Viewer.
**Connectivity Options**

**IP ADDRESSING SCHEMES**

The LEC-1 controller card has the option of configuring a static IP address, or contacting a DHCP server to get an IP address when the LEC-1 controller card powers up.

- **Fixed IP Address Mode**: care must be taken to use unique IP addresses. This is usually not an issue when directly connecting the PC to an LEC-1, but when connecting to a LAN, there may be many devices on the same network, and all must have a unique IP address.

- **Dynamic (DHCP) IP Address Mode**: is the most common approach, and insures no two resources on the network have the same IP address. This mode will create a lengthy power up sequence however, if the PC and the LEC-1 controller card are directly connected.

**To make changes to the LEC-1 IP address settings**

1. In the Laser System viewer, right-click on a connected LEC-1 device and select Settings.
2. Click the Network Tab.

   ![The IP address settings page](image)

**WARNING**

- Select the IP address carefully, as an incorrect address may render the LEC-1 unavailable without changing the PC IP settings.
A Select the IP Address Mode

- Address Type: Manual - The LEC-1 can be configured with a fixed (static) IP address
- Address Type: Assigned by DHCP - The LEC-1 can be configured to request an IP address from a DHCP server.

B The IP address to use when in Manual (Static) mode

**CONFIGURING A DIRECT CONNECTION**

The direct connection is the most simple - a CAT5 cable is used to connect the Ethernet connector on the PC with the Ethernet input on the LEC-1. The behavior of a direct connection depends on the IP addressing scheme.

<table>
<thead>
<tr>
<th>When configured for DHCP...</th>
<th>Since there is no DHCP server available to assign an IP address, both the PC and the LEC-1 will wait up to 90 seconds, then assign themselves an Automatic Private Network address in the range 169.254.xxx.xxx</th>
</tr>
</thead>
<tbody>
<tr>
<td>When configured for Static IP Addressing...</td>
<td>The LEC-1 will immediately be available for connection to WinLase LAN</td>
</tr>
</tbody>
</table>

**CONNECTING THROUGH A LOCAL AREA NETWORK**

When using a Local Area Network, both the PC and the LEC-1 is connected to the LAN.

<table>
<thead>
<tr>
<th>When configured for DHCP...</th>
<th>Both the PC and the LEC-1 will wait for an IP address from a local DHCP server. If no server exists on the network, or an IP address is not assigned, both devices will assign themselves an Automatic Private Network address in the range 169.254.xxx.xxx</th>
</tr>
</thead>
<tbody>
<tr>
<td>When configured for Static IP Addressing...</td>
<td>The LEC-1 will immediately be available for connection to WinLase LAN, provided there are no IP address conflicts on the Local Area Network</td>
</tr>
</tbody>
</table>

**SELECTING THE DEFAULT NETWORK ADAPTER**

WinLase LAN supports multiple network cards (NICs) installed in the local PC. Only one NIC can be used, however, to detect and connect with LEC-1 controllers cards.
To select the Default Network Adapter

1. From the Main menu, select Connections > Manage...
2. Click the Network adapters tab.
3. Select the appropriate network adapter from the list and click Set as Default.

MAKING A CONNECTION

Before WinLase LAN can interact with the LEC-1, a connection must be made to the device. Once one instance of WinLase LAN is connected to an LEC-1, other instances of WinLase LAN are prevented from connecting. In order for a connection to be made, both the PC and the LEC-1 device should be on the same subnet. If WinLase LAN detects that the PC and the LEC-1 device are on incompatible subnets, WinLase LAN has the ability to add a temporary IP address to the local PC to allow connection to the LEC-1 device. This feature can be configured to happen automatically. Once the PC is rebooted, this temporary IP address is deleted.
To automatically add an IP address to the PC when incompatible subnets are detected

1. From the Main menu, select Connections > Manage...
2. Click the Network adapters tab.
3. Select the “Add a new temporary IP address automatically on subnet mismatch” option to automatically add a compatible IP address to the default PC network adapter.

**CONNECTING MANUALLY**

To connect to an LEC-1 controller

1. In the Laser System Viewer, right-click on an available LEC-1 controller card and click “Connect”.

```
Laser System Viewer
Connect
Properties...
I/O Diagnostics...
```
If the PC and the LEC-1 are on different subnets, and the feature to automatically add a new IP address is disabled (see “To automatically add an IP address to the PC when incompatible subnets are detected”), the following message will appear:

If this dialog appears, click Yes to continue.

If there are no Automatic connections configured, the following dialog appears:

If you want WinLase LAN to automatically connect to the LEC-1 when it becomes available (see “Connecting automatically”), click Yes, otherwise click No.

When WinLase LAN connects to an LEC-1, configuration files are downloaded from the LEC-1 to the local PC. The Pending Connections Viewer shows the progress of this process.
When the connection process is complete, the LEC-1 controller card turns blue to indicate it is actively connected.
WORKING WITH THE LEC-1
Connectivity Options

CONNECTING AUTOMATICALLY
In single device installations, where there is only one LEC-1 based system available, it may be more convenient to configure WinLase LAN to connect automatically to the LEC-1 controller card.

To configure Automatic Connections
1. From the Main menu, select Connections > Manage...
2. Click the Laser Systems tab.

3. Select the device to automatically connect to from the Laser System name list and click the Add >>> button.
4. To remove an automatic connection, select it in the Automatic connections list and click the Remove button.
5. Select Yes to continue.

CLOSING AN ACTIVE CONNECTION

To close an active connection
• In the Laser System Viewer, right-click on the LEC-1 controller card that is currently connected and then click Disconnect.
UNDERSTANDING THE LEC-1 STATUS ICONS

WinLase LAN uses different icons in the Laser System viewer to indicate the status of an LEC-1 controller card.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Icon 1]</td>
<td>Connected to this instance of WinLase LAN</td>
</tr>
<tr>
<td>![Icon 2]</td>
<td>Available</td>
</tr>
<tr>
<td>![Icon 3]</td>
<td>Invalid Firmware or License</td>
</tr>
<tr>
<td>![Icon 4]</td>
<td>Connected to another client or in local mode</td>
</tr>
<tr>
<td>![Icon 5]</td>
<td>PC software is incompatible</td>
</tr>
<tr>
<td>![Icon 6]</td>
<td>Not available or not found</td>
</tr>
<tr>
<td>![Icon 7]</td>
<td>Busy or disconnecting</td>
</tr>
<tr>
<td>![Icon 8]</td>
<td>Connecting</td>
</tr>
<tr>
<td>![Icon 9]</td>
<td>Paused</td>
</tr>
<tr>
<td>![Icon 10]</td>
<td>Caching jobs</td>
</tr>
<tr>
<td>![Icon 11]</td>
<td>In Local I/O mode</td>
</tr>
</tbody>
</table>
CHECKING THE CONNECTION STATUS

The status of an LEC-1 can be checked at any time by hovering the mouse over the LEC-1 and waiting for a hint to appear.

To check the LEC-1 status

- In the Laser System viewer, place the mouse (hover) over an LEC-1
CHOOSING LASER, LENS AND MOTION SETTINGS

WinLase LAN supports two hardware configurations:

- The **Offline configuration mode**, which provides the necessary laser, lens and motion information to WinLase LAN when there is no connection to an LEC-1 controller.

- The **Active configuration mode**, in which WinLase LAN applies the current laser, lens and motion settings from the currently active LEC-1 controller.

UNDERSTANDING HOW WINLASE LAN USES LASER, LENS AND MOTION SETTINGS

The LEC-1 controller board can function as a stand-alone capable embedded controller, and so hardware settings and parameters specific to laser, lens and motion control are stored in configuration files in the LEC-1 flash memory. These files are copied to the LEC-1 flash memory when the user selects the appropriate configuration files in the WinLase LAN hardware manager.

During the Job editing process, information is needed from these configuration files in order to calculate and display properties such as speeds, distances and other related parameters in WinLase LAN.

When a connection is made to the LEC-1, these configuration files are downloaded onto the local PC for use by WinLase LAN. See “Making a Connection”. When a Job is assigned to the LEC-1 device (See Assigning a Job to an LEC-1 device), the Job uses the configuration files that were downloaded to the local PC. This allows any instance of WinLase LAN to connect to any LEC-1 and have all the information it needs for job editing. This is known as the **Active configuration mode**.

There are times, however, when an active connection to an LEC-1 controller is not possible, or desirable. For these situation, WinLase LAN has an **Offline configuration mode**.

**WARNING**

- When editing jobs in **Offline configuration mode**, make sure the laser, lens and motion profiles are the same as on the target LEC-1, or unexpected behavior will result.
To select an Offline Laser Driver file

1. From the Main menu, select System > Preferences.
2. Click on the Hardware tab. The Hardware page appears.

3. Open the Offline folder and select the Laser item under the Offline folder. The laser properties will update the properties panel.
4. Click the Change button. The Select Laser Driver window appears.
5. Select the desired Laser Configuration file from the list and click OK.
To copy a Laser Driver file from the PC to the LEC-1

- There must be an active connection to an LEC-1 device
- 1. From the Main menu, select System > Preferences.
- 2. Click on the Hardware tab. The Hardware page appears.
- 3. Locate the LEC-1 to assign the laser to in the tree view. Click on the laser name under this LEC-1. The laser properties will appear in the properties panel.
4 Click the Change button. The Select Laser Driver window appears.

5 From the drop down box, select Show Laser drivers in the PC library.

6 Select the desired Laser Driver file from the list. The currently active driver has (active) appended to the driver name.

7 To automatically set the laser driver used in the Offline Configuration to the new selection, check Also apply to Offline configuration.
To select a Laser Driver file already installed on the LEC-1

- There must be an active connection to an LEC-1 device
- From the Main menu, select System > Preferences.
- Click on the Hardware tab. The Hardware page appears.

3 Locate the LEC-1 to change in the tree view. Click on the laser name under this LEC-1. The laser properties will appear in the properties panel.

4 Click the Change button. The Select Laser Driver window appears.
5 From the drop down box, select *Show Laser Drivers installed on the Laser System*.  
6 Select the desired Laser Configuration file from the list and click OK.

To add a new Laser Driver file to WinLase LAN

* See “To add a new Laser Driver file” on page 9-1.

To select an Offline Lens Correction file

1 From the Main menu, select System > Preferences.  
2 Click on the Hardware tab. The Hardware page appears.

3 Open the Offline folder and select the Lens item under the Offline folder. The lens properties appear in the properties panel.
WORKING WITH THE LEC-1
Choosing Laser, Lens and Motion Settings

4. Click the Change button. The Select Correction File window appears.

![Select Correction File Window]

5. Select the new correction file.

To copy a Lens Correction file from the PC to the LEC-1

- There must be an active connection to an LEC-1 device
- From the Main menu, select System > Preferences.
- Click on the Hardware tab. The Hardware page appears.

![Hardware Page]
3 Locate the LEC-1 to copy the lens to in the tree view. Click on the lens name under this LEC-1. The lens properties appear in the properties panel.

4 Click the Change button. The Select Correction File window appears.

5 From the drop down box, select Show Correction Files in the PC library.

6 Select the new correction file.

7 To automatically set the correction file used in the Offline Configuration to the new selection, check Also apply to Offline configuration.
To select a Lens Correction file already installed on the LEC-1

1. There must be an active connection to an LEC-1 device
2. From the Main menu, select System > Preferences.
3. Click on the Hardware tab. The Hardware page appears.
4. Locate the LEC-1 in the tree view. Click on the lens name under this LEC-1. The lens properties appear in the properties panel.
5. Click the Change button. The Select Correction File window appears.
WORKING WITH THE LEC-1
Choosing Laser, Lens and Motion Settings

5 From the drop down box, select Show Correction Files installed on the Laser System.
6 Select the new correction file.
7 To automatically set the correction file used in the Offline Configuration to the new selection, check Also apply to Offline configuration.

To add a new Lens Correction file to WinLase LAN
• See “To create a new Lens Correction file using scan head design data” on page 8-4.

To select an Offline Motion Configuration file
1 From the Main menu, select System > Preferences.
2 Click on the Hardware tab. The Hardware page appears.

3 Open the Offline folder and select the Motion item under the Offline folder. The motion properties appear in the properties panel.
4 Click the Change button. The Select Motion Configuration window appears.

5 Select the new motion configuration from the list and click OK.
To copy a Motion Configuration file from the PC to the LEC-1

1. There must be an active connection to an LEC-1 device
2. From the Main menu, select System > Preferences.
3. Click on the Hardware tab. The Hardware page appears.
4. Locate the LEC-1 to copy the motion configuration to in the tree view. Click on the motion configuration under this LEC-1. The motion properties appear in the properties panel.
4 Click the Change button. The Select Motion Configuration window appears.

5 From the drop down box, select *Show Motion Configurations in the PC library.*

6 Select the new configuration file.

7 To automatically set the configuration file used in the Offline Configuration to the new selection, check *Also apply to Offline configuration.*
To select a Motion Configuration file already installed on the LEC-1

- There must be an active connection to an LEC-1 device
- From the Main menu, select System > Preferences.
- Click on the Hardware tab. The Hardware page appears.

3 Locate the LEC-1 in the tree view. Click on the motion configuration under this LEC-1. The motion properties appear in the properties panel.

4 Click the Change button. The Select Motion Configuration window appears.
5 From the drop down box, select *Show Motion Configurations installed on the Laser System*.

6 Select the new configuration file and click OK.

**To create a new Motion Configuration**

- See “To create a new Motion Configuration” on page 10-4.
CONTROLLING THE LEC-1 REMOTELY

The LEC-1 supports the ability to execute jobs without the need for a PC. This capability is referred to as Stand-Alone mode. For performance reasons, some features, such as Mark on the Fly, are only available in Stand-Alone mode. To configure Jobs and the LEC-1 for Stand-Alone operation, consider the following:

- Some mark object properties, and some job automation properties need to be correctly configured for use in Stand-Alone mode. See “Stand-Alone Job Considerations” on page 5-14 for more information.
- An LEC Binary job file must be saved in the LEC-1 flash, or on a connect USB flash drive. See “Saving Jobs” on page 5-5.
- If an LEC Binary Job file references an embedded Laser Font, that font must be in the Fonts folder of the LEC-1 device. See “Adding a new Laser font to WinLase LAN” on page 5-40 and “Managing Job Entities” on page 5-16 for more information.

WinLase LAN provides the following features to configure the LEC-1 for Stand-Alone mode operation:

- A file Browser, which explores the on-board flash and connected USB flash drives
- Settings for I/O Job Selection, which provides a means to load selected jobs and execute them with simple discrete I/O
- Settings for Mark on the Fly, which provides for marking on moving parts.
- An Interactive tool, which allows communication with an LEC-1 using the Remote API from within WinLase LAN. See “To use the Interactive tool”.
- A Run Job Remotely tool, which allows “remote control” of an LEC-1 running a Stand-Alone job from within WinLase LAN. See “Running Stand-Alone Jobs” on page 7-24.

RUNNING STAND-ALONE JOBS WITH WINLASE LAN

WinLase LAN provides the capability to interact with the LEC-1 and run Stand-Alone jobs from within the WinLase LAN user interface. See “Running Stand-Alone Jobs” on page 7-24.

MANAGING FILES ON THE LEC-1

WinLase LAN provides tools for browsing files that are stored on an LEC-1 or on a connected USB drive. These files can be of type:

- Lec Binary Job files, which have been saved to the LEC-1, and are used when the LEC-1 is executing in Stand-Alone mode
- Laser Font files, which are used by mark objects in Stand-Alone mode
To open the LEC-1 file browser

- There must be an active connection to an LEC-1 device
1. In the Laser System viewer, right-click on a connected LEC-1 device and select Explore...
2. From the Look in drop down, select Internal Flash memory or External USB stick.

The LEC-1 device Explorer
A. Select the location on the LEC-1 to explore
   - Internal flash memory - The integrated memory on the LEC-1 for storing jobs
   - External USB stick - Storage available on an installed USB stick
   - Fonts - The font library stored on internal flash memory
B. The amount of available storage on the current location
C. Files found in the current location
D. When copying jobs or fonts to the LEC-1, select this option to overwrite a file with the same name
E. Add a new file to the current location
F. Copy a file from the current location to a folder on the PC
G. Rename the selected file
H. Delete the selected file
I/O JOB SELECTION

It is possible to select and execute an available locally saved job by using I/O bit combinations. In order for the LEC-1 to respond to I/O in this manner, the board must be in I/O Job Selection mode. When in this mode, a maximum of eight user programmable I/O Selection inputs are used to select the pre-configured job. The actual inputs scanned by the LEC-1 depend on whether the optional Extended I/O module is installed. See “The Start Mark input is used to start the marking process.” for details. In order to enable I/O Job Selection, please note the following:

- The LEC-1 controller must be in I/O Job Selection Mode
- Jobs stored locally on the LEC-1 must be assigned to I/O Selection bit combinations.
- The appropriate I/O Selection inputs must be set to indicate which job to load/enable.
- The Job Select input must be used to trigger the loading/enabling of a job.
- After the Job Select input is triggered, the Ready output is used to signal that the job is loaded/enabled.
- The Start Mark input is used to start the marking process.

<table>
<thead>
<tr>
<th>I/O Selection bit mapping</th>
<th>Extended I/O option not installed</th>
<th>Extended I/O option installed</th>
</tr>
</thead>
<tbody>
<tr>
<td>00000001 (1)</td>
<td>User In 1</td>
<td>User In 5</td>
</tr>
<tr>
<td>00000010 (2)</td>
<td>User In 2</td>
<td>User In 6</td>
</tr>
<tr>
<td>00000100 (3)</td>
<td>User In 3</td>
<td>User In 7</td>
</tr>
<tr>
<td>00001000 (4)</td>
<td>User In 4</td>
<td>User In 8</td>
</tr>
<tr>
<td>00010000 (5)</td>
<td>N/A</td>
<td>User In 9</td>
</tr>
<tr>
<td>00100000 (6)</td>
<td>N/A</td>
<td>User In 10</td>
</tr>
<tr>
<td>01000000 (7)</td>
<td>N/A</td>
<td>User In 11</td>
</tr>
<tr>
<td>10000000 (8)</td>
<td>N/A</td>
<td>User In 12</td>
</tr>
</tbody>
</table>

Mapping Table
Controlling I/O Job Selection mode

1. In the Laser System Viewer, right-click on an available LEC-1 controller and click Settings. The Laser System Settings window appears.

2. **WARNING** - If the LEC-1 is already in I/O Job Selection mode, opening the Settings dialog will abort any job that is currently active. The following message is displayed to warn the user:

   - ![Warning Message]

3. Click the Job Selection tab. The Job Selection page appears.

   - ![Job Selection Page]

   **The Job Selection page**
   - **A** Select this option to enable or disable I/O Job Selection. When checked and after the OK button is pressed, the LEC-1 card will be immediately put into I/O Job Selection mode.
   - **B** Loading of jobs can be accomplished in one of two ways. (1) In cache mode, all the jobs in the Job assignment list are loaded either at boot time, or when the board is first placed in I/O Job Selection mode. Later, the Job Select bit is used to quickly switch between the previously loaded jobs. Caching the jobs in memory is preferable if fast switching times between jobs is desired. However,
the time to cache all the jobs in the job assignment list may be lengthy. If jobs are not cached, each job is loaded when the Job Select bit is set HIGH and the appropriate selection bits are set. This mode is desirable when the job files are very large, and would consume the local RAM if they were all loaded in memory at the same time. Because the job is loaded when the Job Select bit is set, the process controller must wait for the job to load before executing the job.

C Select the location of the jobs
- Internal flash memory - The integrated memory on the LEC-1 for storing jobs
- External USB stick - Storage available on an installed USB stick

D List of jobs available in the current location

E Insert the selected job at the top of the Job Assignment list

F The list of job assignments. Use this list to assign available jobs to a specific I/O input bit combination. For example, to select the job circle.dat, Bit 2 must be HIGH, and all other Bits must be LOW when the Job Select bit is set HIGH.

G Remove the selected job from the Job Assignments list.

To assign jobs to input bit combinations
1. From the Available jobs list, select an available job. Either drag the job into the Job assignment list, or click the Insert at top button to add the job to the list.
2. Delete a job from the Job assignment list by selecting the job and clicking the Remove button.

I/O JOB SELECTION TIMING
Once the LEC-1 is in I/O Job Selection mode, the LEC-1 periodically scans (every 400 ms, or 10 ms in cache mode) the status of the Job Select input. When the LEC-1 detects that the Job Select input has transitioned (level detection) from GND (LOW) to +5 VDC (HIGH), for at least 400 ms (10 ms in cached mode) it then scans the I/O Selection bits.

- If the I/O Selection bits are all at GND (LOW), this state is interpreted as an Abort. If there is a job actively executing, it will be aborted, and the system will return to scanning the Job Select input.
- If the I/O Selection bits represent a specific bit combination, this state is interpreted as an Enable Job (in cached job mode) or Load Job. The Job Assignment list is used to determine which job to activate.
- If the LEC-1 successfully loaded/enabled a job, the LEC-1 immediately starts waiting for a Start Mark signal. The Ready output is switched to +5 VDC (HIGH), indicating that the job was successfully loaded/enabled and the LEC-1 waits for Start Mark signal.
- If there was an error in loading the job, the system returns to scanning the Job Select input. The Ready output stays at GND (LOW).
- The Job Select bit must be brought to GND (LOW) to allow the LEC-1 to detect the next input transition.
MARK ON THE FLY

WinLase LAN, in combination with the LEC-1, offers marking of moving objects with the Mark on the Fly (MOTF) feature. Using Mark on the Fly, moving objects can be marked while they move through the mark field. An RS-422 encoder input is available, which allows continuous (every 10 µs) corrections to the marking vector list based on the part speed. Pulse frequencies of up to 12.5 MHz can be provided to this input from an external encoder. If the application does not require such accuracy, a Simulated encoder mode is also available.

To configure the Mark on the Fly settings

1. In the Laser System viewer, right-click on a connected LEC-1 device and select Settings.
2. Click the Mark on the Fly tab.

The Mark on the Fly Settings page when using an encoder

- The speed of the part can be tracked in two ways:
  - Using an encoder - An encoder, physically linked to the movement of the part, will allow tracking of part speed during the mark. This is the most accurate way to mark moving parts.
  - Simulating an encoder - If an encoder is not available to track the part speed, the controller card can "simulate" an encoder by providing internal pulses to the MOTF system. The system will assume a fixed part speed during the marking process.

- Select the part movement direction relative to the marking field.
WORKING WITH THE LEC-1

Controlling the LEC-1 Remotely

**D** The current encoder count. Click the Get Count button to refresh

**E** Click this button to refresh the Encoder count value

---

The Mark on the Fly Settings page when in simulated mode

**A** Enter the actual part speed in mm/s. The system assumes a constant part speed during the marking process.

---

The Mark on the Fly Settings page when in simulated mode

**A** Enter the actual part speed in mm/s. The system assumes a constant part speed during the marking process.
CONTROL SIGNAL OPTIONS

WinLase LAN must have an active connection to an LEC-1 controller in order to configure the Control signal options. The following control signal settings can be configured:

- The **Analog servo output** voltage range
- The Initial states of the **User Out signals**
- The **Laser Pipeline delay**, which provides a programmable delay between the galvo command stream and the laser signals.
- The **Interlocks**, which are four dedicated interlock inputs when signaled, will Abort an active job, and switch all laser signals to their OFF state.
- The **COM Port** settings and interface assignments.

To configure the **Analog servo outputs**

1. In the Laser System viewer, right-click on a connected LEC-1 device and select Settings. Click the Outputs Tab and then the Analog button.

The Analog servo page

A. If using analog servo amplifiers directly, the voltage range of the analog outputs can be selected.
B. If using analog servo amplifiers directly, the voltage range of the analog outputs can be selected.
To configure the Initial User Out states

1. In the Laser System viewer, right-click on a connected LEC-1 device and select Settings. Click the Outputs Tab and then the Digital button.

The Initial User Out settings page

A. Check a box to set an output HIGH, and uncheck a box to set an output LOW when the LEC-1 first starts up, or after an Abort.

B. The Pipeline delay sets a fixed delay between the galvo control signals and the laser control signals, and is used when connecting the LEC-1 to some digital servo amplifier systems.

To set the Pipeline Delay

1. In the Laser System viewer, right-click on a connected LEC-1 device and select Settings.
2. Click the Outputs Tab.
3. Click the Digital button and enter the desired value in the Pipeline Delay.

To configure the Interlocks

1. In the Laser System viewer, right-click on a connected LEC-1 device and select Settings.
2. Click the Interlocks tab.
3 Select the “Enable Interlock monitoring” check box.

![Interlocks page screenshot]

The Interlocks page
A Enable interlock monitoring. This option must be selected in order to monitor the interlock inputs
B Enable monitoring of a specific Interlock. Each interlock can be enabled independently.
C Each interlock can have a description, which will display in the Run Process or QuickMark dialog window if the interlock is signaled
D Select if the interlock will trip on a HIGH or a LOW signal input

• When an interlock is tripped, the interlock description is displayed
To configure the COM ports

1. In the Laser System viewer, right-click on a connected LEC-1 device and select Settings.
2. Click the COM Ports tab.

The COM Ports page

A. Select what COM port to use for the Pendant
B. Select the Pendant port speed. Default is 19200.
C. Select what COM port to use for the Remote API
D. Select the Remote API port speed.
E. Select what COM port to use for the Motion control interface
F. Select the Motion port speed.
WORKING WITH THE LEC-1

Diagnostic Tools

DIAGNOSTIC TOOLS

WinLase LAN provides two diagnostic tools for examining the current settings and I/O port states on the LEC-1. They are:

- The Properties Window, which displays the current property set
- The I/O Diagnostics Tool, for working with the hardware inputs and outputs on an LEC-1 device.
- The Interactive Tool, which provides an means to communicate with an LEC-1 using the Remote API

To open the LEC-1 Properties Window

1. In the Laser System viewer, right-click an LEC-1 device and select Properties...
2. The LEC-1 Properties Window appears.

<table>
<thead>
<tr>
<th>LEC-1 (00b50c2e68a1d2) - Laser System Properties</th>
<th>X</th>
</tr>
</thead>
<tbody>
<tr>
<td>Firmware version</td>
<td>2.2.5.3</td>
</tr>
<tr>
<td>Application version</td>
<td>Advanced</td>
</tr>
<tr>
<td>Platform version</td>
<td>1.5.4</td>
</tr>
<tr>
<td>FPGA version</td>
<td>20034042</td>
</tr>
<tr>
<td>Device name</td>
<td>LEC-1</td>
</tr>
<tr>
<td>Server name</td>
<td>LEC-1 (00b50c2e68a1d2)</td>
</tr>
<tr>
<td>Device S/N</td>
<td>08401301</td>
</tr>
<tr>
<td>Device IP address</td>
<td>192.168.42.106</td>
</tr>
<tr>
<td>Netmask</td>
<td>255.255.255.0</td>
</tr>
<tr>
<td>Device MAC address</td>
<td>00:50:2e:68:a1:d2</td>
</tr>
<tr>
<td>Client IP address</td>
<td>192.168.42.107</td>
</tr>
<tr>
<td>Available FLASH</td>
<td>11566</td>
</tr>
<tr>
<td>Available RAM</td>
<td>1304</td>
</tr>
<tr>
<td>Available USB</td>
<td>8</td>
</tr>
<tr>
<td>CPU temperature (°C)</td>
<td>52</td>
</tr>
<tr>
<td>Current load</td>
<td>126</td>
</tr>
<tr>
<td>Current U/O state</td>
<td>0000</td>
</tr>
<tr>
<td>Current Extended U/O state</td>
<td>0000</td>
</tr>
<tr>
<td>Interfaces word</td>
<td>2</td>
</tr>
<tr>
<td>Last error</td>
<td>5001</td>
</tr>
<tr>
<td>PPF6a status</td>
<td>0</td>
</tr>
<tr>
<td>State code</td>
<td>1</td>
</tr>
<tr>
<td>X active pos</td>
<td>0</td>
</tr>
<tr>
<td>X pos</td>
<td>0</td>
</tr>
<tr>
<td>X pos acknowledge</td>
<td>FAULT</td>
</tr>
<tr>
<td>X servo power status</td>
<td>FAULT</td>
</tr>
<tr>
<td>X servo temp status</td>
<td>FAULT</td>
</tr>
<tr>
<td>Y active pos</td>
<td>0</td>
</tr>
<tr>
<td>Y pos</td>
<td>0</td>
</tr>
<tr>
<td>Y pos acknowledge</td>
<td>FAULT</td>
</tr>
<tr>
<td>Y servo power status</td>
<td>FAULT</td>
</tr>
<tr>
<td>Y servo temp status</td>
<td>FAULT</td>
</tr>
</tbody>
</table>
To use the I/O Diagnostics Tool

- There must be an active connection to an LEC-1 device

1. In the Laser System viewer, right-click on a connected LEC-1 device and select I/O Diagnostics...

The I/O Diagnostics Tool

A. The current status of the User In inputs is displayed and updated once per second.

B. The current status of the Interlock inputs is displayed and updated once per second.

C. The current status of the User Out outputs is indicated by the state of the pushbuttons. In the screenshot, all outputs are currently LOW.

D. Use the pushbuttons to change the state of a specific User Out output. The state of the pushbuttons is updated once per second. This option will have no effect if there is no active connection to the LEC-1 device. See “Making a Connection”.

E. The current status of the System outputs is displayed and updated once per second.
If the optional Extended I/O board is connected, the I/O Diagnostics Tool expands to include the additional I/O.

The I/O Diagnostics Tool expanded to include the Extended I/O ports.
To use the Interactive tool

1. Right-click the LEC-1 device in the Laser System Viewer and select “Interactive…”.

2. Click the Interactive tab

   - **A** Enter the string to send to the Remote API
   - **B** The response sent from the LEC-1 is displayed here.
   - **C** Select the length of time to wait for a response before triggering a time-out exception.
   - **D** Click the Send button to send the string to the Remote API
FIRMWARE UPDATES

From time to time, Lanmark Controls Inc. will release an updated version of the firmware resident on the LEC-1 board. This update may be in the form of a single file, or a web link.

| WARNING | • When updating the LEC-1 firmware, all files stored locally on the LEC-1 will be lost. It is highly recommended to back up any job files that have been stored in the flash memory of the LEC-1 |
| NOTE | • After updating the firmware, the LEC-1 board must be automatically (or manually) restarted for changes to take effect |

To install an update from a provided update file

1. From the Main menu of WinLase, click Tools -> Laser System device software update. The backup warning appears.

2. Click Yes, and the Browse for Laser System software updates dialog box appears.
3. Browse to the provided Update file, select it, and click Open. The Laser System
Software Updater appears:

- **A** List of LEC-1 devices detected on the local network. Select all the devices to update.
- **B** On current firmware versions after 1.4.2, the LEC-1 can automatically restart when the firmware
  update is complete. In order for changes to take affect, the LEC-1 must be restarted after an update
  session. On LEC-1 devices with current firmware previous to 1.4.2, this checkbox has no effect, and
  the LEC-1 must be restarted manually.
- **C** Click this button to re-scan the network for LEC-1 devices.
- **D** After selecting the LEC-1 devices to update, click the Update button to start the process.
- **E** The version of the firmware currently on the LEC-1 device.
- **F** Indicates whether the update file you have selected is newer, older, or the same version as the
  version currently on the LEC-1 device.

- Select the LEC-1 boards to update, and click the Update button.
The Job, with the entities it contains, form the basis for all interaction with a laser marking system. At job execution time, WinLase LAN directs the motion of scanning galvanometers while simultaneously modulating the laser beam, based on the graphical images and laser settings contained within the job entities. The laser is turned on when a pattern is to be drawn, and off when moving to the beginning of a new pattern location. Entities are placed spatially within the marking field, which is defined by a cartesian coordinate system.

**SETTING UP THE WORKSPACE**

**COORDINATE SYSTEM CONVENTIONS**

The marking field is defined using a Cartesian coordinate system that is illustrated in the following figure.

![Scanning system coordinate conventions](image-url)
The imaging field is addressed using 16-bit integers with a range of -32768 to +32767. These units are referred to in the following sections as “bits”. All job coordinates are expressed in these units. When a user desires to represent coordinates in other units such as mm, WinLase LAN scales those coordinates appropriately taking into account the projection system optics that are involved.

CUSTOMIZING THE PAGE SIZE

Use the Page Setup settings to specify a custom field size area. The custom area can be circular or square and must be smaller in dimension than the maximum field size allowed by the LEC-1 device. The Page Setup settings are saved with the job, so different jobs could have different Page Setup settings.

To modify Page Setup values

1. Do one of the following:
   - From the main menu, select Job > Settings, then click the Page Setup tab.
   - Double click the Page Setup item in the Job Manager.
2. The Page Setup Properties window appears.

The Page Setup property page

A. Select the format:
   - Display as Rectangle - The marking field is defined and displayed as a rectangular field
   - Display as Circle - The marking field is defined and displayed as a circular field
B The width of the logical field size. This size must be less than or equal to the maximum available field size width as determined by the LEC-1 device.

C The height of the logical field size. This size must be less than or equal to the maximum available field size height as determined by the LEC-1 device.

D Click this button to use the current settings and apply them when a new job is created.

E Apply the maximum field size width and height as determined by the LEC-1 device.
OPENING, CLOSING AND SAVING JOBS

CREATING, OPENING AND CLOSING JOBS

When starting WinLase LAN, a new Job is automatically created by default. See “Default Open and Save Behavior” to configure how WinLase opens jobs when first starting. New Jobs can also be created or existing Jobs can be opened at any time using the File menu or the tool bar buttons once WinLase LAN is running. An existing Job appears with its name displayed in the Title Bar above the menu bar, in the Laser System Viewer, and on the Active Job tab. WinLase LAN supports a maximum of ten open Jobs at the same time.

To start a new Job

• Choose File > New Job or click on the New Job button.

To open an existing Job

1 Choose File > Open Job… or click on the Open button.
2 Locate and select the name of the Job to open.
3 Click Open. The Title Bar, Job Manager and Active Job tab updates with the Job name.
4 When finished with a Job, close it individually or close all open Jobs.

To load an available Job in the Touch Screen interface

• When running in the Touch Screen Interface, only jobs stored in the Touchscreen Job folder location are available.
  1 Click in the Job Manager and select the desired Job from the list of available Jobs.
  2 The Job loads and updates the display screen with the marking objects.

To close an existing Job

• Choose File > Close Job. The Job is closed.

To close all open Jobs

• Choose File > Close All Jobs. All the open Jobs are closed, and the WinLase LAN workspace is cleared.
SAVING JOBS
The job file, with the entities it contains, form the basis for all interaction with a laser marking system. There are two types of job files that WinLase LAN supports:

- **PC Job files**, which are saved on the local PC or on a network resource. These files have the extension WLJ.

- **LEC binary Job files**, which are compiled from a WinLase LAN job, and can be stored on the local PC, directly on the LEC-1 or on a USB drive attached directly to the LEC-1. These files have the extension DAT, and are the files used by the LEC-1 when it loads a job in Stand-Alone mode.

WinLase LAN provides several ways to save a Job using the File menu or the tool bar buttons:

- The **Save Job** command saves the Job with its current name and location. To save the Job for the first time, the Save As dialog box appears. Specify the Job name and where to save the Job.

- The **Save Job As** command saves the Job with a different name or location.

To save an existing Job

- Choose File > Save Job or click on the Save button. The Job is saved with the same Job name and location.

Saving Stand-Alone (LEC Binary) Job Files
When creating job files for Stand-Alone operation, there are several ways to store files and move them to the LEC-1 device.

- While connected to an LEC-1 device, directly save an open job to the flash memory of the LEC-1 device

- While connected to an LEC-1 device, directly save an open job to USB flash drive which is connected to the LEC-1 device

- Save an open job to a USB flash device connected to the PC and later transfer the USB device to the LEC-1

- Archive an open file to a hard drive location
JOB EDITING
Opening, Closing and Saving Jobs

Not all object types (Run Application automation objects for example) or special functions within objects (such as a operator prompts) are supported in Stand-Alone mode. See “Stand-Alone Job Considerations” for more information.

To save a Stand-Alone Job to a connected LEC-1

- There must be an active connection to an LEC-1 device, and the job to save must be assigned to that device.

1. In the Laser System Viewer, right-click on the job and select “Save to Laser System...”.

2. If the External Start settings have not been configured properly, a warning message will appear. See “To control the job with External I/O” on page 7-15 for configuration options.

3. From the Location drop down list, select “Internal Flash Memory”.
To save a Stand-Alone Job to a USB flash drive connected to an LEC-1

1. In the Laser System Viewer, right-click on the job and select “Save to Laser System...”.

2. If the External Start settings have not been configured properly, a warning message will appear. See “To control the job with External I/O” on page 7-15 for configuration options.

3. From the Location drop down list, select “Internal Flash Memory”. 

**NOTE**

- When transferring large job files, it may be faster to save the job to the USB flash drive while the flash drive is plugged into the PC.
To save a Stand-Alone Job to a USB flash drive connected to a PC

1. From the Main menu, select File > Save Job As... The Save Job dialog appears.
2. In the Save as Type drop down list, select “LEC binary Job files (*.dat)”. 
   ![Save Job dialog]
3. Browse to the USB flash drive.
4. In order for the LEC-1 to find detect Jobs on the USB flash drive, the folder hierarchy must be LEC\Jobs. Create the folder structure on the USB flash drive.
   ![Folder structure]
   * The folder structure for job file storage on a USB flash drive
   * Copy the file into the Jobs folder.

To archive a Stand-Alone Job

1. From the Main menu, select File > Save Job As... The Save Job dialog appears.
2. In the Save as Type drop down list, select “LEC binary Job files (*.dat)”. 
   ![Save Job dialog]
3. Browse to the desired hard drive location to save the file.
MOVING JOBS TO NEW LOCATION

When a Job containing imported graphics is saved, WinLase LAN saves a reference to the imported graphic file in its original location. If a Job file is moved to another location (a PC or a different network location), the Job will not be able to locate the imported graphic file. To make moving Jobs easier, WinLase LAN supports packaging of a Job, with all the associated graphic files.

To move a Job and all referenced graphic files to a new location

1. From the Main menu, select File > Save Job Package... The Save Job Package As dialog appears.
2. Browse to the new location and click Save.
# JOB Editing

## Opening, Closing and Saving Jobs

### DEFAULT OPEN AND SAVE BEHAVIOR

To edit the Default Open and Save behavior:

1. From the Main menu, select System > Preferences. The System Preferences window appears.
2. Click on the Job Files tab. The Job Files page appears.

![Job Files Page](image)

**A** Select options for job loading when the application starts:
- Do not load a job - No job is loaded when the application starts
- Load a specific job - A specifically named job can be selected to load when the application starts. Click the Browse button to locate the job.
- Load a new job - When the application starts, a new, empty job is loaded.
- Load the last saved job - When the application starts, the job file that was last saved will be automatically loaded.

**B** The name of the job file, depending on the option selected in A

**C** Select this option to automatically save a backup copy of a Job (with a .bak extension) when the Job is saved. By default, the Automatic backup is enabled and the save location is c:\marker\backup. To change the Automatic backup location, click on the Browse button and select the desired backup location.

**D** Backup job file folder location

**E** Location of job files when using the Touchscreen interface. Only jobs located in this folder will be visible in the Available jobs list in the Touchscreen interface.

**F** Select this option to automatically display the Job Notes when the Job is loaded from disk.
ASSIGNING JOBS TO AN LEC-1 DEVICE

The LEC-1 is a network device, and is intended to be installed onto a local area network, or connect directly to a PC. Multiple LEC-1 devices can be attached to the same network, and WinLase LAN will display all the LEC-1 devices detected on the local area network. In order for WinLase LAN to know which LEC-1 to communicate with when executing jobs, and which laser and lens settings to use, the Job must be “assigned” to an LEC-1 device. When a job is not assigned to an LEC-1 device, it is by default assigned to the Offline configuration.

<table>
<thead>
<tr>
<th>When assigned to an LEC-1 device</th>
<th>The job file will use the laser, lens and motion configuration files that are associated with the LEC-1 device. It is also possible to execute the job in streaming mode, and to save the job to the LEC-1 device</th>
</tr>
</thead>
<tbody>
<tr>
<td>When assigned to the Offline configuration</td>
<td>The job file will use the Offline laser, lens and motion configuration files. The job cannot be executed because there is no association between the job and an LEC-1 device.</td>
</tr>
</tbody>
</table>

**To assign a Job to an LEC-1 device**

1. **Make the Job to assign Active by selecting it with the Job tab, or selecting it in the Laser System Viewer.**

   The Laser System Viewer showing the Active Job is circle.wlj

   Both test.wlj and circle.wlj are assigned to the Offline configuration
Assigning Jobs to an LEC-1 device

1. Right-click the job, and select Assign to:

2. Select the LEC-1 device to assign the job to. The job now appears as a child of the LEC-1 device.

To assign a Job to the Offline configuration

1. Make the Job to assign Active by selecting it with the Job tab, or selecting it in the Laser System Viewer.

2. Right-click the job, and select Assign to:
3 Select Offline configuration. The job is no longer a child of any LEC-1 device.

To automatically assign Jobs to an LEC-1 device

1 From the Main menu, select System > Preferences. The System Preferences window appears.

2 Click on the Job Files tab. The Job Files page appears.

A Select this option to automatically assign jobs to the default LEC-1 device.
STAND-ALONE JOB CONSIDERATIONS

The LEC-1 supports the ability to execute jobs without the need for a PC. This capability is referred to as Stand-Alone mode. For performance reasons, some features, such as Mark on the Fly, are only available in Stand-Alone mode. To configure Jobs and the LEC-1 for Stand-Alone operation, consider the following:

• If changing strings at run-time, some String based object properties need to be correctly configured for use in Stand-Alone mode, and some are not available.

• The External Start settings need to be configured correctly.

• Only Laser Fonts can be used if strings need to be changed at run-time. New Laser fonts can be created for applications where the look of TrueType style fonts is required. See “Creating a new Laser font” for more information.

• Only symbologies Data Matrix, and Code 128 are currently available if the barcode string needs to be changed at run-time.

CHANGING STRINGS AT RUN-TIME

If the application requires strings contained in Text / Barcode objects to be changed at run time, only the following Source > String rules are available:

• Use AutoDate - The Text / Barcode object will mark a date code according to the format specified

• Serialize with current start value - The Text / Barcode object will mark a serial number using the format specified

• Get string from memory buffer - The Text / Barcode object will retrieve the next string from a memory buffer

• Custom string - The Text / Barcode object will build a custom string according to the format specifier

• Controlled by Remote API - The string contained in the Text / Barcode object can be modified using the Remote API on an Ethernet connection or RS-232 serial port connection.

All other String rules are not applicable to dynamic strings in Stand-Alone mode.
CONFIGURING EXTERNAL START SETTINGS
Stand-Alone jobs, by definition, are executed on the LEC-1 device. To control the execution of these jobs, an External Start signal is usually used to synchronize the start of the next job execution cycle. When a job is saved to the Stand-Alone format, WinLase LAN checks the External Start settings to verify that External Start is enabled. It may be desirable in some situations not to use an External Start signal, and execute the job only with Remote API commands. The External Start settings can be configured to support this requirement.

To configure the External Start settings

- See “To control the job with External I/O” on page 7-15.

To disable External Start Settings in Stand-Alone mode

1. From the Main menu, select Job > Settings, then click the External Start tab.
2. The External Start Properties window appears.
3. If the state of the External Start signal is always LOW (default when nothing is connected to the input), from the Trigger Mode drop down list, select “If Port is LOW”.
4. If the state of the External Start signal is always HIGH, from the Trigger Mode drop down list, select “If Port is HIGH”
MANAGING JOB ENTITIES

The Job, with the entities it contains, form the basis for all interaction with a laser marking system. WinLase LAN. Add new job entities:

- By adding a System Entity
- By importing a graphic file
- By pasting a graphic from the Windows clipboard into the current job
- By pasting a job entity from another WinLase LAN job into the current job

ADDING A SYSTEM ENTITY

A system entity includes any of the built in mark objects such as Rectangle, Polygon, etc., and any of the Automation objects.

| ![Image] | New Line toolbar button |
| ![Image] | New Rectangle toolbar button |
| ![Image] | New Rounded Rectangle toolbar button |
| ![Image] | New Polygon toolbar button |
| ![Image] | New Text toolbar button |
| ![Image] | New Barcode toolbar button |
| ![Image] | New Automation toolbar button |
| ![Image] | New Point array toolbar button |

To add a System entity to a Job

- Select Objects > Add and then select the desired object, or click on the Object from the Tool bar. The selected object is added to center of the Work area.
IMPORTING GRAPHIC FILES

Importing files or objects from other applications into WinLase LAN is easily performed using the File menu or the Import button. WinLase LAN can import many file formats, including WLJ (WinLase Job), WLO (WinLase Object), PLT (HPGL Plotter File), WMF (Windows Metafile), EMF (Windows Enhanced Metafile), DXF (AutoCAD), DWG (AutoCad), EPS (Encapsulated PostScript), BMP (Windows Bitmap), JPG (JPEG Bitmaps), GIF (CompuServe Bitmaps), PCX (PaintBrush), JOB (TruView Job), and MCL (TruView Object).

| NOTE | When importing a graphic image, WinLase LAN creates a link to the graphic file, which includes the file name and its location on disk. When the job containing the object is saved, WinLase LAN saves the link to the object in the job file. When the job is reopened, the graphic file must be present at the original location of the link, or the graphic will fail to load. |

To import a file

1. Choose File > Import, or click the Import button.

2. Locate and select the file to import.

3. Click Open. The Work Area displays the imported file and the Object List updates with the new object.

PASTING A GRAPHIC FILE

Use the Paste Special command to paste a graphic file from the Windows Clipboard into WinLase LAN. An image of the correct format must be in the Clipboard, or the Paste Special menu item is grayed out.

To Paste a graphic from the Windows Clipboard

1. Select Edit > Paste Special. If the Clipboard contains more than one type of compatible image format, the Paste Special dialog appears.
2 Select the desired graphic format to paste. The following options may be available depending on the contents of the Clipboard:

- Picture (Metafile) - Graphic is pasted as a vector object.
- Device Independent Bitmap - Graphic is pasted as a bitmap object.
- Text - Graphic is pasted as a text object.

IMPORTING JOBS

A Job is a collection of objects and system settings that describe a set of actions the laser and connected equipment will perform when the Job is run. When a Job is imported, the objects in the imported Job are added to the currently open Active Job. This is in contrast to opening a Job, where the opened Job is added to the list of Available Jobs.

To import a Job file

1 Select File > Import. Click the Files of type drop down list. The supported Job file formats are displayed. These formats are:
   - WinLase LAN Job (WLJ) - The WinLase LAN Job file.
   - TruView Job (JOB) - A Job file format developed by General Scanning, Inc. and used on its TruView DOS based software package.
2 Select the desired Job file type.
3 Locate the file to import and select it.
4 Click Open to close the Import dialog window and import the file.

CUT, COPY, AND PASTE JOB ENTITIES

The Cut, Copy and Paste commands are usually used in conjunction with one another to move, or copy an object or objects within or between Jobs. WinLase LAN provides several ways to accomplish these tasks using the File menu, Tool bar buttons, or the Ctrl+C, Ctrl+X, and Ctrl+V commands.

To copy an object or objects to the same Job

1 Select a single object or group of objects.
2 Select Edit > Copy, click the Copy button, or press Ctrl+C.

Copy toolbar button
To copy an object or objects to another Job

1. Select a single object or group of objects.
2. Select Edit > Copy, click the Copy button, or press Ctrl+C.

3. Select the target Job by clicking on the Job tab in the Available Jobs tab control, or selecting Job > and clicking on the desired Job in the list.
4. Click the Paste button, or Select Edit > Paste or press Ctrl+V. The object(s) are added to the Work area of the target Job.

To move an object or objects to another Job

1. Select a single object or group of objects.
2. Select Edit > Cut, click the Cut button, or press Ctrl+X. The objects are deleted from the Work area of the current Job.

3. Select the target Job by clicking on the Job tab in the Available Jobs tab control, or selecting Job > and clicking on the desired Job in the list.
4. Click the Paste button, or Select Edit > Paste or press Ctrl+V. The object(s) are added to the Work area of the target Job.
DELETING OBJECTS

The Delete command removes the selected object. WinLase Professional provides several ways to do this using the File menu, Tool bar button, Ctrl+Del command, or right-mouse click after selecting the object.

To delete an object or objects

1. Select the object or objects to delete in the Work area or in the Object Manager.
2. Select Edit > Delete, click the Delete button or press Ctrl+Del. The selected object or objects are deleted from the Work area.

USING SELECT ALL

The Select All command selects all objects in the Active Job.

To use Select All

- Select Edit > Select All. The objects are selected in the Work area and in the Object Manager.

EXPORTING ENTITIES

Exporting vector graphic objects is easily performed using the File menu or the Export button. WinLase LAN can export to the following file formats: PLT (HPGL Plotter File) and WLO (WinLase Object).

To export a file

- Select the desired object to export. Choose File > Export or click the Export button. The Export Graphic dialog appears.
SELECTING AND DESELECTING OBJECTS

Before modify an object, it needs to be selected by clicking on the object in the Object Manager or clicking on the object in the work area. Once an object is selected, an array of handle boxes surrounds the object and it can be edited by moving, duplicating or deleting it. Once an object has been deselected, it must be reselected to do any further editing.

To select an object using the Arrow button
• Using the arrow cursor, click on the desired object in the work area. The object now appears with anchor points around it to indicate selection and the object name is highlighted in the Object Manager.

To select an object from the Object Manager
• Click on the desired object in the Object Manager. That object now appears with anchor points around it to indicate selection.

To select multiple objects
Do one of the following:
• Using the arrow cursor, place it near the desired objects in the work area. Hold down the left mouse button, click and drag a marquee over all the objects to be selected. The objects now appear with one set of anchor points around them to indicate a group selection. All selected objects are highlighted in the Object Manager.
• Using the Object Manager, click on the first desired object, hold down the Ctrl key and click on the next desired object. Continue selecting objects until all desired objects are selected and highlighted in the Object Manager.
• From the Work area, while holding down the shift key, click on each object to add to the group. As each object is added to the current group, new anchor points will appear.

To deselect objects
Do one of the following:
• Using the arrow cursor, click at least 2 pixels away from the selected object. The anchor points are removed from around the object.
• Click on a different object in the Object Manager. The anchor points now appear around the newly selected object.
EDITING OBJECTS IN THE WORKSPACE

Editing Jobs is made easy in WinLase LAN by means of tools that allow objects to be moved and arranged precisely. WinLase LAN provides tools to move and align, scale and rotate objects, and apply these changes to groups of objects. Objects can also be moved and arranged by using the Dimension Tool. See “Using the Dimension Tool”.

To move an object

1. Select the desired object using one of the selection tools. See “Selecting and Deselecting Objects” for instructions.
2. Click the object with the mouse, and while holding the left mouse button down, drag the object to the desired location on the work area.
3. Release the mouse button. The object is moved to the new location.

To move multiple objects

1. Select the desired objects to move using one of the selecting tools. See “Selecting and Deselecting Objects” for instructions.
2. Click the group with the mouse, and while holding the left mouse button down, drag the group to the desired location on the work area.
3. Release the mouse button. The object group is moved to the new location.
To nudge an object with the keyboard
1 Select the mark object to nudge.
2 While holding down the Ctrl key, use the arrow keys to nudge the object in the desired direction.

To nudge a group of objects with the keyboard
1 Select the group to nudge.
2 While holding down the Ctrl key, use the arrow keys to nudge the object in the desired direction.

To adjust the keyboard nudge
1 From the Main menu, select System > Preferences.
2 Click the Workspace tab. The Workspace page appears.

The Workspace settings page

A Enter the amount of offset to apply to the object(s) when using the Keyboard Nudge function
To size an object proportionally

1. Select the desired object using one of the selection tools. See “Selecting and Deselecting Objects” for instructions.

2. Place the mouse over one of the corner handles and the mouse will change to the proportional arrow indicator. Click the left mouse button, and while holding the button down, drag the object to the new proportional size. Release mouse button.

Left: Mouse placed on the upper right handle. Middle: Mouse dragged to size object Right: Object at new size

To size (stretch) an object

1. Select the desired object using one of the selection tools. See “Selecting and Deselecting Objects” for instructions.

2. Place the mouse over one of the side handles and the mouse will change to the size arrow indicator. Click the left mouse button, and while holding the button down, drag the object to the new size. Release mouse button.

Left: Mouse placed on the right side handle. Middle: Mouse dragged to size object Right: Object at new size

To size a group of objects proportionally

1. Select the desired group of objects using one of the selection tools. See “Selecting and Deselecting Objects” for instructions.
Place the mouse over one of the corner handles and the mouse will change to the proportional arrow indicator. Click the left mouse button, and while holding the button down, drag the object to the new proportional size. Release mouse button.

To size (stretch) a group of objects

1. Select the desired group of objects using one of the selection tools. See “Selecting and Deselecting Objects” for instructions.

2. Place the mouse over one of the side handles and the mouse will change to the size arrow indicator. Click the left mouse button, and while holding the button down, drag the group of objects to the new size. Release mouse button.
To modify the radius and rotation of a Radial Text object

- **Radius** - First make sure the object is selected. See “Selecting and Deselecting Objects” for instructions. While holding down the ALT key, press the up or down arrow keys to increase or decrease the objects radius. If the String orientation is Radial - fixed, the circumference can be directly entered into the Dimension tool.

- **Rotation** - First make sure the object is selected. See “Selecting and Deselecting Objects” for instructions. While holding down the ALT key, press the left or right arrow keys to rotate the object clockwise or counterclockwise.

**LOCKING/UNLOCKING OBJECTS**

A job entity can be locked to prevent changes to its settings, and to prevent the object from being sized, scaled, moved, or deleted.

**To lock an object**

1. Click on the desired unlocked object to select it.
2. From the Main menu select Objects > Lock Object, or right click with the mouse and select Lock Object. The object handles change to indicate the object is locked.

**To unlock an object**

1. Click on the desired locked object to select it.
2. From the Main menu select Objects > Unlock Object or right click with the mouse and select Unlock Object. The object handles change to indicate the object is unlocked.

**To lock all objects**

- From the Main menu select Objects > Lock All. When selected, the object handles indicate the objects are locked. The Lock All menu item will only be available if there is more than one object in the Job.
To unlock all objects

- From the Main menu select Objects > Unlock All. When selected, the object handles indicate the objects are unlocked.

**UNDOING ACTIONS**

The Undo command reverses up to ten actions that have been performed on a Job. WinLase LAN provides several ways to do this using the File menu, Toolbar button, or the Ctrl+Z command.

![Undo toolbar button]

To undo the last action

- Select Edit > Undo, click on the Undo button, or press Ctrl+Z. The last action performed is reversed.
MANAGING PROFILES

An Object Profile is the set of laser parameters and scan head parameters specified in the Object Properties. WinLase LAN provides options for saving Profiles, arranging them in a tree structured set of folders, and applying the Profiles to objects. Saved Profiles are displayed in the Profile Manager. By default, the Profile Manager is displayed on the right hand side of the WinLase LAN workspace. See “Profiles Panel” on page 3-15.

THE DEFAULT PROFILE

WinLase LAN applies the Default Profile to a new object when it is first created. Because it is a required part of the system, the Default Profile cannot be deleted or moved to another folder.

| NOTE | The Default Profile always uses the Laser and Lens settings from the Offline configuration. See “To select an Offline Lens Correction file” on page 4-18 and “To select an Offline Laser Driver file” on page 4-14. |

To apply an objects profile to the Default Profile

1 Right mouse click on the object in the work area and select Add to Profiles. The Add Profile window appears.

2 Select “Apply this profile when creating a new object”. The Copy to Default confirmation appears.

3 Click OK. This profile is now applied to all new objects created.
To apply an existing profile to the Default Profile

1. From the Profile Manager, right mouse click on the existing profile. The Profile menu appears.

2. Select “Copy to Default”. The Copy to Default window appears.

3. Click OK. The profile is now applied to all new objects created.

To modify the Default Profile

1. From the Profile Manager, do one of the following:
   - Right mouse click on the Default Profile.
   - Double click on the Default Profile.

2. Select “Modify”. The Modify Profile window appears.

3. Modify the Default Profile as desired. See “Profiles” on page 6-9 for a description of the Profile parameters.
**CREATING AND ORGANIZING PROFILES**

Object Profiles can be created and organized into folders in a hierarchical directory tree.

**To Organize Profiles**

1. Do one of the following:
   - From the Menu bar, select Profiles > Organize Profiles
   - Click the Organize button in the Profile Manager.

Use the Organize Profiles window to create folders, move profiles, rename profiles, and delete profiles:

- **A** Create a new folder
- **B** Move the selected profile to another folder
- **C** The properties of the selected profile
- **D** Rename the selected profile
- **E** Delete the selected profile
- **F** The Profile viewer
**ADDING PROFILES**

**To add a Profile**

1. From the Work area, click on the object with the profile to be saved. Do one of the following:
   - Right-mouse click on the object and select Add to Profiles.
   - From the Menu bar, select Profiles > Add to Profiles.
   - From the Profiles area, click the Add button.

   Use the Add Profile window to name the profile, select its folder, or apply this profile when creating a new object.

   - **A** The name of the new profile as displayed in WinLase LAN
   - **B** Select this option to assign the profile to the Default profile. See “The Default Profile”.
   - **C** Select the folder to place the new profile in if not applying to the Default profile.
   - **D** Open the Profile viewer
   - **E** Create a new folder
MOVING PROFILES

Profiles can be moved to another folder in WinLase LAN.

To move a Profile

1. Do one of the following:
   • From the Menu bar, select Profiles > Organize Profiles.
   • From the Profile Manager, click Organize.

2. From the Profile list, click on the plus sign to display the profiles in that folder.

3. Click on the desired profile to move.

4. Click Move to Folder. The Browse Folder window appears.

5. Click on the folder to move the selected profile to.
APPLYING PROFILES TO OBJECTS
Existing Profiles can be applied to an individual object, a group of objects, or all objects within a Job.

To apply a Profile to all objects in a Job
1 From the Profile Manager, right mouse click on the desired profile to apply. The Profile menu appears.
2 Select “Apply to All”. The Apply Profile confirmation window appears.

3 Do one of the following:
   • Click OK to apply this profile to all marking objects in the Job. To confirm the profile on each object, right mouse click on the object and select Properties. The profile values in the Profiles folder are identical to the profile selected from the profile list.
   • Click Cancel to cancel the command.

To apply a Profile to a single object
1 From the Work area, click on the object to which the profile will be applied.
2 From the Profile Manager, right mouse click on the desired profile to apply to the selected object. The Profile menu appears.
3 Select “Apply to Object”. The selected profile values are applied to the selected object.
4 To confirm the Profile has been applied to the object, right mouse click and select Properties. The profile values in the Profiles folder are identical to the profile selected from the Profile Manager.

To apply a Profile to a group of objects
1 From the Work area, select the group of objects. See the section on Selecting Objects on how to select groups.
2 From the Profile Manager, right mouse click on the desired profile to apply to the selected group of objects. The Profile menu appears.
3 Select “Apply to Group”. The selected profile values are applied to the group of objects.
4 To confirm the Profile has been applied to the objects, right mouse click and select Properties. The profile values in the Profiles folder are identical to the profile selected from the Profile Manager.

**To copy an objects profile to another object**

1 From the Work area, right mouse click on the object to copy the profile from. The objects Context menu appears.

2 Select “Copy Profile”. The objects profile is temporarily stored in memory.
3 Right mouse click on the object to copy the profile to. The objects Context menu appears.

4 Select “Paste Profile”. The profile in memory is copied to the object.

To copy an objects profile to a group of objects

1 From the Work area, right mouse click on the object to copy the profile from. The objects Context menu appears.

2 Select “Copy Profile”. The objects profile is temporarily stored in memory.

3 Select a group of objects.

4 Right mouse click on the group to copy the profile to. The groups Context menu appears.

5 Select “Paste Profile”. The profile in memory is copied to the group of objects.

MODIFYING EXISTING PROFILES

To modify an existing Profile

1 From the Profile Manager, right mouse click on the desired profile to be modified. The Profile menu appears.

2 Select “Modify”. The Modify Profile window appears.

3 Or, double click the desired profile. The Modify Profile window appears.

4 Modify the profile as desired. See Section 10 for a description of the Profile parameters.

5 Click OK. The new values are applied to this profile.
IMPORTING AND EXPORTING PROFILES

Profiles created in WinLase LAN can be easily imported or exported by using the File menu.

**To import Profiles**

1. From the main menu, select File > Import and Export Profiles. The dialog appears.

![Import and Export Wizard dialog](image1.png)

2. From the Choose an action list, select “Import Profiles from a file”.

3. Click the Next button. The Select file to import page appears.

![Import and Export Wizard dialog](image2.png)

4. Click the Browse button. The Import from File dialog appears.

5. Locate the file to import and click the Open button.
6 When importing Profiles, the following two options are available:
   • Replace duplicates with Profiles imported - If there are any existing Profiles with the same name as the Profiles imported, the existing Profiles will be overwritten.
   • Do not import duplicates - Duplicate imported Profiles will not overwrite existing Profiles.
7 Click the Finish button to close the Wizard. The confirmation window appears. Click OK to close the window.

To export Profiles
1 From the main menu, select File > Import and Export Profiles. The Import and Export Profiles window appears.
2 From the Choose an action list, select “Export Profiles to a file”.
3 Click the Next button. The Save exported file page appears.
4 Click the Browse button. The Export to file dialog box appears.
5 Type the file name and locate the desired folder to save the file. Enter a filename that is unique. If the file already exists, the export operation will fail.
6 Click the Save button. The filename appears in the filename field.
7 Click the Next button. The Select folder page appears.
8 Select the folder to export. The profiles appear in the list for reference, but they cannot be exported individually.
9 If the top Profiles folder is selected, all sub folders will be exported.
10 Click the Finish button. The confirmation window appears.
MANAGING FONTS

Text Objects created in WinLase LAN can either use TrueType fonts or Laser fonts to generate their graphical representation. TrueType fonts are outline fonts and are installed in the Windows operating system. Laser fonts are specially designed fonts that are installed in the WinLase LAN font library.

ADDING A NEW TRUETYPE FONT

TrueType fonts are installed directly into the Windows operating system.

To install a new TrueType font
1. In Windows click Start > Control Panel.
2. Double-click the Fonts applet. The Fonts window appears.
3. From the Main menu, click File > Install New Font... The Add Font tool appears.
4. In the Folders drop down, select the folder that contains the new font.
5. The font will appear in the List of Fonts list. Select the font in the list and click OK.

CREATING A NEW LASER FONT

In some Dynamic Text applications, the available Laser fonts may not be acceptable for aesthetic and/or technical reasons. WinLase LAN provides a tool to create Laser Fonts from TrueType fonts. To use a custom Laser Font, consider the following:

• After the font is compiled, it needs to be added to the WinLase LAN font library, which is stored on the PC
• Text objects can be added to a job, and the new Laser Font selected as the Text Object font.
• To use the Laser Font in Stand-Alone mode, the font must also be copied to the LEC-1 card, so it is available as a resource when the job executes locally on the LEC-1 device.
To compile a new Laser font

1. From the Main menu, select Tools > Laser font compiler...

   ![Laser font compiler utility](image)

   **A** Select the source of the font outlines:
   - TrueType font
   - PLT files

   **B** The name of the new Laser font as displayed in WinLase LAN. This name is created automatically by the utility, but can be overridden with another name.

   **C** The TrueType font to convert

   **D** Select the character set:
   - ASCII (32d to 127d) - The standard ASCII character range
   - ASCII (32d to 255d) - The extended ASCII character set.

   **E** Character spacing

   **F** Curve optimization allows control over the number of straight-line segments used to define the curves in each character. More segments produce a smoother curve, but will increase the size of the Laser font file.

   **G** Select this option to automatically add the new Laser font to the WinLase LAN font library. This library is located at `\marker\fonts`. After creating a new laser font, it must be located in the library for WinLase LAN to access it. If the font is to be used in Stand-Alone mode, it must also be copied to the font library on the LEC-1 device.

   **H** Select this option to space the characters evenly in the font, rather than space them based on the width of the characters.

   **I** Click the Compile button to create the font

   **J** Select the Bold or Italics attributes before compiling the font
Managing Fonts

**ADDING A NEW LASER FONT TO WINLASE LAN**

Laser fonts are added to the WinLase LAN font library. Usually, when the Laser font is created, the “Add new font to Laser font library option” is selected. A new Laser font can also be manually added to the Laser font library.

**To add a new Laser font**

1. In Windows Explorer, browse to the folder `\marker\markers\fonts` on the local drive that WinLase LAN was installed on.
2. Copy the new font into this folder.

**WARNING**

- Adding file types other than a Laser font to the fonts folder will create errors in the way WinLase LAN detects Laser fonts. Copy ONLY Laser fonts into this folder.

**ADDING A NEW LASER FONT TO AN LEC-1 DEVICE**

If a job contains a Text object that uses a Laser font that is not part of the standard Laser font library, and that job is to be run in Stand-Alone mode on an LEC-1 device, then the Laser font must be installed on the LEC-1 device.

**To add a new Laser font to an LEC-1 device**

1. In the Laser System viewer, right-click on a connected LEC-1 device and select “Explore...”.

**NOTE**

- There must be an active connection to an LEC-1 device.
2 From the Look in drop down, select “Fonts”.

![Image of the LEC-1 interface showing a list of fonts]

3 Click the Add.. button and browse to the new Laser font.

4 Select the new Laser font and click Open. The file is copied to the LEC-1 device.
USING THE MOTION MANAGER

The Motion Manager provides a method for direct control of installed motion devices. There are two versions of the Motion Manager, depending on the installed hardware.

INTELLIGENT MOTION

To interact with available motion devices, check the following:

- A motion device or devices are attached to the correct COM port of the LEC-1. See “To configure the COM ports” on page 4-38 for more information.
- WinLase LAN has an active connection to the LEC-1 device. See “Making a Connection” on page 4-6.
- WinLase LAN has a Motion Configuration loaded. See “Working with Motion Configurations” on page 10-3.
- The LEC-1 device is selected in the Laser System Viewer.

To use the Motion Manager

1. If the Motion Manager is not visible, select View > Motor Manager.
2. From the Laser System Viewer, select an LEC-1 device that has a motion system connected.
3. When an LEC-1 device is selected, the Motion Manager updates with a view of the current Motion Configuration.
With the mouse, select an axis to control. The motion control panel appears.

The Motion Manager with an axis motor selected

- **A** The current Motion Configuration of the selected LEC-1 device
- **B** A Motion axis type contained in the Motion Configuration
- **C** The individual axis motors within the Motion axis type
- **D** The Limit and Home switch states:
  - L- is the negative travel Limit switch state. When the indicator is Red the switch is signaled.
  - H is the Home switch state. When the indicator is Red the switch is signaled.
  - L+ is the positive travel Limit switch state. When the indicator is Red the switch is signaled.
- **E** The current position of the selected motor
- **F** The amount to move the axis
- **G** Select an Action:
  - Absolute - Move the axis to absolute position F
  - Relative - Move the axis a relative amount from the current position using F
  - Home - Perform a Homing routine
  - Stop - Stop an axis that is currently moving using a deceleration profile
  - To + limit - Slew the axis to the plus limit until stopped by either the software or the limit switch.
  - To - limit - Slew the axis to the minus limit until stopped by either the software or the limit switch.
- **H** Select the units to display in the Motion Manager
- **I** After selecting the move profile, click the Go button
- **J** The Settings button, used to access the axis speed and acceleration settings.
- **K** Stop an axis immediately without using a deceleration profile.
To change speed and acceleration settings

- Click the Settings button. The Settings panel appears.

The axis Settings panel

A The acceleration rate of the axis
B The deceleration rate of the axis
C The initial speed of the motor when it first starts accelerating
D The speed of the motor after the acceleration ramp is complete
E When working with rotary motion, the radius of the part can be entered

RUNTIME ERRORS

When using the Motion Manager, runtime errors may be encountered. These errors are displayed as they are received in the Motion Manager. Click the + to see a list of all the errors received. When the Go button is click, the current Runtime errors are cleared.
**PRODEX OMS CONTROLLER**

The Motor Manager is only available if the OMS hardware is installed in the PC and detected by WinLase LAN.

**To use the Motor Manager**

1. If the Motor manager is not visible, select View > Motor Manager.
2. In the Motor Manager panel, select a motor axis to interact with. A control panel appears.

![Motion Manager Panel](image)

- **A** The installed Pro-Dex OMS controller card
- **B** The enabled axes (one shown)
- **C** The units of display in the Motion Manager
- **D** The current position of the selected axis
- **E** The amount to move the axis when the move button is clicked
- **F** The amount to jog the axis when one of the jog buttons is clicked
- **G** The speed the axis moves
- **H** Perform a homing routine
- **I** The Move button
- **J** The Jog buttons
- **K** The Stop button
USING THE DIMENSION TOOL

The Dimension Tool is used to adjust the position, size, and angular orientation of Mark Objects. To set the display units of measure and accuracy, see “Setting the Units of Measure” on page 3-6. The Dimensions form consists of six tabs:

- **Rotate**, which provides the ability to rotate the selected object or group.
- **Nudge**, which provides the ability to nudge the selected object or group.
- **Skew**, which provides the ability to shear the selected object.
- **Position**, which provides the ability to move the selected object or group to the indicated position.
- **Scale**, which provides the ability to scale or mirror the selected object or group.
- **Size**, which provides the ability to change the selected object or group to the indicated size.

Opening the Dimension Tool

<table>
<thead>
<tr>
<th>NOTE</th>
</tr>
</thead>
<tbody>
<tr>
<td>There must be an object or group of objects selected to initially display the Dimension Tool. See “Selecting and Deselecting Objects”.</td>
</tr>
</tbody>
</table>

1. To open the Dimension Tool, do one of the following:
   - From the Main menu, select Objects > Dimensions.
   - Right-click the selected object(s) and click “Dimensions...”.
   - Click the Dimension button.

---

Cut  
Copy  
Convert to Template  
Lock Object  
Delete  
Add to Profiles...  
Copy Profile  
Paste Profile  
Dimensions...  
Properties...  

- Click the Dimension button.
To Rotate a Mark Object

1. From the menu bar, select Objects > Dimensions.
2. Click on the Rotate tab. The Rotate page appears.
3. Type in the desired angle in degrees.
4. Click Apply. The object rotates about its center.
5. Optional. Click Apply to Duplicate to create a duplicate of the object with the indicated settings.

To Nudge a Mark Object

1. From the menu bar, select Objects > Dimensions.
2. Click on the Nudge tab. The Nudge page appears.
3. Type in the desired horizontal and vertical nudge in the current units.
4. Click Apply. The object moves the indicated amount.
5. Optional. Click Apply to Duplicate to create a duplicate of the object with the indicated settings.
To Skew a Mark Object

- Skew shears the object in the indicated direction. The following examples show a skewed and an un-skewed Rectangle object.

![Skewed and Un-skewed Rectangles](image)

1. From the menu bar, select Objects > Dimensions.
2. Click on the Skew tab. The Skew page appears.
3. Type in the desired horizontal and vertical skew in degrees.
4. Click Apply.
5. Optional. Click Apply to Duplicate to create a duplicate of the object with the indicated settings.
To Position a Mark Object

1. From the menu bar, select Objects > Dimensions.
2. Click on the Position tab. The Position page appears.
3. Type in the desired horizontal and vertical position in the current units.
4. Click Apply. The bottom left corner of the objects bounding rectangle moves to the indicated position.
5. Optional - Click the Center button to move the objects center to the center of the marking field.
6. Optional - Click Apply to Duplicate to create a duplicate of the object with the indicated settings.

To Scale a Mark Object

1. From the menu bar, select Objects > Dimensions.
2. Click on the Scale tab. The Scale page appears.
3. Type in the desired horizontal and vertical scale in percent.
JOB EDITING
Using the Dimension Tool

4 Optional - Enable the Proportional box to maintain the aspect ratio between the height and the width of the object.
5 Click Apply. The object scales from its center.
6 Optional - Click Apply to Duplicate to create a duplicate of the object with the indicated settings.

To Mirror a Mark Object
1 From the menu bar, select Objects > Dimensions.
2 Click on the Scale tab. The Scale page appears.
3 Select the desired Mirror action. The two mirror options available are:

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Mirror Horizontally button" /></td>
<td>Mirror Horizontally button</td>
</tr>
<tr>
<td><img src="image" alt="Mirror Vertically button" /></td>
<td>Mirror Vertically button</td>
</tr>
</tbody>
</table>

4 Click Apply.
5 Optional - Click Apply to Duplicate to create a duplicate of the object with the indicated settings.

To Size a Mark Object
1 From the menu bar, select Objects > Dimensions.
2 Click on the Size tab. The Size page appears.
3 Type in the desired horizontal and vertical size in the current units.
4 Optional - Enable the Proportional box to maintain the aspect ratio between the height and the width of the object.
5 Click Apply. The object sizes from its center.
Optional - Click Apply to Duplicate to create a duplicate of the object with the indicated settings.

To Constrain the Size of a Mark Object
1. From the menu bar, select Objects > Dimensions.
2. Click on the Size tab. The Size page appears.
3. Click on the Constraints radio button. This is only available with Text Objects.
4. Click the When marking, constrain size to: check box.
5. Enter the desired size constraints.
6. When marking, if the current text string (for example, from a text merge operation) will be larger than the constraints, the object will be scaled down to fit inside the constraints. If the text string will fit inside the constraints, no scaling is applied.

To Size a Fixed Radial Text object
1. From the menu bar, select Objects > Dimensions.
2. Click on the Size tab. The Size page appears.
The Radial text size page

A. The circumference of the text itself. This circumference is represented on screen as a circle drawn with a red dotted line.

B. The actual height of the ascent portion of a text character.

C. The actual height of the descent portion of a text character.

To constrain the arc of a Fixed Radial Text object

1. From the menu bar, select Objects > Dimensions.
2. Click on the Size tab. The Size page appears.
3. Check the “When marking constrain arc to:” check box.
4. Enter the desired value.
5. Click Apply. The object redraws with the new setting.
6. Optional - Click Apply to Duplicate to create a duplicate of the object with the indicated settings.
USING THE ALIGN TOOL

The Align Tool is useful for aligning two or more objects to each other.

To use the Align Tool

1. Select more than one object in the work area. See “Selecting and Deselecting Objects”.
2. Do one of the following:
   - From the Main menu, select Tools > Align.
   - Click the Align button.
3. Select the desired alignment options. For example, to align the centers of both objects to each other, use the settings shown above. Note that the last object selected into the object group becomes the target object for the align process.
4. Click the Preview button to see what the align action will do to the objects in the work area. Click the Reset button to return the objects to their original positions.
Using the Grid and Guidelines

Using the Grid and Guidelines

In addition to the Align Tool, there are two on-screen object alignment tools that aid in positioning objects in the marking field. They are:

- **Grid**, which is a series of evenly spaced horizontal and vertical lines that are used to help draw and arrange objects. Use the controls on the Grid/Guidelines window to set the grid's parameters.

- **Guidelines**, which are lines that can assist in aligning objects. Use the controls on the Grid/Guidelines window to set the guideline parameters.

Using Snap to Grid

The Snap to Grid command automatically aligns object edges vertically and horizontally relative to the Grid.

To use the Snap to Grid

- Select Edit > Snap to Grid or click on the Snap to Grid button.

To display the Grid

The grid can be visible, overlaying on the work area, or it can be hidden from view.

1 To display the Grid over the work area, do one of the following:
   - From the menu bar, select View > Grid.
   - Click the Show Grid button on the toolbar.

To hide the Grid

1 To hide the Grid do one of the following:
   - From the menu bar, select View > Grid.
   - Click the Show Grid button on the toolbar.
To modify Grid Settings

Grid settings affect the way the Grid is drawn on screen, and how an object behaves when moved near a grid line.

1. From the menu bar, select Tools > Grid/Guidelines. The Grid/Guidelines window appears.

   ![Grid/Guidelines window](image)

   - **A** Sets the spacing between the horizontally drawn grid lines, in the current display units.
   - **B** Sets the spacing between the vertically drawn grid lines, in the current display units.
   - **C** Shows or hides the grid.
   - **D** If this option is selected, when an object is moved near a grid line, the object will snap to the line.

**USING SNAP TO GUIDELINES**

The Snap to Guideline command automatically aligns object edges vertically and horizontally relative to the guideline.

![Snap to Guidelines toolbar button](image)

**To use Snap to Guidelines**

- Select Edit > Snap to Guidelines or click on the Snap to Guidelines button.
To add, delete, and move Guidelines

An unlimited number of guidelines can be added to the work area. Guidelines can be added, moved, deleted, and cleared. All of these tasks are performed from the Guidelines Setup window.

1. From the menu bar, select Tools > Grid/Guidelines.
2. Click the Setup button. The Guidelines Setup window appears.

![Guidelines Setup Window]

The Guidelines Setup page
A. Select the Horizontal or Vertical tab to manage guidelines.
B. Enter a position
C. List of current guidelines.
D. Add a guideline at the position specified in B
E. Move a selected guideline to a new location as specified in B
F. Delete the selected guideline
G. Clear the list of guidelines

To display the Guidelines

The Guidelines (if there are any set) can be visible, overlaying the work area, or they can be hidden from view.

NOTE: If there are no Guidelines set, the Show Guidelines feature is disabled.

1. To display the Guidelines over the work area, do one of the following:
   • From the menu bar, select View > Guidelines.
To hide the Guidelines

1. To hide the Guidelines do one of the following:
   - From the menu bar, select View > Guidelines.
   - Click the Show Guidelines button on the toolbar.

To modify Guideline Settings

Guideline settings affect the way the Guidelines are drawn on screen, and how an object behaves when moved near a Guideline

1. From the menu bar, select Tools > Grid/Guidelines. The Grid/Guidelines window appears.

   ![](image.png)

   The Guidelines page

   - **A** Restores the Guidelines as they were saved in the Job. If this selection is not checked, the Job loads without displaying the guidelines.
   - **B** Shows or hides the Guidelines.
   - **C** If this option is selected, when an object is moved near a Guideline, the object will snap to the line.
GUIDELINE PRESETS
WinLase LAN can save different combinations of Guidelines to the Preset library. This feature is useful if there are many different tooling sets, and a quick method is needed to set up for each tool. The Preset options are:

- Load Preset, which loads a pre-saved Guideline set into the work area.
- Save Preset, which saves the current Guidelines to a Preset.
- Organize Presets, which renames and deletes Presets.

To save a Guidelines Preset
1. From the menu bar, select Tools > Grid/Guidelines.
2. Click the Setup button.
3. If there are no Guidelines set, add the desired horizontal and vertical Guidelines.
4. Click the Save Preset button. The Save Preset window appears.
5. Select an appropriate name for the new Preset, and click the OK button.

To load a Guidelines Preset
1. From the menu bar, select Tools > Grid/Guidelines.
2. Click the Setup button.
3. Click the Load Preset button. The Preset window appears.
4. Select the desired Preset.
5. Click OK to apply this Preset, Cancel to quit.
6. The Preset values appear in the Guidelines Setup list.
To delete a Preset

1. From the menu bar, select Tools > Grid/Guidelines.
2. Click the Setup button.
3. Click the Organize Presets button. The Organize Presets window appears.
4. Select the desired Preset to delete.
5. Click the Delete button. The Preset is deleted and removed from the list.

To rename a Preset

1. From the menu bar, select Tools > Grid/Guidelines.
2. Click the Setup button.
3. Click the Organize Presets button. The Organize Presets window appears.
4. Select the desired Preset to rename.
5. Click the Rename button. An edit box appears next to the Preset.
6. Edit the Preset name as desired.
7. Click away from the Preset. The new Preset name is saved.
USING THE ZOOM TOOLS

- There are three tools available to change the zoomed view of the work area:
  - Zoom In Tool, which provides methods to zoom in on a specific place in the work area.
  - Zoom Out Tool, which provides methods to zoom out, reversing the zoom in actions.
  - Full Field Tool, which returns the work area to the default full field area view.

The scroll bars on the right and bottom of the work area can also be used to scroll the current view of the work area.

Using the Zoom In Tool

1. Click on the Zoom In button. The button stays depressed, and the mouse cursor changes to the zoom in cursor.

2. While holding the right mouse button down, drag a marquee around an object in the work area. The marquee box updates the screen.

- Release the mouse button. The new work area extents become the window that the marquee defined. The Zoom In button returns to its off state, and the mouse cursor returns to its default.
- To repeat the process, click the Zoom In button again.
Using the Zoom Out Tool

1. Click on the Zoom Out button.

2. The work area zooms out.

3. To repeat the process, click the Zoom Out button again.

Using the Full Field Tool

1. Click on the Full Field button.

2. The work area returns to its default size.
PRINTING JOBS

WinLase LAN can print an image of a Job as it appears on screen. WinLase LAN provides several ways to print Jobs using the File menu or the Toolbar button.

To print a Job

1. Select File > Print Setup. The Print Setup dialog appears.
   • Click the Print button.

2. Select the desired printer from the drop down list.
3. Select the desired paper size and source.
4. Select the desired orientation of the Job.
5. Click OK. The Job prints to the selected printer.

To adjust the print layout of a Job before printing

1. Select File > Print or click on the Print button.
   • The Print Layout dialog appears.

The Print Layout dialog

A Objects will print the actual size.
B Scales the Job so that it fits on the page.
**C** Adjusts the Job so that it's located in the center of the page. Select this to adjust the width and height of the printed Job.

**D** Changes the width and height of the Job to be printed.

**E** Forces the width and height to maintain a constant ratio.

**F** Displays the field size boundaries on the printed Job.
JOB EDITING

Printing Jobs
This chapter provides an overview of the Job Entity types. There are three types of Job Entities:

- **Mark Objects** consist of lines, rectangles, polygons, text, barcodes, imported vector files, imported bitmap files and drill points. These objects represent the pattern the laser will mark.

- **Automation Objects** consist of I/O functions that set or get the state of I/O ports, Time Delays, displaying of Message Boxes, and multi-axis Motor Control objects. These Automation objects are usually used for interfacing to and controlling external equipment.

- The **Template Object**, which provides a graphic that is displayed in the work area, but is not a marking object.

### WORKING WITH JOB ENTITIES

Each entity has a set of properties that can be modified, and these settings can be edited by selecting the object and selecting Objects > Properties, pressing F2 on the keyboard while a single object is selected, or right-mouse clicking on the selected object and selecting Properties.

**To view and set Entity Property Values**

1. Click on the desired object to select it.
2. Do one of the following:
   - From the Main menu, select Objects > Properties.
   - Press F2 on the keyboard.
Working with Job Entities

- Right-mouse click on the selected object and select “Properties...”. The Properties window appears for the selected object.

  3 Edit the property values as desired.

  4 Click Apply to leave the Properties window open, or click OK to apply the changes and close the Properties window.

CHANGING THE NAME OF AN OBJECT

You can change the name of the job entity as it appears in the Object Manager.

To change the Name of the Object

  1 Click on the desired Object in Object Manager.
2 Right-mouse click and select Properties. The Properties window appears.

---

Enter the object name

The object name as it appears in the Object Manager
**ADDING NOTES TO AN OBJECT**

All objects have a Notes property, which you can use to save details about the object. The notes property is only visible in the User Interface.

**To add a Note to the object**

1. Click on the object to be modified.
2. Right-mouse click and select “Properties...”.
3. Click on the Notes Tab. The Properties window displays the Notes settings:
MARK ENTITIES

Mark entities can be defined as any entity type that controls the motion of the scan head and the laser to produce a laser mark. Mark entities consist of imported graphics files as well as the WinLase LAN built-in system objects.

EXTERNAL CONTROL

Use External Control to Enable or disable marking of the entity based on discrete I/O input.

| NOTE | • This feature is ONLY available when running the job in Stand-Alone mode. |

To modify External Control settings

1. Click on the Object to be modified.
2. Right-mouse click and select “Properties...”. 
Click on the Ext. Control tab. The Properties window displays the ExternalControl settings.

The property External Control page

A. Select this option to enable External Control. When the Job is run, the object will check the I/O ports, and if they match the configuration selected in D, the object will mark, otherwise, it will be skipped.

B. Selects the I/O ports to be used during the process. Only User In 1 - User In 20 are available when working with an LEC-1 device.

C. Select the Control logic:
   • Scan ALL inputs (AND) - All the inputs on the LEC-1 device are read and then compared to the configuration in D. If every input matches D, then the object is marked.
   • Scan ONLY checked inputs (OR) - All the inputs on the LEC-1 device are read and then compared to the configuration in D. If just the inputs checked in D match, even though other inputs may actually be set on the LEC-1 device, the object is marked.

D. Select a checkbox to require the input to be HIGH, deselect the checkbox to require the input to be LOW.
**FILL (HATCHING)**

WinLase LAN has the ability to add fill lines inside closed paths within any two-dimensional object type (except Bitmaps and Dot Matrix). Closed paths are defined as polyline objects where the beginning of the first vector aligns with the end of the last vector. See “Understanding Closed Paths”. Fill is usually used to create a “solid look” to the marked objects. An important parameter in fill is the spacing between each fill line. The optimal spacing value is dependent on laser wavelength, spot size, material, etc. Once the optimal value is determined, it can be saved with the object. WinLase LAN has an added benefit: as the object is scaled and sized, the fill maintains a constant spacing. This eliminates the need to regenerate the object artwork with new fill each time the object is resized.

An unfilled and a filled Text entity using parallel lines

In addition to parallel lines, a crosshatch style is available, with customized settings for the angles of each set of lines.

Crosshatch at 0 and 90 degrees, Crosshatch at -45 and 45 degrees
To modify Fill values

1. Click on the object to be modified.
2. Right-mouse click and select “Properties...”. The Properties window displays.
3. If the object has closed paths (a contiguous series of connected vectors that start and stop at the same point), the Fill tab will be visible. Click the Fill tab. The Fill page appears.

The property Fill page:

A. Enable or disable filling (hatching) objects
B. Select the Style:
   - Parallel lines
   - Crosshatch
   - Bidirectional
C. The distance between adjacent fill lines.
D. The angle from the X-axis for the parallel fill or bidirectional fill, or the first set of fill lines in crosshatch fill.
E. The angle from the X-axis for the secondary fill lines when using the crosshatch style.
UNDERSTANDING CLOSED PATHS

The path is the basis for all vector objects. A path is made up of one or more line segments connected by two or more anchor points. Paths can be made from a combination of straight lines and curves, each of which may be made up of many connecting points. Paths can be open or closed. An open path is one with unconnected end points, while a closed path is one whose start and end points meet. WinLase LAN cannot fill objects unless they are closed paths.

Example of an open path

Example of a closed path with four nodes

PROFILES

An Object Profile defines the laser marking parameters and scan head parameters to be used when marking the object. After developing laser-marking parameters for different materials, these settings can be saved in the Profile library. WinLase LAN provides a means of saving the marking Profiles, and arranging them in a tree structured set of folders.

Saved Profiles are displayed in the Profile Manager. By default, the Profile Manager is displayed on the right hand side of the WinLase LAN workspace. See “Profiles Panel” on page 3-15.

To show the Profiles page

1. Do one of the following:
   - Right mouse click on a mark object and select “Properties...”.
   - Select a mark object, then from the menu bar, select Objects > Properties.
Select a mark object and then press the F2 key.

The Profiles page

A. Select the marking Mode:
- Mark once - The object will mark once with the selected Profile parameters.
- Mark Multiple times - The object will mark the number of times indicated in the Passes field.
- 2 pass Cut and Clean - The object will mark twice and each pass has its own Profile settings. To modify different Profile settings, select them with the Current Profile box.
- 3 pass Cut and Clean - The object will mark three times and each pass has its own Profile settings. To modify different Profile settings, select them with the Current Profile box.
- 4 pass Cut and Clean - The object will mark four times, and each pass has its own Profile settings. To modify different Profile settings, select them with the Current Profile box. If the Use pens checkbox is checked, 2 pass Cut and Clean, 3 pass Cut and Clean, or 4 pass Cut and Clean is not available.

B. When the Mode field is set to 2 pass Cut and Clean, 3 pass Cut and Clean, or 4 pass Cut and Clean, or the Use pens box is checked, the Current Profile box selects which Profile is currently displayed. If displaying pens, the associated pen color is displayed to indicate which line segments in the...
object will use the current Profile. Changes can be made to the current Profile and saved with the object.

C The Passes field is only available when the Mark Multiple times mode is selected. Enter the desired number of marking passes for the object. When running the Job, the object will mark the number of times indicated in the Passes field, even though it only appears in the Object List once.

D Controls the output power of the laser. On YAG type lasers, this is typically accomplished by changing the lamp or diode current. On CO2 type lasers, varying the pulse width while maintaining the frequency at a constant value controls power. Depending on the settings in the Laser Configuration file, the units are percent (%) or Watts.

E Controls the repetition rate of the laser control signal. On YAG lasers, this is usually referred to as the Q-Switch frequency.

F Many applications require laser marking without variation in intensity at the start or end of a vector. In order to reach acceptable marking results, it is necessary to mark vectors with a constant velocity. When the Scan Head first executes a marking vector, the mirrors on the galvanometers have to be accelerated up to the defined marking speed. To make sure the laser is not switched on before the mirrors have reached the programmed angular velocity, a LaserOn Delay is automatically inserted before the start of a series of marking vectors. The length of the LaserOn Delay has to be matched with the Mark Speed.

G Depending on the programmed Mark Speed, a difference occurs between the commanded position and the actual position of each mirror during execution of a vector. The difference in time between these two values is called lag. When the command value of the end of a vector is reached, the laser should not be turned off immediately; it must be turned off after a delay, to compensate for the lag. A LaserOff Delay is automatically inserted at the end of every series of marking vectors. The length of the LaserOff Delay has to be matched with the Mark Speed.

H At the end of a series of marking vectors, the mirrors have to settle to a stop before executing the next command. For this reason, a Mark Delay is automatically inserted after the last marking vector in a series. For best performance, Mark Speed and Mark Delay have to be well matched.

I The time lag occurring while executing a series of marking vectors results in a rounding of the corners of the polygon. To control this, a Poly Delay is inserted between each vector in a series of marking vectors (polyline).

J The position to move the z-axis output device. This is typically used with a linear translator assembly to move the focus point up and down in relation to the marking surface.

K Controls the waveform mode of the laser. Currently supported only with SPI G3 laser systems.

L After the object has completed marking, the laser power will be set to zero % if this option is selected. This feature is useful if using certain laser types that require a separate signal to control the laser power.

M The Use pens check box is only available when the object contains extended pen information. Pen information is usually found in files of type *.PLT, *.DXF and *.DWG. Using pens allows different line segments within one object to be assigned different Profiles. When the Use pens box is checked, the Current Profile control updates with the pens available in the object, and the associated color in which the line segments in the object are drawn on screen. When the Mode field is set to 2 pass Cut and Clean, 3 pass Cut and Clean, or 4 pass Cut and Clean, using pens is not available.
**JOB ENTITIES**

*Mark Entities*

N Controls the speed with which the laser spot moves on the target while executing a marking vector. The laser is on during the mark.

O Controls the pulse width of the laser control signal. On CO2 lasers, this parameter is not available, as it is set automatically based on the value in the Laser Power field. For example, if the Laser Power field is set to 50% and the Frequency field to 5 KHz, the pulse width will be set automatically to 100 µs.

P Controls the speed with which the spot moves while “jumping” to the start of the next marking vector. The laser is off during the jump.

Q Before executing a jump command, the Scan Head mirrors have to be accelerated up to the programmed Jump Speed. This acceleration results in a time lag. After the jump, the mirrors need time to settle to a complete stop. In order to take into account the time lag and settling time, a Jump Delay is inserted automatically at the end of every jump vector. Note that a higher Jump Speed requires a longer Jump Delay. The entire time taken by a jump consists of the jump time and the Jump Delay and can be minimized by choosing optimum values of Jump Speed and Jump Delay.

R Jump delays sometimes need to be longer for larger jumps, and shorter for smaller jumps. When a jump length is greater than the Vari. Jump Length, the Vari. Jump Delay is applied. When jumps are smaller than Vari. Jump Length, the standard Jump Delay is used. To disable, set to 0.

S Jump delays sometimes need to be longer for larger jumps, and shorter for smaller jumps. When a jump length is greater than the Vari. Jump Length, the Vari. Jump Delay is applied. When jumps are smaller than Vari. Jump Length, the standard Jump Delay is used.

T When Wobble Width is greater than 0, the beam dithers (moves in a very small circle) while marking a vector. Changing the Wobble Frequency controls the speed at which this circle is moved.

U When Wobble Width is greater than 0, the beam dithers (moves in a very small circle) while marking a vector. This has the effect of making the marked line wider. Changing the value of Wobble Width controls the width of the marked line.

V Select this option to place the laser in CW Mode. This option is only available on SPI G3 lasers.
ESTIMATING THE MARK TIME

The estimated marking time for an object or group of objects is calculated automatically and can be displayed in the objects Properties window.

To display estimated marking times

1. Do one of the following:
   - Right mouse click on a mark object or group of objects and select “Properties...”.
   - Select a mark object or a group of mark objects, then from the Main menu, select Object > Properties.
   - Select a mark object or group of mark objects and then press the F2 key.

2. The Properties window appears. Click the Performance details button to show the marking times.

The Performance details panel

A. The total theoretical marking time for the object / group
B. The total time of all the delays
C. The total time of all the jump vectors
D. The total time of all the marking vectors
E. The total number of marking vectors in the outline portion of the object / group
F. The total number of jump vectors in the outline portion of the object / group
G. The total number of marking vectors in the fill portion of the object / group
H. The total number of jump vectors in the fill portion of the object / group

MICRO-VECTORING AND DELAYS

Controlled velocity marking and jumping is accomplished through a process called micro-vectoring. This process is illustrated in the following figure. The marking engine of the LEC-1 takes a vector and divides it into multiple shorter segments (micro-vectors) that are applied to the galvos at regularly spaced time intervals. This interval is known as the update interval. The galvo speed is controlled by the magnitude of the change in the output command at each update period.

The following figure shows the sequence of typical output commands for the X axis. The commands for the Y and Z axes are similar and are strictly locked in time with the X axis,
differing only in magnitude of the discrete steps. As the X axis reaches successive targets X1, X2, etc., so do the Y and Z axes reach their corresponding targets, Y1, Z1, Y2, Z2, etc.

Micro-vector operation

Because laser scanning systems are electro-mechanical in nature, various delays must be employed to compensate for inertial effects of the mirror and motor structure. These effects generally result in a positional lag of the deflection mirrors relative to the electrical command to make them move. These delays are used to properly time laser on/off and modulation signals relative to the mirror positions. In addition to compensating for lag times, the delays can be used to compensate for transient instability in mirror positions after a step to a new location. The following figures illustrate these effects.

Each system configuration requires fine-tuning of delay commands to ensure full and complete marking with no over burns. The individual delay settings are dependant on the dynamic response of the galvo/mirror combination in use, and the sensitivity characteristics of the marking medium. Determining these delays is typically a trial-and-error process. The delays are specified as part of the job definition described in the next section.

Micro-vectoring and laser timing relationships
Optimizing the Jump delay

During a jump, the scan head mirrors accelerate to rapidly get to the next mark position, ideally at the fastest speed possible to minimize overall marking time. As with all accelerations, mirror and system inertia create a slight lag at the beginning of the acceleration. Likewise, the system will require a certain delay (settling time) at the end of the jump as it decelerates to precisely the correct speed required for accurate marking. Acceleration and deceleration times and settling times will vary from system to system (weight of mirrors, type of galvanometer, etc.), and will vary depending on the requested jump speed and the length of the jump.

Effects of the Jump Command

Jump Delay too short: Marking starts before mirrors properly settle. Too short of Jump Delay will cause marking to start before mirrors are properly settled, resulting in inadvertent marking. Too long of a Jump Delay will have no visible effect, but marking is delayed so overall job production time (marking time) increases.
Optimizing the Mark delay

A mark delay at the end of marking a line segment allows the mirrors to complete the move to the required position prior to executing the next mark command.

*Mark Delay too short:* Marking continues into a jump vector. Too short of a Mark Delay will allow the subsequent jump command to begin before the system mirrors get to their final marking position. The end of the current mark will turn towards the direction of the jump vector, as shown to the right. Too long of a Mark delay will cause no visible marking errors, but will add to the overall processing time.
Optimizing the Laser On Delay

The Laser On Delay can be used to prevent burn-in effects at the start of a vector. This delay in time before the laser is turned on is typically used to turn on the laser after the first few micro-steps of a mark command to ensure that the laser's motion control systems (mirrors, etc.) are “up to speed” before marking. This delay can have either a positive or a negative value and will vary with different systems and lasers because of galvo motor and mirror inertias, and laser activation timings.

**Laser On Delay too short: Burn-in at vector start points**

**Laser On Delay too long: Marking starts too late, skips vector start points because the vector mark has started before the laser has switched on**
Optimizing the Poly Delay

A polygon delay is a delay automatically inserted between two marking segments where two vectors meet. The minimum delay allows enough time for the galvos and mirrors to “catch up” with the command signal before a new command is issued to move on to the next point.

*Poly Delay too short: Characters not well formed*

*Poly Delay too long: Burn-in at vector junctions*
**Optimizing the Laser Off Delay**

The Laser Off Delay is used to prevent burn-in effects at the end of a vector. This delay in time before the laser is turned off is typically used to turn off the laser just before the last few micro-steps of a mark command to ensure that the marking stops exactly where it is desired to stop. The goal is to adjust the Laser Off Delay to ensure uniform marking with no variations of intensity throughout the desired vector.

*Laser Off Delay too short:* Marking stops too soon, skipping vector endpoints. Typically, too short of a delay will cause skipping of vector endpoints as the laser switches off too early.

*Laser Off Delay too long:* Marking stops too late, burn-in at vector endpoints. Typically, too long of a delay will cause burn-in at the end of a vector where the laser stays on too long.
Tips on optimizing Profiles

Take care of the basics when setting up a scanning system. Best results are achieved when
the input beam is perfectly aligned cleanly into the scan head without contacting non-
transmissive surfaces, expanded and collimated so the energy floods the mirrors without
overspill. eg. using a 10mm scan head, the entry diameter is just under 10mm. Larger and
the beam will contact the housing, causing interference, and compounding the focus at the
target.

Pay strict attention to parallelism between scan head and target. Be aware the wider the
angle scanned to the field extremities, the more the spot will change from a perfect circle,
and when using focusing lenses after the mirrors, more diffraction will be introduced.

1 Ensure any pointer laser is aligned to the main processing beam. Mark 5 points (center
and corners), and position the pointer to the same points, adjusting until it falls
perfectly on the marks.

2 Mark a series of 10 close parallel lines across roughly half the field size. Do not worry
about the starts and ends of the lines at this point. The first goal is to find the best laser
and marking speed settings for the absorption of the energy by the target material.

3 Set Line 1 at the minimum and Line 10 at the maximum Mark speed you feel would suit
the material. Set Lines 2 to 9 in incremental Mark speed steps between the minimum
and maximum. This gives an indication of the best results, but may be slower or faster
than expected. You may need to adjust the speed range and mark again. When you
have a good result, reduce the range to fine-tune the Mark speed.

4 Set the best Mark speed to all lines. Set a range of incremental laser frequencies
between the minimum and maximum you feel may suit the material and mark again.
Different materials may absorb differently at differing frequencies, and you may see
further improvements.
When you have found the best laser parameters, set all lines the same and repeat the incremental Mark speed variations either side of the setting for the frequency optimisation. Repeat these steps until you have the best results.

Use a step-by-step approach to optimize delays, rather than changing several parameters at the same time. Download the delays.plt file and place in the marker/graphics/vector folder. Open a new Job and import the delays graphic. 4 simple lines will be marked, joined by a double-Jump.

The file is in its simplest form and will mark over 80% of the field, starting with the index lines A-B-C. The scanners will then double-jump without marking via C-D-E, before marking the calibration lines E-F-G.

Set the Jump speed the same as the Mark speed, the Laser On, Jump and Mark delays relatively long (800µs), and the Poly and Laser Off delays relatively short (80µs).

Mark and check Point E. A tail in the direction D-E leading into the marked line E-F should mark. If the tail is, say 2mm, reducing the Laser On delay to 400µs will roughly halve it to 1mm. This is speed and laser dependent. Continue reducing the Laser On delay until Point E starts the mark perfectly in the middle of the A-B index line.

Now increase the Jump speed until Point E starts to lose position. Reduce the Jump speed slightly until Point E is clear again.
11 Now reduce the Jump delay to 400µs. If you see no difference, halve it again. Keep reducing the Jump delay until Point E starts to lose position, then slightly increase the Jump delay until Point E starts the mark perfectly in the middle of the A-B index line.

12 Because a jump is a repositioning of the mirrors, you want to minimise these process timings. The faster the Jump speed, the longer the Jump delay to allow the mirrors to settle, and you may have to reduce the Jump speed to reduce the Jump delay to gain faster overall process times.

13 Now concentrate on Point F where the 2 vectors E-F and F-G meet. If Point F over-burns, reduce the Poly delay. If Point F is rounded, increase the Poly delay until you have a crisp result.

14 Finally, check Point G where the vectors end. Increase the Laser Off delay until Point G ends the mark perfectly in the middle of the B-C index line. Reduce the Mark delay until the mark moves away or over-burns, then reduce slightly until it marks perfectly in the middle of the B-C index line again.

You have now set the optimum parameters for the material. Do not forget to save these parameters by adding them to a Profile and naming as your choice (refer to Managing Profiles in the WinLase LAN User Guide provided as a .pdf document in your marker/documentation folder).
**OBJECT SETTINGS**

- Use the Object Settings to configure:
  - The Object Name
  - The on screen Color
  - When the Outline and Fill will mark
  - Jump display properties

**To modify Settings Values**

1. Click on the Mark Object to be modified.
2. Right-mouse click and select “Properties...”.
3. Click on the Settings tab. The Settings page displays the object settings values.

![Rectangle - Properties](Image)

- **A** Name: This name will appear in the Object Manager, and in any messages that appear referencing the object.
- **B** On screen color: Change the color of the selected object on screen.
- **C** Mark style: Select between vector, dot and circle dot marking styles (not available on all releases of WinLase).
- **D** Mark outline: Check this box to mark the outline portion of the object. By default, this field is enabled.
JOB ENTITIES

Mark Entities

E  If Fill has been enabled, select this option. By default, this field is disabled.

F  Shows the jump vectors, indicating the path the marking beam spot takes while moving to the next marking vector. By default, this field is disabled.

G  To mark multiple objects in a job onto a continuous moving part (like wire, etc.), endless sequences of marks can be attained by resetting the starting point of the object using this option.

H  Enter the spacing, in field distance on the moving part, between successive objects.
**BITMAP GRAPHIC OBJECT**

A bitmap is a rectangular grouping of pixels that form a visual image. In laser marking, the bitmap image must be “rastered” to render it with the laser. Because the scan head is a vector output device, this rastering action must be simulated, with the laser spot tracing across the image one row of pixels at a time. This can be a time consuming process, and it will usually take longer to mark a bitmap representation of an object than a vector representation. Some images, however, lend themselves only to bitmap marking, i.e. photographs. WinLase LAN supports importing bitmap files with monochrome, grayscale or color content. All color images, however, will be converted to grayscale internally after import.

To modify Bitmap Graphic settings

1. Click on the Bitmap Graphic to be modified.
2. Right-mouse click and select “Properties...”.
3. Click on the Settings tab. The Settings page displays the Bitmap object settings values for a multi-tonal bitmap.

---

*The Bitmap graphic Settings page*

- **A** Adjusts the spacing of pixels within the bitmap image, in dots/inch.
**JOB ENTITIES**

*Mark Entities*

**B** Adjusts the range between the lightest and darkest pixel. A higher contrast setting will increase this range.

**C** Adjusts the overall lightness of the image. Increasing this value will cause the laser to stay on longer at each pixel.

**D** Applies the standard error diffusion algorithm to a grayscale bitmap, converting it to a monochrome bitmap. The pixels are placed in such a way that the image appears to be grayscale.

**E** Reverses the light and dark pixels in the image, using the middle of the range as a reference point.

**F** Forces the lines of pixels in the bitmap to all be marked in the same direction. This improves pixel alignment when marking at high speed.

**G** When marking, pixels that have a value of black (non-marking) will be jumped over by the laser beam, reducing the overall marking time.

**H** When bitmaps are rotated, black pixels may be added to the bitmaps corners. To add white pixels instead, select this checkbox.

**I** Select this option to lock the Y mirrors in place and only scan the X mirrors. The part to be marked is then translated under the marking head in the y axis.
POINT ARRAY OBJECT

Point objects direct the laser to specific coordinates and then turn the laser on for a specified time. Point objects are usually set up as an array of points arranged in rows and columns. If specifically placed point objects are needed, use multiple objects of one point each. This object is used for applications such as perforating or drilling into a material.

To modify Point settings

1. Click on the Point Object to be modified.
2. Right-mouse click and select “Properties...”.
3. Click on the Settings tab. The Settings page displays the Drill Object settings values.

The Point object Settings page

A. The size each individual dot is displayed on the screen in WinLase LAN. This value has no effect on the mark.
B. The length of time the laser is on during a single pulse.
C. The time the laser is off between successive pulses.
D. The number of times to pulse the laser at each dot location.
E. The number of rows in a point object array.
F. The number of columns in a point object array.
G. Total number of points in an array. Note that a setting of 1 creates a single point.
**POLYGON OBJECT**

Polygons are markable objects with a specified number of sides of equal length, each side being the same distance from the center of the object.

**To modify Polygon settings**

1. Click on the Polygon to be modified.
2. Right-mouse click and select “Properties...”.
3. Click on the Settings tab. The Settings page displays the Polygon object settings values.

![Polygon Properties](image)

The Polygon Settings page

- **A** The number of straight-line segments the object has. For example, to create a triangle, use a value of three. Circles are specified by setting this value to a large number. (> 10).
- **B** The angle where the first line segment starts. An angle of 0 is the 12:00 position.
- **C** The angle where the last line segment ends.
**RECTANGLE OBJECT**

Rectangle Objects are markable objects with four sides, and optional radiused corners. The radius changes as the object is sized.

**To modify Rectangle settings**

1. Click on the Rectangle to be modified.
2. Right-mouse click and select “Properties...”.
3. Click on the Settings tab. The Settings page displays the Rectangle object settings values.

![The Rectangle Settings page](image)

- **A** The radius of the corner as a percent of the size of the rectangle.
- **B** The number of straight line segments used to make up the corner radius.
ROUNDED RECTANGLE OBJECT

Rounded Rectangle Objects are markable objects with four sides, and optional radiused corners. The radius of the corners is fixed and independent of the size of the rectangle.

To modify Rounded Rectangle settings

1. Click on the Rounded Rectangle to be modified.
2. Right-click and select “Properties...”.
3. Click on the Settings tab. The Settings page displays the Rectangle object settings values.

The Rounded Rectangle Settings page

A. The radius of the corner.
B. The number of straight line segments used to make up the corner radius.
TEXT AND BAR CODE OBJECTS
WinLase LAN has two object types that represent strings:

- Text Objects
- Barcode objects

TEXT OBJECTS
Text Objects are a collection of alphanumeric characters that represent words, sentences, and numbers. Text objects can be either created from TrueType fonts or Laser fonts. TrueType fonts are outline fonts and are installed in the Windows operating system. Laser fonts are specially designed fonts that are installed in the WinLase LAN font library.

The Text object uses a different icon for each font type

A  Icon representing a TrueType font based text object
B  Icon representing a Laser font based text object

Top: Typical TrueType font
Bottom: Typical Laser font
To modify Horizontal and Vertical Text String settings

1. Click on the Text object to be modified.
2. Right-mouse click and select “Properties...”.
3. Click on the String tab. The String page displays the Text object string values.

The Horizontal and Vertical Text Object String page

A. The currently selected font. There are two types of fonts:
   • TrueType fonts
   • Laser fonts

B. The string value of the object

C. Change the text flow to:
   • Horizontal (default) - Text is marked along the horizontal axis.
   • Vertical - Text characters are placed vertically, each one under the previous
   • Radial Variable - Text is arranged in a circular fashion, and can be scaled independently in the x and y axes.
   • Radial fixed - Text is arranged in a circular fashion, and the object is displayed with three dotted line circles. The inner circle represents the maximum descent, the middle circle represents the circumference of the text itself, and the outer circle represents the maximum text height.
   • Circumferential - Text can be marked around the outside diameter of cylindrical parts by using a rotary motion system.

D. Change the spacing between characters
E  Enabled only when Radial - fixed is selected in the String orientation box. Change the width of the characters independent of the height.

F  Change the spacing between lines. This field is only enabled if there is more than one line of text in the edit box.

G  Change the Bold attribute of a True Type text object.

H  Change the Italic attribute of a True Type text object.

I  Use the justify buttons to control the alignment of multiple lines of text.

J  Use this Windows tool to insert special characters into the string edit box.

To modify Paragraph Text String settings:

1  Click on the text to be modified.

2  Right mouse click and select “Properties...”.

3  Click on the String tab. The String page displays the Text object string values.

The Text Object paragraph property page:

A  To space lines further apart, enter a positive number. To space lines closer together, enter a negative number. A value of zero uses the default line spacing built into the font. Note that if the current text is a single line, this field is disabled.
To modify Radial Text String settings

1. Click on the text object to be modified.
2. Right mouse click and select “Properties...”.
3. Click on the String tab. The String page displays the Text object string values.

The Text Object radial property page

A Select from the following:
- CW fit
- CCW fit

To modify Circumferential Text String settings with Intelligent Motion

<table>
<thead>
<tr>
<th>NOTE</th>
<th>• This function is available only if a compatible motion controller is detected by WinLase LAN and an appropriate motion configuration has been created</th>
</tr>
</thead>
</table>
1. Click on the text object to be modified.
2. Right mouse click and select “Properties...”.
3. Click on the String tab. The String page displays the Text object string values.
4 From the String orientation drop down list, select “Circumferential”. A new tab appears in the Property window called Motion.

5 Click the Motion tab. The Motion page displays the motion settings.

The Text Object Motion property page

A Initial velocity of the motor.
B The acceleration rate of the motor when changing velocity.
C The radius of the cylindrical part to be marked.
D Reverses the rotation direction of the motor when indexing between individual characters in the text string.
E The maximum velocity the motor will reach during a move.
F The deceleration rate when the motor is coming to a stop.
G Change the delay between when the motor has stepped to its final position and when the next character is marked. This delay allows settling time for the motor.
**BARCODE OBJECTS**

Barcode Objects represent numeric and/or alpha characters as machine-readable images. WinLase LAN Barcode Objects are offered in several different symbologies, including:

- Code 39, Extended Code 39, HIBC
- CodaBar
- Code 93
- Code 128, EAN/UCC 128
- Interleaved 2 of 5 (ITF)
- POSTNET (Zip+4, Zip+6)
- UPC A, UPC E
- EAN 8, EAN 13, BookLan
- Data Matrix (ECC200)
- Denso QR code
- PDF417
To modify Barcode String settings

1. Click on the Barcode Object to be modified.
2. Right-mouse click and select “Properties...”.
3. Click on the String tab. The String page displays the Barcode Object string values.

---

**A** The character string data for the object. Refer to the barcode specific sections that follow for the rules on what characters are allowed for each barcode type.

**B** Select this option to automatically position a text string, which represents the string content of the barcode. This option is not available in Stand-Alone mode.

**C** The font used to display and mark the text string.

**D** Where the string is positioned relative to the barcode:
- Bottom
- Top
- Left
- Right

**E** The direction the text string is drawn and marked.

**F** The height of the text string as a percentage of the barcode height.
JOB ENTITIES

Mark Entities

\[ G \] The distance from the closest part of the text to the edge of the barcode, as a percentage of the barcode height.

Left: Human Readable Text String position Bottom, Orientation 0
Middle: Human Readable Text String position Top, Orientation 180
Right: Human Readable Text String position Right, Orientation 90
To modify Code 39 settings

Code 39 is a variable length symbology that can encode a maximum of 100 characters in a single string. Each bar code is framed by a start/stop character represented by an asterisk (*). The Asterisk is reserved for this purpose and may not be used in the body of the message. WinLase LAN automatically adds the start and stop code to each barcode, so do not include them in the string.

1. Click on the Code 39 Object to be modified.
2. Right-mouse click and select “Properties...”.
3. Click on the Tuner tab. The Tuner page displays the Barcode Object tuner values.

The Code 39 tuner property page

_A Normal Code 39 is a variable length symbology that can encode the following 44 characters:
- 1234567890ABCDEFGHIJKLMNOPQRSTUVWXYZ-.*$/%_. If the string contains lower case characters, WinLase LAN will convert them to upper case, even though they appear as lower case in WinLase LAN._

_B Full ASCII is a modification of the Normal (standard) version that can encode the complete 128 ASCII character set (including asterisks). The full set of characters uses the concept of shift characters to change the meanings of the rest of the characters in the Normal Code 39 set. Please refer to the Code 39 specifications for more details._
HIBC, or “Health Industry Bar Code” is a specification for a standard method of encoding data using Code 39 in healthcare applications. When using this option, WinLase LAN automatically adds a plus character (+) as the first character, and also calculates and adds a Modulo 43 check digit.

The Bar Width Reduction parameter allows setting of a reduction or gain (-99 to 99%) in the width of all the solid bars in a barcode, as a percentage of the Narrow bar width.

Code 39 symbologies consist of bars and spaces with only two element widths, Narrow and Wide, where the width of the wide elements is a fixed multiple of the width of the narrow elements. The specifications for Code 39 allow a Narrow to Wide Ratio of 20% to 30% (2.0 to 3.0).

Code 39 allows for an optional (modulo 43) check. When this option is enabled, WinLase LAN will automatically calculate and append the proper check character to the symbol.

Inverts the dark and light bars, and adds a quiet zone around the barcode.

The size of the quiet zone as a percentage of the barcode size.
To modify CodaBar settings

CodaBar is a variable length symbology that allows encoding of the following 20 characters:

- 0123456789-$:/÷+ABCD

A maximum of 100 characters can be encoded in a single string. CodaBar uses the characters A B C and D only as start and stop characters. Thus, the first and last digits of a CodaBar message must be A B C or D and the body of the message should not contain these characters. If lower case letters are used for A B C or D, WinLase LAN will convert them to upper case, even though lower case is displayed in WinLase LAN.

1. Click on the CodaBar Object to be modified.
2. Right-mouse click and select “Properties...”.
3. Click on the Tuner tab. The Tuner page displays the Barcode Object tuner values.

The CodaBar tuner property page

A. The Bar Width Reduction parameter allows setting of a reduction or gain (-99 to 99%) in the width of all the solid bars in a barcode, as a percentage of the Narrow bar width.
CodaBar symbologies consist of bars and spaces with only two element widths, Narrow and Wide, where the width of the wide elements is a fixed multiple of the width of the narrow elements. The specifications for CodaBar allow a Narrow to Wide Ratio of 20% to 30% (2.0 to 3.0).

C Inverts the dark and light bars, and adds a quiet zone around the barcode.

D The size of the quiet zone as a percentage of the barcode size
To modify Code 93 settings

Code 93 is a variable length symbology that can encode the complete 128 ASCII character set. A maximum of 100 characters can be encoded in a single string. Code 93 incorporates two check digits as an added measure of security, and the barcode is also framed by a special start/stop character. WinLase LAN will automatically add the start and stop characters as well as the check digits, so they should not be included as part of the string value.

1. Click on the appropriate barcode object to be modified.
2. Right-mouse click and select “Properties...”.
3. Click on the Tuner tab. The Tuner page displays the Barcode Object tuner values.

The Code 93 tuner property page

A. The Bar Width Reduction parameter allows setting of a reduction or gain (-99 to 99%) in the width of all the solid bars in a barcode, as a percentage of the Narrow bar width.

B. Inverts the dark and light bars, and adds a quiet zone around the barcode.

C. The size of the quiet zone as a percentage of the barcode size.
To modify POSTNET settings

POSTNET (POSTal Numeric Encoding Technique) is a 5, 9 or 11 digit numeric only bar code symbology. The bar code may represent a five digit ZIP code (32 bars), a nine digit ZIP + 4 code (52 bars) or an eleven digit Delivery Point code (62 bars). WinLase LAN will ignore non-numeric data in the bar code string when creating the bar code image, even though the non-numeric data is displayed in WinLase LAN.

1. Click on the appropriate barcode object to be modified.
2. Right-mouse click and select “Properties…”.
3. Click on the Tuner tab. The Tuner page displays the Barcode Object tuner values.

The POSTNET tuner property page

A. The Bar Width Reduction parameter allows setting of a reduction or gain (-99 to 99%) in the width of all the solid bars in a barcode, as a percentage of the Narrow bar width.

B. Inverts the dark and light bars, and adds a quiet zone around the barcode.

C. The size of the quiet zone as a percentage of the barcode size.
To modify UPC settings

UPC-A and UPC-E are numeric only symbologies used in retail applications. When specifying UPC-A or UPC-E codes, the string may contain 6, 7, 11 or 12 digits. If the string contains 6 or 7 digits, WinLase LAN will generate a UPC-E symbol. In a 7 digit string, the 7th digit will be removed. If the string contains 11 or 12 digits, WinLase LAN will generate a UPC-A symbol. In a 12 digit string, the 12th digit will be removed. WinLase LAN automatically calculates and appends a check digit when creating the bar code image.

Both UPC-A and UPC-E allow for a supplemental two or five digit number to be appended to the main bar code symbol. The supplemental is simply a small additional bar code that is added onto the right side of a standard UPC symbol. To include a supplemental number, append it to the main number, with a comma separating it from the main number as in: 123456,12

1. Click on the appropriate barcode object to be modified.
2. Right-mouse click and select “Properties...”.
3. Click on the Tuner tab. The Tuner page displays the Barcode Object tuner values.

The UPC tuner property page

A. The Bar Width Reduction parameter allows setting of a reduction or gain (-99 to 99%) in the width of all the solid bars in a barcode, as a percentage of the Narrow bar width.
JOB ENTITIES

Mark Entities

B Inverts the dark and light bars, and adds a quiet zone around the barcode.
C The size of the quiet zone as a percentage of the barcode size
To modify Code 128 settings

Code 128 is a variable length, high density, alphanumeric symbology, and can encode a maximum of 100 characters in a single string. Code 128 has 106 different bar and space patterns, and each pattern can have one of three different meanings, depending on which of three different character sets is employed. In addition to ASCII characters, Code 128 also allows encoding of four special function codes (FNC1 - FNC4). Please refer to the Code 128 specification for more details.

1. Click on the Code 128 Object to be modified.
2. Right-mouse click and select “Properties...”.
3. Click on the Tuner tab. The Tuner page displays the Barcode Object tuner values.

The Code 128 tuner property page

A. Supports the special function codes (FNC1 - FNC4). Please refer to the Code 128 specification.
B. EAN/UCC 128 (Europäische Artikel Numerierung) is a special form of the Code 128. EAN 128 is based on Code128 but has a double start character. Also the code does not support function codes FNC2 - FNC4, and uses FNC-1 as part of the start code in the symbol.
C. WinLase LAN will automatically select the proper character sets and insert the necessary start character and shift codes so that the resulting bar code will be as short as possible. The check digit will also be calculated automatically.
**JOB ENTITIES**

*Mark Entities*

**D** Use character subset A which includes the standard ASCII symbols, digits, upper case letters, and control codes.

**E** Use character subset B which includes standard ASCII symbols, digits, upper and lower case letters.

**F** Use character subset C which compresses two numeric digits into each character, providing excellent density.

**G** The Bar Width Reduction parameter allows setting of a reduction or gain (-99 to 99%) in the width of all the solid bars in a barcode, as a percentage of the Narrow bar width.

**H** Some applications for EAN/UCC 128 require an additional Mod 10 check digit, which can be enabled by selecting this option.

**I** Inverts the dark and light bars, and adds a quiet zone around the barcode.

**J** The size of the quiet zone as a percentage of the barcode size.
To modify Interleaved 2 of 5 settings
Interleaved 2 of 5 is a high density variable length numeric only symbology that encodes digit pairs in an interleaved manner. The odd position digits are encoded in the bars, and the even position digits are encoded in the spaces. Because of this, Interleaved 2 of 5 bar codes strings must consist of an even number of digits. If an odd number of digits is entered for the string, WinLase LAN will Left-Pad one zero to the string entered, even though WinLase LAN does not display the Left-Padded digit.

1 Click on the 2 of 5 Object to be modified.
2 Right-mouse click and select “Properties...”.
3 Click on the Tuner tab. The Tuner page displays the Barcode Object tuner values.

The Interleaved 2 of 5 tuner property page
A The Bar Width Reduction parameter allows setting of a reduction or gain (-99 to 99%) in the width of all the solid bars in a barcode, as a percentage of the Narrow bar width.
B Interleaved 2 of 5 symbologies consist of bars and spaces with only two element widths, Narrow and Wide, where the width of the wide elements is a fixed multiple of the width of the narrow elements. The specifications for Interleaved 2 of 5 allow a Narrow to Wide Ratio of 20% to 30% (2.0 to 3.0).
C  Interleaved 2 of 5 optionally allows for a weighted modulo 10 check character for special situations where data security is important. When this option is selected, WinLase LAN will automatically calculate and append the proper check character to the symbol.

D  Inverts the dark and light bars, and adds a quiet zone around the barcode.

E  The size of the quiet zone as a percentage of the barcode size
To modify EAN settings

EAN or European Article Numbering system (also called JAN in Japan) is a European version of UPC. It uses the same size requirements and a similar encoding scheme as UPC codes. When specifying EAN-8 or EAN-13 codes, the string may contain 7, 8, 12 or 13 digits. If the string contains 7 or 8 digits, WinLase LAN will generate an EAN-8 symbol. In an 8 digit string, the 8th digit will be removed. If the string contains 12 or 13 digits, WinLase LAN will generate a UPC-13 symbol. In a 13 digit string, the 13th digit will be removed. WinLase LAN automatically calculates and appends a check digit when creating the bar code image.

Like UPC, both EAN-8 and EAN-13 allow for a supplemental two or five digit number to be appended to the main bar code symbol. The supplemental is simply a small additional bar code that is added onto the right side of a standard EAN symbol. To include a supplemental number, append it to the main number, with a comma separating it from the main number as in: 123456,12

1. Click on the EAN Object to be modified.
2. Right-mouse click and select “Properties...”.
3. Click on the Tuner tab. The Tuner page displays the Barcode Object tuner values.

The EAN tuner property page
A  Encodes a standard EAN symbol.
B  Encodes a BookLAN symbol, which is an EAN-13 symbol consisting of the first 9 digits of a ISBN number preceded by the digits 978 and terminated with a standard EAN check digit. Please refer to the BookLAN specification.
C  The Bar Width Reduction parameter allows setting of a reduction or gain (-99 to 99%) in the width of all the solid bars in a barcode, as a percentage of the Narrow bar width.
D  Inverts the dark and light bars, and adds a quiet zone around the barcode.
E  The size of the quiet zone as a percentage of the barcode size
To modify Data Matrix settings

Data Matrix is a high density 2 dimensional matrix style barcode symbology that can encode up to 3000 characters from the entire 256 byte ASCII character set. The symbology is built on a square (or optionally rectangular) grid arranged with a finder pattern around the perimeter of the bar code symbol.

1 Click on the Data Matrix Object to be modified.
2 Right-mouse click and select “Properties...”.
3 Click on the Tuner tab. The Tuner page displays the Barcode Object tuner values.

The Data Matrix tuner property page

A Select the resulting shape of the symbol. Automatic will generate a square grid, and the other selections will generate rectangular grids.

B Select from the following ECC (Error Checking and Correction) options:
   • ECC 000 - Provides no error correction
   • ECC 050 - Provides error correction for damage of up to 2.8% of the marked symbol
   • ECC 080 - Provides error correction for damage of up to 5.5% of the marked symbol
   • ECC 100 - Provides error correction for damage of up to 12.6% of the marked symbol
   • ECC 140 - Provides error correction for damage of up to 25% of the marked symbol
• ECC 200 - The latest and most advanced version of Data Matrix, which employs a Reed-Solomon error correction algorithm along with a code set switching mechanism that is much more efficient at packing data into the symbol. This option supports all

C When specifying ECC 000 - ECC 140, select from the following Data formats, which defines the type of data that may be encoded in the symbol:
• 1 - Numeric digits 0 to 9 and the space character
• 2 - Upper case alpha A-Z and the space character
• 3 - Upper case alphanumeric A-Z, 0-9 and the space character
• 4 - A-Z, 0-9, space, minus, period, comma and forward slash
• 5 - 7 bit ASCII - all ASCII characters between ASCII 0 to ASCII 127
• 6 - 8 bit ASCII - all ASCII characters between ASCII 0 to ASCII 255

D Adjust the size of each individual cell as a percentage of the normal size cell

E When this option is selected, then the tilde character (~) can be used in the string as an indicator that the character(s) following the tilde are to be interpreted with a special meaning. An example is when encoding UID codes. If this option is not selected, then the string is assumed to not contain any special function codes. For most applications, this option would be used.

F Inverts the dark and light bars, and adds a quiet zone around the barcode.

G The size of the quiet zone which surrounds the symbol as the number of cells.
To modify QR Code settings

QR code is a two-dimensional matrix symbol which consists of square cells arranged in a square pattern and can encode the following 4 character sets:

- Numeric data (0 to 9)
- Alphanumeric data (0 to 9, Uppercase A to Z, and nine special characters -- space, &, %, *, +, -, /, :)
- 8-bit byte data (JIS 8-bit character set (Latin and Kana) in accordance with JIS X0201)
- Kanji characters (Shift JIS values 8140h to 9FFCh and E040h to EAA4h shifted from JIS X0208)

1. Click on the QR Code Object to be modified.
2. Right-mouse click and select “Properties...”.
3. Click on the Tuner tab. The Tuner page displays the Barcode Object tuner values.

![QR Code Tuner Property Page](image-url)
A Select from the following models:

<table>
<thead>
<tr>
<th>Model</th>
<th>Size (cells)</th>
<th>Max numeric characters</th>
<th>Max Alphanumeric characters</th>
<th>Max Kanji characters</th>
</tr>
</thead>
<tbody>
<tr>
<td>Model 1</td>
<td>21 x 21 to 73 x 73</td>
<td>1167</td>
<td>707</td>
<td>299</td>
</tr>
<tr>
<td>Model 2</td>
<td>21 x 21 to 177 x 177</td>
<td>3000</td>
<td>3000</td>
<td>1817</td>
</tr>
<tr>
<td>MicroQR</td>
<td>11 x 11 to 17 x 17</td>
<td>35</td>
<td>21</td>
<td>9</td>
</tr>
</tbody>
</table>

B Select the Reed-Solomon error correction level from the following:
- L (7%)
- M (15%)
- Q (25%)
- H (30%)

C Adjust the size of each individual cell as a percentage of the normal size cell

D Inverts the dark and light bars, and adds a quiet zone around the barcode.

E The size of the quiet zone which surrounds the symbol as the number of cells.
To modify PDF417 settings

PDF417 is a high density 2 dimensional bar code symbology that essentially consists of a stacked set of smaller bar codes. The symbology is capable of encoding the entire 255 ASCII character set. A maximum of 2710 characters can be encoded in a single string.

1. Click on the PDF417 Object to be modified.
2. Right-mouse click and select “Properties...”.
3. Click on the Tuner tab. The Tuner page displays the Barcode Object tuner values.

The PDF 417 tuner property page

A. Select from the following Compaction modes:
   - Auto/EXC/Bin/Num - This mode allows full switching between the three standard data compaction modes and provides the maximum data compression possible.
   - Auto/EXC/Bin - This mode is similar to Auto/EXC/Bin/Num except it does not allow switching to Numeric mode.
   - EXC mode only - Extended Alphanumeric Compaction, which supports the encoding of all printable ASCII characters and can compress approximately 2 characters per code word.
   - Binary mode only - Supports encoding the entire ASCII character set, and can compress approximately 1.2 characters per code word.
   - Numeric mode only - Supports encoding only the numeric characters 0 - 9 and can achieve data compression of approximately 3 characters per code word.
B Select from the following Security levels:

<table>
<thead>
<tr>
<th>Security Level</th>
<th>Maximum Limit of Allowable Erasures + (2 x Misdecodes)</th>
<th>Symbol Overhead (Number of Additional Code words)</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>2</td>
</tr>
<tr>
<td>1</td>
<td>2</td>
<td>4</td>
</tr>
<tr>
<td>2</td>
<td>6</td>
<td>8</td>
</tr>
<tr>
<td>3</td>
<td>14</td>
<td>16</td>
</tr>
<tr>
<td>4</td>
<td>30</td>
<td>32</td>
</tr>
<tr>
<td>5</td>
<td>62</td>
<td>64</td>
</tr>
<tr>
<td>6</td>
<td>126</td>
<td>128</td>
</tr>
<tr>
<td>7</td>
<td>254</td>
<td>256</td>
</tr>
<tr>
<td>8</td>
<td>510</td>
<td>512</td>
</tr>
</tbody>
</table>

C If the Security Level is set to Automatic, the Error Correction overhead can be specified from 0 to 99%.

D The default maximum number of row and columns allowed in a PDF symbol is 30 rows and 90 columns. If smaller values for these parameters are specified, an upper limit is defined for the overall height or width of the generated symbol.

E The default maximum number of row and columns allowed in a PDF symbol is 30 rows and 90 columns. If smaller values for these parameters are specified, an upper limit is defined for the overall height or width of the generated symbol.

F Defines the overall shape of the symbol

G The Bar Width Reduction parameter allows setting of a reduction or gain (-99 to 99%) in the width of all the solid bars in a barcode, as a percentage of the Narrow bar width.

H Select this option to generate a Truncated PDF417 symbol. A truncated symbol is almost identical to a standard PDF417 symbol except that the right row indicator code words and the right hand stop pattern are omitted and replaced with a narrow bar one module wide.

I Inverts the dark and light bars, and adds a quiet zone around the barcode.

J The size of the quiet zone which surrounds the symbol as the number of cells.
CHANGING THE STRING AT RUN TIME (DYNAMIC STRINGS)

One of the most powerful features of WinLase LAN is the ability to dynamically change the string content of barcode and text objects while the job process is running. Changing the string can be accomplished in a number of different ways:

- Configuring the object to prompt the machine operator to enter a new string using the Supply String Source options. Not available in Stand-Alone mode.
- Configuring the object to automatically serialize it’s text string using the Serialize Source option.
- Reading consecutive strings from a text file using the TextMerge Source option. Not available in Stand-Alone mode.
- Configuring the object to retrieve the next text string to mark from an internal memory buffer using the Get string from memory buffer Source option.
- Automatically retrieve the current time/date settings from the operating system for the AutoDate feature.
- Configure complex combinations of string components using the Custom String Source option.
- Configure the job so strings can be changed while in Stand-Alone mode using the Controlled from Remote API Source option.

To control the justification of the Object

The way an object justifies after rendering its image with the new string it receives during run time can be configured using the Justify settings.

- From the Source tab, select the appropriate radio button corresponding to the justification desired. This feature is for single line text or barcodes only.

<table>
<thead>
<tr>
<th>NOTE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dynamic Text is only possible in Stand-Alone mode when using Laser Fonts. See “Creating a new Laser font” on page 5-38 and “Adding a new Laser font to an LEC-1 device” on page 5-40 for more information.</td>
</tr>
<tr>
<td>Dynamic Text only supports Barcode types: Data Matrix, Code 128. For additional symbology support, please consult the factory.</td>
</tr>
</tbody>
</table>

WinLase LAN User Guide 6-59
Controlling how the User Interface updates when strings are dynamically changed

During the execution of a job that contains Dynamic Strings, the object can be configured to display the previous string, or the next string to be marked in the WinLase LAN workspace. For example, if using the TextMerge function, what the next string to mark will be, before marking the part. In this case, the screen is displaying the next string. In other situations, it may be desirable to compare the string displayed on the screen after the mark is complete. In this case the screen would display the previous string.

- To see the next string on-screen, from the Source tab, select “Update String before mark”
- To see the previous string on-screen, deselect “Update String before mark”

- To refresh the screen while the Run dialog is open, it may be necessary to click the Refresh button.
To configure the Text Merge option

Create or link to a text file, and select the desired justification to use when merging the next string from the text file. At runtime, the object will automatically extract the correct line or lines from the text file, and mark the barcode on the part. TextMerge is a feature that allows large lists of string values, such as names, etc. to be “merged” with the text object while the Job is running. A text merge file is a simple text file, with a .txt extension. Each contiguous string must be separated by a carriage return (Enter key). The last line of the text merge file must also have a carriage return as well. Single lines, as well as multi-line merge operations are available. Multi-line text merge operation is made possible by using the # objects in group and the Start line values. A detailed description of these features is in the following section.

NOTE
- Not available in Stand-Alone mode

1. Click on the string Object to be modified.
2. Right-mouse click and select “Properties...”.
3. Click on the Source tab. The Source page displays the Source values.

![Text Merge Settings](image)
The TextMerge property page

A The text file to link to at run time. The text file is read once when the Job is first started, and then written to at the end of a Job to save the current text file line location.

B Create and save a text merge file with this button

C Change the number of objects in a multi-line merge group. An example of a multi-line merge group is a Name and Company Name. The Job would consist of two text objects, positioned appropriately, each using the same MergeFile. Both objects would have the # objects in group set to 2. The first object to mark would have the Start line value set to 1, and the second object to mark would have the Start line value set to 2.

D Change the starting line in a multi-line merge group. An example of a multi-line merge group is a Name and Company Name. The Job would consist of two text objects, positioned appropriately, each using the same MergeFile. Both objects would have the # objects in group set to 2. The first object to mark would have the Start line value set to 1, and the second object to mark would have the Start line value set to 2.

E Edit an existing text file with this button.

F Locate and insert a text merge file with this button.
To configure the AutoDate option

The calendar date, time, or shift code will be automatically inserted, using the justification selected, and the date format selected. AutoDate automatically inserts a time related string retrieved from the Windows system clock into the objects string value at runtime. The original object can be regarded as a placeholder for the date to be inserted during Job execution.

1. Click on the string Object to be modified.
2. Right-mouse click and select “Properties...”.
3. Click on the Source tab. The Source page displays the Source values.
4. From the String rules drop down list, select “Use AutoDate”. The AutoDate settings appear.

The AutoDate property page

Using the date January 15, 2009 as an example, the available AutoDate formats are:

- **YYMMDD** - Object will print a barcode representation of: 090115
- **MM/DD/YY** - Object will print a barcode representation of: 01/15/09
- **DD/MM/YY** - Object will print a barcode representation of: 15/01/09
- **Month DD YYYY** - Object will print a barcode representation of: January 15 2009
- **DD Month YYYY** - Object will print a barcode representation of: 15 January 2009
- **YWW** - Object will print a barcode representation of: 902, where WW is the week number.
• YMD - Object will print a barcode representation of: 912
• JJJ - Object will print a barcode representation of: 015, where JJJ is the three-digit day of the year.
• JJJY - Object will print a barcode representation of: 0159, where JJJ is the three-digit day of the year, and Y is the single digit year.
• YY - String will print 09.
• Shift code - String will print a custom value depending on the settings chosen. Details on using the shift code feature are in the next section.
• DMY - String will print 15019.
• HH:MM:SS - String will print the current system time.
To configure the AutoDate > Shift Code option

1. Click on the string Object to be modified.
2. Right-mouse click and select “Properties...”.
3. Click on the Source tab. The Source page displays the Source values.
4. From the String rules drop down list, select “Use AutoDate”.

The Shift code property page

A  Changes the start time at which this particular shift code is valid.
B  Enables or disables multiple shift codes. If multiple shifts have overlapping times, the first shift that is valid is used, and the rest are ignored. If there are times that are not specified within any of the enabled shifts, a “?” is returned.
C  Changes the stop time where this particular shift code is no longer valid.
D  Changes the character string to mark if this shift code is valid.
To configure the Supply String at Start option

Before the Job is run, the operator is prompted to enter a text string, which will be used throughout the running of the Job. The next string value will use the selected justification. The Supply string at start feature will prompt the operator to supply a new string value just after the Job > Run button is clicked. This new value is then used until the process is stopped.

1 Click on the string Object to be modified.
2 Right-mouse click and select “Properties...”.
3 Click on the Source tab. The Source page displays the Source values.
4 From the String rules drop down list, select “Supply string at start”. The Supply string at start settings appear.

To configure the Supply String Every Mark option

Prompts the operator to supply a text string before each mark is executed, using the selected justification. Short production runs are typical of this example. For larger volumes, the TextMerge feature should be used. The Supply string every mark feature will prompt the operator to supply a new string value just before the object is scheduled to mark.

1 Click on the string Object to be modified.
2 Right-mouse click and select “Properties...”.
3 Click on the Source tab. The Source page displays the Source values.
4 From the String rules drop down list, select “Supply string every mark”. The Supply string every mark settings appear.

NOTE
• Not available in Stand-Alone mode
To configure the Serialize options

Uses the current string value as the start of a serialization sequence, using the selected justification. The increment controls the amount the alphanumeric string value is incremented each mark, and the batch value controls how many cycles to wait before incrementing. To automatically increment or decrement a Barcode Objects string value, use this feature. When the Job starts, the first value marked by the object will be the current string value that was saved with the Job. Prompts the operator to supply the starting value of a serialization sequence, using the selected justification. The increment controls the amount the alphanumeric string value is incremented each mark, and the batch value controls how many cycles to wait before incrementing. This feature is the same as Serialize with Current Start Value, except the operator will be prompted to supply the starting value of the serialization sequence.

1. Click on the string Object to be modified.
2. Right-mouse click and select “Properties...”.
3. Click on the Source tab. The Source page displays the Source values.
4. From the String rules drop down list, select “Serialize with current start value” or “Serialize with supplied start value”. The Serialize settings appear.

The Serialize property page
JOB ENTITIES

Mark Entities

A There are two options available for serialization:

• Serialize with current start value - This option will start serializing with the value that the text object had when the job was saved. To save the current value of the text object to the job automatically when the job is running, see “To continuously save Dynamic string changes” on page 7-13.

• Serialize with supplied start value - When the job is run, the operator is prompted to enter the starting serial number. See “To respond to the Enter Character String dialog box” on page 7-19 for more details.

B Changes the serialization increment value. Serialization is alpha as well as numeric; 0001A will increment to 0001B. Note that alpha serialization is only valid on ANSI text. Unicode alpha text may not increment correctly. Leading zeros are retained in the string if the format of the object allows it, otherwise they are removed.

C When a number greater than one is placed in the batch field, the object will not increment until “batch” mark cycles have taken place. On the next mark, the object will increment by “increment”.

D Select this option to automatically reset the serial number based on specified conditions.
To automatically reset the serial number

- Select the “Automatically reset serial number” option.

**Reset when threshold is reached**

**A** When the threshold is reached, the serial number is reset to this value. The reset value can have leading zeros.

**B** The value at which the serial number is reset.

**Reset when specific I/O port is HIGH**

**A** When the I/O port is set, the serial number is reset to this value. The reset value can have leading zeros.

**B** The input port to check before marking the object. If the port is set, the serial number is reset.

**Reset when specific time is reached**

**A** When the specified time is reached, the serial number is reset to this value. The reset value can have leading zeros.

**B** Before the object is marked, the time is checked, and if the PC time is after the specified time, the serial number will reset.
To configure the Get String from Memory Buffer option

During runtime, the string object will retrieve the string content to mark from an internal memory buffer. There are 10 buffers available, and these buffers can be filled with string values from outside equipment. The maximum string length for each buffer is 3000 characters. To change a string objects string from an external program while the Job is running, use this feature. Just before the object is scheduled to mark, the string will be retrieved from the selected memory buffer. An external program can simply set any of the ten available memory buffers with a string value, and does not need to know about the internal structure of a particular Job file.

1. Click on the string Object to be modified. Right-mouse click and select “Properties...”.
2. Click on the Source tab. The Source page displays the Source values.
3. From the String rules drop down list, select “Get String from memory buffer”. The memory buffer settings appear.

The Memory Buffer property page

A. Changes an index value from 1 to 10, corresponding the 10 memory buffers available.
B. Displays the current contents of the internal memory buffer. The buffers are initialized with a '?' when the application starts. To refresh the display, change the buffer index to another value, and then back to the desired index.
Using the Custom String feature

Using a format specifier string, you can build a customized mark string from a list of available format specifiers. To change a string object's string to a customized mark string while the marking Job is running, use this feature. Just before the object is scheduled to mark, the string will be assembled using the format specifier instructions saved with the object.

1. Click on the string Object to be modified.
2. Right-mouse click and select “Properties...”.
3. Click on the Source tab. The Source page displays the Source values.
4. From the String rules drop down list, select “Get String from memory buffer”. The memory buffer settings appear.

A

Customize the mark string using this specifier string. See the following Format Specifier Table for a list of available specifiers.
### SPECIFIER

<table>
<thead>
<tr>
<th>Specifier</th>
<th>Example</th>
<th>Data inserted into string</th>
</tr>
</thead>
<tbody>
<tr>
<td>%A</td>
<td></td>
<td>Abbreviated Weekday (Mon, Tue, Wed, Thu, Fri, Sat, Sun)</td>
</tr>
<tr>
<td>%B</td>
<td></td>
<td>Abbreviated Month (Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec)</td>
</tr>
<tr>
<td>%C</td>
<td></td>
<td>Date and Time (MM/DD/YY HH:MM)</td>
</tr>
<tr>
<td>%D</td>
<td></td>
<td>Day of the Month (01 - 31)</td>
</tr>
<tr>
<td>%d, %e, %y</td>
<td></td>
<td>See Note A: Map a string to a Day of the month (See Note A)</td>
</tr>
<tr>
<td>%E</td>
<td></td>
<td>Inserts current string value of object</td>
</tr>
<tr>
<td>%f, i</td>
<td></td>
<td>Inserts a string from another object, where i = zero-based object index</td>
</tr>
<tr>
<td>%I , %j, %s</td>
<td></td>
<td>See Note D: Insert text string, s = string to insert (See Note F)</td>
</tr>
<tr>
<td>%i, i</td>
<td></td>
<td>Inserts a string from another object, where i = zero-based object index, and numerically adds the value to the string (See Note G)</td>
</tr>
<tr>
<td>%J</td>
<td></td>
<td>Julian Day of the Year (001 - 366)</td>
</tr>
<tr>
<td>%K</td>
<td></td>
<td>Month Code (1 - 9, O, N, D)</td>
</tr>
<tr>
<td>%L</td>
<td></td>
<td>Last Digit of the Year (0 - 9)</td>
</tr>
<tr>
<td>%M</td>
<td></td>
<td>Month (01 - 12)</td>
</tr>
<tr>
<td>%n</td>
<td></td>
<td>Seconds of the Hour (00 - 59)</td>
</tr>
<tr>
<td>%N</td>
<td></td>
<td>Minutes of the Hour (00 - 59)</td>
</tr>
<tr>
<td>%O</td>
<td></td>
<td>Serial Number, increments by 1, starts with value 1 at start of process</td>
</tr>
<tr>
<td>%P</td>
<td></td>
<td>AM or PM</td>
</tr>
<tr>
<td>%Q#</td>
<td></td>
<td>Inserts string from memory buffer # (1-10)</td>
</tr>
<tr>
<td>%R</td>
<td></td>
<td>Week Number (01 - 53) [week 01 is week containing January 1]</td>
</tr>
<tr>
<td>%S, m, s, i, b</td>
<td></td>
<td>Serial number, m = maximum value, s = start value, i = increment, b = batch (See Note B)</td>
</tr>
<tr>
<td>%T</td>
<td></td>
<td>Time (HH:MM)</td>
</tr>
<tr>
<td>%U, e, c, s</td>
<td></td>
<td>Shift code, b = begin time, c = end time, s = string to insert (See Note C)</td>
</tr>
<tr>
<td>%W</td>
<td></td>
<td>Weekday (where: 1 = Monday… 7 = Saturday)</td>
</tr>
<tr>
<td>%x</td>
<td></td>
<td>Weekday (where: 1 = Monday… 7 = Saturday)</td>
</tr>
<tr>
<td>%x#</td>
<td></td>
<td>Insert number of spaces in string</td>
</tr>
<tr>
<td>%y</td>
<td></td>
<td>Year (00 - 99)</td>
</tr>
</tbody>
</table>
Notes

A The %G specifier is used to map a string value to the Hour of the day. There are 24 mandatory positions after the specifier, and each position corresponds to an Hour of the day value, in 24 hour format. The following is an example: %G,a,b,c,d,e,f,g,h,i,j,k,l,m,n,o,p,q,r,s,t,u,v,w,x In this example, at midnight (hour = 0), an 'a' will be inserted, at 01:00, a 'b' will be inserted, and so on.

B The text object will mark the start value first, then increment until it reaches the maximum value. The next mark will reset to the start value. If leading characters are required, make sure the total number of characters is the same for both the start value and maximum value (e.g. 0001 and 9999). Alpha characters are allowed, and will be incremented based on the ASCII value of the character. Batch will allow skipping of an increment event. For example, if batch = 2, the object will mark the same string two times before incrementing to the next value.

C Time values must be in the 24 hour time format. If the current time is between the begin time and the end time, the string between the single quotes will be inserted, otherwise nothing will be inserted. To program a shift that goes across 00:00 (midnight), use one shift to 23:59 and another shift from 00:00.

D The %m specifier is used to map a string value to the current Month. There are 12 mandatory positions after the specifier, and each position corresponds to a Month value. The following is an example: %m,a,b,c,d,e,f,g,h,i,j,k,l > In this example, in May an 'e' will be inserted, in October a 'j' will be inserted, and so on.

E The %d specifier is used to map a string value to the current Day. There are 31 mandatory positions after the specifier, and each position corresponds to a Day of the month value. The following is an example: %d,1,2,3,4,5,6,7,8,9,A,B,C,D,E,F,G,H,I,J,K,L,M,N,O,P,Q,R,S,T,U,V > In this example, on the second Day of the month a '2' will be inserted, on the fifteenth day an 'F' will be inserted, and so on.

F The %I specifier is used to insert a string into a specific position in the current string, using a position and justification variable. The position variable starts with an index of 1. The justification variable is defined as 0 = left justification, 1 = right justification. For example, if the current string is Lanmark, and we specify %I,3,0,'Controls' the result would be LaControlsnmark. If we specify %I,1,1,'Controls' the result would be LanmarkControls

G The %i specifier is used to obtain a string from another object using a zero-based index variable, and add an integer value to the string using a value variable. The string obtained from the object must be numerical only (no alpha characters). For example, if the string obtained from an object at index 0 is 1000, and we specify %i,0,3 the result would be 1003

Example marked on February 24, 2009:
Format Specifier String:%D%X1%M%X1%Y%X1%VPART#: 100
Resulting marked string:24 02 09 PART#: 100
Changing text strings from an external controller in Stand-Alone mode

There are a number of ways a Text object can be configured to change its text string automatically when in Stand-Alone mode:

- Serialization
- AutoDate
- Get string from Memory Buffer

If the requirement is to send a new Text string from an external controller such as a PLC or another PC, the text object must be configured to allow this capability.

1. Click on the string Object to be modified.
2. Right-mouse click and select “Properties...”.
3. Click on the Source tab. The Source page displays the Source values.
4. From the String rules drop down list, select “Controlled by Remote API”.

![Text Properties](image)
DOT MATRIX LASER FONTS
Dot Matrix Laser Fonts provide a fundamentally different way to mark text from the standard vector-marking format. With Dot Matrix Laser Fonts, the text is comprised of closely spaced dots, similar to a bitmap object. The Dot Matrix Laser Font offers control over the number of times the laser will fire at each dot. The following images illustrate some of the effects that are achieved by adjusting the dot matrix parameters.

Left: On screen display using dot display size of 200 bits
Right: On screen display using dot display size of 50 bits

To modify Dot Matrix Laser Font settings

1. Click on the Dot matrix text style object to be modified.
2. Right-mouse click and select “Properties...”.
3. Click on the Settings tab. The Settings page displays the Text object settings values.
4 In the Mark Style drop-down, select Dot.

The Dot Settings page

A Changes the size of each individual dot as it is displayed in WinLase LAN. This value has no effect on the actual mark. If the dot size is set to the effective spot size of the laser on the material, correct dot spacing can be visualized on screen.

B The length of time the laser is on during a single pulse.

C The time the laser is off between successive pulses.

D This setting controls the number of times the laser will fire at each dot within the array of dots that comprise a character. The laser is turned on using the settings of frequency and pulse width found on the Profiles page.
FILLING BARCODES WITH DOTS OR CIRCLES

Dot mode provides a fundamentally different way to mark barcodes from the standard vector-marking format. In Dot mode, the barcode is comprised of closely spaced dots, similar to a bitmap object. The Dot mode barcode object offers additional control over dot spacing, and the number of times the laser will fire at each dot. The following images illustrate some of the effects that are achieved by adjusting the Dot parameters. In Circle mode, the barcode is comprised of closely spaced circles. The Circle Dot mode barcode object offers additional control over circle dot spacing, the number of sides on each circle, and the diameter of each circle.

To modify Linear barcode Dot Setting Values

1. Click on the linear barcode object to be modified.
2. Right-mouse click and select “Properties...”.
3. Click on the Settings tab. The Settings page displays the Text object settings values.
In the Mark Style drop-down, select Dot.

The Dot Settings page

A Control the spacing between adjacent dots.
B Changes to the size of the dot on screen have no effect on the mark.
C The length of time the laser is on during a single pulse.
D The time the laser is off between successive pulses.
E This setting controls the number of times the laser will fire at each dot within the array of dots that comprise a character. The laser is turned on using the settings of frequency and pulse width found on the Profiles page.
F Display and mark the rectangular outline that represents each individual bar.
To modify 2D bar code Dot settings

1. Click on the 2D barcode object to be modified.
2. Right-mouse click and select “Properties...”.
3. Click on the Settings tab. The Settings page displays the Text object settings values.
4. In the Mark Style drop-down, select “Dots”.

The Dots Settings page

A. Select the number of rows and columns of dots to place in each cell.
B. Control the spacing between adjacent dots.
C. Changes to the size of the dot on screen have no effect on the mark.
D. The length of time the laser is on during a single pulse.
E. The time the laser is off between successive pulses.
F. This setting controls the number of times the laser will fire at each dot within the array of dots that comprise a character. The laser is turned on using the settings of frequency and pulse width found on the Profiles page.
G. Display and mark the rectangular outline that represents each individual cell.
To modify linear bar code Circle settings

1. Click on the linear barcode object to be modified.
2. Right-mouse click and select “Properties...”.
3. Click on the Settings tab. The Settings page displays the Text object settings values.
4. In the Mark Style drop-down, select “Circles”.

The Circles Settings page

A. The spacing between adjacent circles.
B. The number of straight line vector segments that make up the circle.
C. The diameter of each individual circle.
D. Display and mark the rectangular outline that represents each individual bar.
To modify 2D bar code Circle settings

1. Click on the linear barcode object to be modified.
2. Right-mouse click and select “Properties...”.
3. Click on the Settings tab. The Settings page displays the Text object settings values.
4. In the Mark Style drop-down, select “Circles”.

The Circles Settings page

A. The number of rows and columns of circles that are placed in each cell.
B. The spacing between adjacent circles.
C. The number of straight line vector segments that make up the circle.
D. The diameter of each individual circle.
E. Display and mark the rectangular outline that represents each individual cell.
VECTOR GRAPHIC OBJECT

Unlike JPEGs, GIFs, and BMP images, vector graphics are not made up of a grid of pixels. Instead, vector graphics are comprised of paths, which are defined by a start and end point, along with other points, curves, and angles along the way. A path can be a line, a square, a triangle, or a curvy shape. These paths can be used to create simple drawings or complex diagrams. Paths are even used to define the characters of specific typefaces.

Because vector-based images are not made up of a specific number of pixels, they can be scaled to a larger size and not lose any image quality. When you scale up a vector graphic, the edges of each object within the graphic stay smooth and clean. Vector images are ideal for use with laser marking equipment, as the scan head is a vector output device.

To modify Vector Graphic curve settings

1. Click on the Vector Graphic to be modified.
2. Right-mouse click and select “Properties...”.
3. Click on the Settings tab. The Settings page displays the Vector object settings.
The Vector graphic Settings page

A The size that each individual Point entity is displayed on the screen in WinLase LAN. This value has no effect on the mark.

B The length of time the laser is on during a single pulse at each Point entity.

C The time the laser is off between successive pulses at each Point entity.

D The number of times to pulse the laser at each Point entity location. WinLase LAN.

E Select the number of straight line vector segments to use when rendering an arc section into vectors. More segments will produce a smoother curve, but will increase the number of vectors.

F Select the number of straight line vector segments to use when rendering a spline section into vectors. More segments will produce a smoother curve, but will increase the number of vectors.

G Select the number of straight line vector segments to use when rendering text into vectors. More segments will produce a smoother curve, but will increase the number of vectors.

H Select the number of straight line vector segments to use when rendering a Bezier curve section of a text curve into vectors. More segments will produce a smoother curve, but will increase the number of vectors.

IMPORTING GRAPHICS AT ACTUAL SIZE

Some vector graphics files, such as EMF, DXF and DWG files, contain information to scale the vector coordinates contained in the file into real world dimensions. If the file contains this Unit information, WinLase LAN can use it to import the graphic to “actual size”. Without this Unit information, WinLase LAN will import the graphic using dimension units of BITS. See “Coordinate System Conventions” on page 5-1. Refer to the following table for import behavior with the different graphics files. WinLase LAN.

<table>
<thead>
<tr>
<th>File Type</th>
<th>Contains Units</th>
<th>WinLase LAN import behavior</th>
</tr>
</thead>
<tbody>
<tr>
<td>DWG</td>
<td>Optional</td>
<td>User is presented with import options</td>
</tr>
<tr>
<td>DXF</td>
<td>Optional</td>
<td>User is presented with import options</td>
</tr>
<tr>
<td>EMF</td>
<td>Optional</td>
<td>If Units are detected, they are used. If no Units detected, coordinate values in file assumed to be BITS</td>
</tr>
<tr>
<td>PLT</td>
<td>No</td>
<td>Units are always in BITS</td>
</tr>
<tr>
<td>WLO</td>
<td>No</td>
<td>Units are always in BITS</td>
</tr>
<tr>
<td>WMF</td>
<td>No</td>
<td>Units are always in BITS</td>
</tr>
</tbody>
</table>
When importing DXF and DWG files

1. Form the Main menu, click File > Import. The Import dialog box appears.
2. Browse to a DXF or a DWG file and click Open. The Import AutoCAD file dialog appears.

The Import AutoCAD dialog window

A. The version of the file being imported.
B. The Units that were detected in the file. AutoCAD version 14 and older did not support real world units and the graphic units will be indicated as “Unspecified”.
C. Select what action WinLase LAN should take when importing the graphic:
   - Automatic - This is the default setting. If the file was saved with real world units, it will be imported and sized in WinLase LAN to actual size. If the units in the file are unspecified, WinLase LAN assumes the units are Millimeters when converting coordinates.
   - English - Forces WinLase LAN to use units of Inches when converting coordinates.
   - Metric - Forces WinLase LAN to use units of Millimeters when converting coordinates.
D. If an image will size import larger that the field size, this option will scale the image to just fit into the field. Note that the graphic will no longer be actual size.
E. This option will center the image in the field independent of where it was drawn with respect to the origin.
AUTOMATION OBJECTS

Automation Objects provide a means to communicate with external handlers and motion controllers to automate a marking process, and to automate a process within WinLase LAN itself. Some Automation objects are valid for execution locally on the PC and some can also be executed on the LEC-1 controller card in Stand-Alone mode. WinLase LAN supports the following Automation Objects:

- **Alignment Tool** - Provides the ability to transform and objects position scaling and rotation based on data in an alignment file, or in a memory buffer location. Not available in Stand-Alone mode.

- **Custom Axis** - OMS Controller only. An object used to control an attached motor that can be customized from the Motor Controller Properties dialog. Not available in Stand-Alone mode.

- **Insert Time Delay** - Inserts a specified time delay between objects within a job.

- **Laser Control**, which provides direct control of a laser. Not available in Stand-Alone mode.

- **Linear Motion** - Intelligent Motion only. An object used to control an axis configured as linear motion. Not available in Stand-Alone mode.

- **Rotary Indexer** - OMS Controller only. An object used to control an attached Rotary Indexer. Not available in Stand-Alone mode.

- **Rotary Motion** - Intelligent Motion only. An object used to control an axis configured as rotary motion. Not available in Stand-Alone mode.

- **Run Application** - An object used to start an external executable file or an external batch file. Not available in Stand-Alone mode.

- **Serial Communication** - An object used to output a single string, or series of strings using a COM port. Not available in Stand-Alone mode.

- **Set I/O Port** - Sets a User Out output port HIGH, LOW, or pulses the output.

- **Show Messagebox** - Displays a message box on screen, and the job waits until the message box is closed before continuing. Not available in Stand-Alone mode.

- **Wait for External Signal** - An object used to poll The User In inputs and wait until that a programmed input is received.

- **XY Table** - OMS Controller only. An object used to control an attached XY Table. Not available in Stand-Alone mode.

- **XY Motion** - Intelligent Motion only. An object used to control two axes configured as xy motion. Not available in Stand-Alone mode.
ALIGNMENT TOOL

WinLase LAN supports the use of alignment files during job execution. Alignment files are text-based files that describe offsets and rotation to be applied to the complete job. The alignment tool object also supports manually entered alignment data, as well as the ability to get the alignment data from one of the internal memory buffers. When an Alignment Tool object executes, the alignment changes are applied to all objects in the job. Multiple alignment tasks can be accomplished by adding as many Alignment Tool objects as required.

**NOTE** • Not available in Stand-Alone mode

**To modify Alignment Tool settings**

1. Click on the desired Alignment Tool Object in Object Manager.
2. Right-mouse click and select “Properties...”. The Alignment Tool Properties window appears.

The Alignment Tool property page with “Use settings from this object” selected

A. The X offset amount to apply to all objects in the job.
B. The Y offset amount to apply to all objects in the job.

C. The Z offset amount to apply to all objects in the job.
D. The Rotation Angle amount.
E. The X center offset amount.
F. The Y center offset amount.
G. The Test button to test the alignment changes.
**JOB ENTITIES**

*Automation Objects*

---

**C** The Z offset (de focus) amount to apply to all objects in the job. The scanning hardware must support 3-axis scanning for this value to have any affect.

**D** The amount of rotation to apply to all objects in the job.

**E** The X center of rotation used when applying Angle. To rotate an object about the center of the field, the center of rotation would be X center = 0, Y center = 0. To rotate the object about its center, the center of rotation would be the coordinates of the center of the object.

**F** The Y center of rotation used when applying Angle. To rotate an object about the center of the field, the center of rotation would be X center = 0, Y center = 0. To rotate the object about its center, the center of rotation would be the coordinates of the center of the object.

**G** Click this button to test the settings.

---

The Alignment Tool property page when “Import settings from alignment file” is selected

**A** A new Alignment file can be created by clicking the New button and choosing a file name and location. A new Alignment file with default settings is created.

**B** An existing Alignment file that has already been loaded can be edited by clicking the Edit button. When editing is complete, the changes can be saved back to the file by clicking Save.

**C** To load an existing Alignment file, click the Browse button to locate the Alignment file.
D The name of the current alignment file.

The Alignment Tool property page when "Get settings from memory buffer" is selected:

A Select and index value from 1 to 10, corresponding the 10 memory buffers available.

B Displays the current contents of the internal memory buffer. The buffers are initialized with a '?' when the application starts.
**FORMATTING THE BUFFER STRING**

When sending a string to a memory buffer, it must be formatted in the following way:

```
<xoffset>,<yoffset>,<zoffset>,<angle>,<xcenter>,<ycenter>
```

where:

- `xoffset` = millimeters, with 5 decimal places (0.0000)
- `yoffset` = millimeters, with 5 decimal places (0.0000)
- `zoffset` = millimeters, with 5 decimal places (0.0000)
- `angle` = degrees, with 5 decimal places (0.0000)
- `xcenter` = millimeters, with 5 decimal places (0.0000)
- `ycenter` = millimeters, with 5 decimal places (0.0000)

Example: The following string will offset all objects in the job by 10mm in X, 20mm in Y and will rotate all objects about the center of the field 45 degrees:

```
10.00000,20.00000,0.00000,45.000,0.00000,0.00000
```
CUSTOM AXIS

The Custom Axis Object provides control over a generic motor axis. The custom axis can be configured for either linear or rotary applications. An optional OMS PCIx-004 motor controller card is required to control the external motor axis.

**NOTE**

- Not available in Stand-Alone mode

To modify Custom Axis settings

1. Click on the desired Custom Axis Object in Object Manager.
2. Right-mouse click and select "Properties...". The Custom Axis Properties window appears.

The Custom Axis property page

- **A** The units in which the “Move to” values are displayed, which can be one of the following:
  - The units are in mm of travel along the parts surface.
  - The units are in inches of travel along the parts surface.
  - Displays only if the axis has been set up as a rotary axis. The units are in degrees of motor rotation.
  - The units are in steps of motor rotation.

- **B** The mode of the motor movement, which can be one of the following:
  - Absolute - The motor will move to the actual absolute position indicated in “Move to”.
• Relative - The motor will move the amount in “Move to” from the current motor position.

C The current position count of the motor

D Apply the current position value to the “Move to” value

E The position to move the motor to when the object is executed. If the Moves are setting is Absolute, the motor will move to the absolute position indicated in “Move to”. If the Moves are setting is Relative, the motor will move the amount in “Move to” from its current position.

F The speed at which the motor will execute the move in steps/s.

G Executes the indicated “Move to” settings immediately on the custom motor axis

H Executes the Home command immediately on the custom motor axis.

I Immediately stops movement of the custom motor axis.
**INSERT TIME DELAY**

The Insert Time Delay objects inserts a specified time delay between objects within a process.

**To modify Insert Time Delay settings**

1. Click on the desired Insert Time Delay Object in Object Manager.
2. Right-mouse click and select “Properties...”. The Insert Time Delay Properties window appears.

The Insert Time Delay property page

A. Specifies the delay time in ms.
B. If this option is selected, the time delay will execute on the LEC-1 device using the Windows CE timer. Otherwise, it will execute on the PC using the PC timer.
LASER CONTROL

The Laser Control object provides a way to turn the laser on and off directly within the context of a job.

**NOTE** • Not available in Stand-Alone mode

**To modify Laser Control settings**

1. Click on the desired Laser Control Object in Object Manager.
2. Right-mouse click and select “Properties...”. The Laser Control Properties window appears.

The Laser Control Settings property page

A. Select from the following control modes:
   • Turn laser off - Immediately turns the laser off when the object executes, if the laser was turned on by a previous Laser Control object. If the laser is already off, this setting will do nothing.
   • Turn laser on and leave on - Immediately turns the laser on when the object executes. If the laser is already on, this setting will do nothing.
   • Turn laser on for specified time - Turns the laser on for the time specified in “Duration” when the object executes, then turns laser off.

B. The power the laser will use when it turns on.

C. The frequency of the laser control signal when the laser turns on.
The pulse width of the laser control signal when the laser turns on.

The duration the laser is on if Mode is set to “Turn laser on for specified time”
LINEAR MOTION
The Linear Motion object provides control over a linear motion axis, and is synchronized with marking objects within the job.

NOTE • Not available in Stand-Alone mode

To modify Linear Motion settings
1 Click on the desired Linear Motion Object in Object Manager.
2 Right-mouse click and select “Properties...”. The Linear Motion Properties window appears.

The Linear Motion Settings property page
A Assign this motion object to a specific hardware axis. There must be the correct motion type configured in the Motion Configuration. See Understanding the Motion Types.
B Select from the following Move modes:
   • Move to an absolute position - The axis will move to the actual absolute position indicated in “Move” when the object executes.
   • Move a relative amount - The axis will move the amount in “Move” from the current motor position when the object executes.
   • Perform a homing routine - The axis will perform a homing routine based on the home settings of the axis when the object executes.
• Stop the axis - The axis will be stopped if it was moving as a result of a previous motion object when the object executes.
• Move continuously in the positive direction - The axis will move towards the positive limit when the object executes. The axis will continue to move until either hitting a limit switch, or if stopped by another motion object.
• Move continuously in the negative direction - The axis will move towards the negative limit when the object executes. The axis will continue to move until either hitting a limit switch, or if stopped by another motion object.

C A reset condition can be configured so that after the specified number of cycles, the axis will perform a reset function. The reset modes are:
• <disabled> - Disable the reset functionality
• Move to an absolute position - The axis will move to the actual absolute position indicated in “Reset to” when the reset condition is met.
• Move a relative amount - The axis will move the amount in “Reset to” from the current motor position when the reset condition is met.
• Perform a homing routine - The axis will perform a homing routine based on the home settings of the axis when the reset condition is met.
• Move continuously in the positive direction - The axis will move towards the positive limit when the reset condition is met. The axis will continue to move until either hitting a limit switch, or if stopped by another motion object.
• Move continuously in the negative direction - The axis will move towards the negative limit when the reset condition is met. The axis will continue to move until either hitting a limit switch, or if stopped by another motion object.

D The amount to move the axis when performing a normal move
E The initial speed the axis moves at while accelerating to the slew speed
F The acceleration rate of the axis when changing from the initial speed to the slew speed
G The object can be configured to skip execution by setting this parameter greater than 1. For example, to execute the object every third job cycle, set this value to 3.
H The amount to move the axis when performing a reset move
I After the axis has completed the preprogrammed motion, wait for an amount of time before executing the next object in the job list.
J When the option is selected, all axis movement will be opposite normal movement
K The maximum speed the axis will attain when executing a move.
L The deceleration rate of the axis when changing from the slew speed to a stop at the end of the programmed travel.
M The number of cycles the object needs to execute before triggering a reset. When the reset is triggered, the axis will perform the action specified in “Reset move mode”.
N Change the display units for all values in the current window.
CHAPTER 6

JOB ENTITIES

Automation Objects

ROTARY INDEXER
The Rotary Indexer Object provides control over an external rotary indexer. An optional OMS PCIx-004 motor controller card is required to control the external rotary indexer.

NOTE
• Not available in Stand-Alone mode

To modify Rotary Indexer settings
1. Click on the desired Rotary Indexer Object in Object Manager.
2. Right-mouse click and select “Properties...”. The Rotary Indexer Properties window appears.

The Rotary Indexer property page
A. The radius of the part being rotated. This value is used to calculate the circumference of the part, and allows a distance along the part to be entered in the “Move to” value.
B. Enter the amount of process cycles to execute before the rotary indexer executes its move. For example, if the cycle is set to 2, the process must complete two complete cycles before the indexer will rotate.
C. The units in which the “Move to” values are displayed, which can be one of the following:
   • The units are in mm of travel along the parts surface.
   • The units are in inches of travel along the parts surface.
• Displays only if the axis has been set up as a rotary axis. The units are in degrees of motor rotation.
• The units are in steps of motor rotation.

D The mode of the motor movement, which can be one of the following:
• Absolute - The motor will move to the actual absolute position indicated in “Move to”.
• Relative - The motor will move the amount in “Move to” from the current motor position.

E The current position count of the motor

F Apply the current position value to the “Move to” value

G The amount to move the motor to when the object is executed. If the Moves are setting is Absolute, the motor will move to the absolute position indicated in “Move to”. If the Moves are setting is Relative, the motor will move the amount in “Move to” from its current position.

H The speed at which the motor will execute the move in steps/s.

I Executes the indicated “Move to” settings immediately on the axis

J Executes the Home command immediately on the axis.

K Immediately stops movement of the axis.
**ROTARY MOTION**

The Rotary Motion object provides control over an external rotary indexer axis, and is synchronized with marking objects within the job.

**NOTE**
- Not available in Stand-Alone mode

**To modify Rotary Motion settings**

1. Click on the desired Rotary Motion Object in Object Manager.
2. Right-mouse click and select “Properties...”. The Rotary Motion Properties window appears.

![Rotary Motion Properties window]

**A** Assign this motion object to a specific hardware axis. There must be the correct motion type configured in the Motion Configuration. See Understanding the Motion Types.

**B** Select from the following Move modes:
- **Move to an absolute position** - The axis will move to the actual absolute position indicated in “Move” when the object executes.
- **Move a relative amount** - The axis will move the amount in “Move” from the current motor position when the object executes.
- **Perform a homing routine** - The axis will perform a homing routine based on the home settings of the axis when the object executes.
• Stop the axis - The axis will be stopped if it was moving as a result of a previous motion object when the object executes.
• Move continuously in the positive direction - The axis will move towards the positive limit when the object executes. The axis will continue to move until either hitting a limit switch, or if stopped by another motion object.
• Move continuously in the negative direction - The axis will move towards the negative limit when the object executes. The axis will continue to move until either hitting a limit switch, or if stopped by another motion object.

C A reset condition can be configured so that after the specified number of cycles, the axis will perform a reset function. The reset modes are:
• <disabled> - Disable the reset functionality
• Move to an absolute position - The axis will move to the actual absolute position indicated in “Reset to” when the reset condition is met.
• Move a relative amount - The axis will move the amount in “Reset to” from the current motor position when the reset condition is met.
• Perform a homing routine - The axis will perform a homing routine based on the home settings of the axis when the reset condition is met.
• Move continuously in the positive direction - The axis will move towards the positive limit when the reset condition is met. The axis will continue to move until either hitting a limit switch, or if stopped by another motion object.
• Move continuously in the negative direction - The axis will move towards the negative limit when the reset condition is met. The axis will continue to move until either hitting a limit switch, or if stopped by another motion object.

D The amount to move the axis when performing a normal move
E The initial speed the axis moves at while accelerating to the slew speed
F The acceleration rate of the axis when changing from the initial speed to the slew speed
G The object can be configured to skip execution by setting this parameter greater than 1. For example, to execute the object every third job cycle, set this value to 3.
H The amount to move the axis when performing a reset move
I After the axis has completed the preprogrammed motion, wait for an amount of time before executing the next object in the job list.
J When the option is selected, all axis movement will be opposite normal movement
K The maximum speed the axis will attain when executing a move.
L The deceleration rate of the axis when changing from the slew speed to a stop at the end of the programmed travel.
M The number of cycles the object needs to execute before triggering a reset. When the reset is triggered, the axis will perform the action specified in “Reset move mode”.
N The radius of the part being marked. This value is useful to scale distances on the surface of the part.
O Change the display units for all values in the current window.
RUN APPLICATION

The Run Application Object provides a way for the application to start an external program or batch file synchronized with the execution of marking objects within a job.

NOTE • Not available in Stand-Alone mode

To modify Run Application settings

1 Click on the desired Run Application Object in Object Manager.
2 Right-mouse click and select “Properties...”. The Run Application Properties window appears.

The Run Application property page

A The default folder location where the program or batch file exists. This setting is optional as the full path to the file can be specified in the Program parameter.

B The program or batch file to run. If the Default path is set to a folder location, then the program or batch file must be the filename with extension only. If no Default Path is set, the fully qualified path to the executable or batch file must be specified here.

C Optional command line parameters to pass to the program. WinLase LAN will automatically insert the first space after the program file name. Any additional spaces required must be specified here.

D Time to wait after application closes before executing the next object in the job list.
E Select this option to wait for the program or batch file to exit before WinLase LAN continues. If the box is not checked, WinLase LAN starts the program or batch file, and then continues to the next object in the Object list after the Continue delay.

F Select the default path.

G Select the batch file or program to execute.

Testing the configuration settings

- After configuring the settings click the test button. The program or batch file you are referencing will run.
SERIAL COMMUNICATION

The Serial Communication Object provides a way for the application to output a string or series of strings using a COM port. A valid Windows COM port must be configured for a Serial Communication Object to function.

To modify Serial Communication settings

1. Click on the desired Serial Communication Object in Object Manager.
2. Right-mouse click and select “Properties...”. The Serial Communication Properties window appears.

The Serial Communication property page when Transmit a single line of text is selected

A. Configures the object to send a single line of text using the COM port when the object executes.
B. The string to send when Transmit a single line of text is selected.
C. Select this option if a response is expected from the device WinLase LAN is communicating with. If this box is checked, WinLase LAN will generate an error message if the response conditions are not met when this object executes. If no response is expected, or to ignore a response, clear this check box.
D. The response string expected from the connected device.

NOTE - Not available in Stand-Alone mode
The time to wait for the response back from the connected device.

F The control character \r will be added to the end of all string sent to the COM port.

G The control character \n will be added to the end of all string sent to the COM port.

The Serial Communication property page when Transmit multiple lines of text using a script file

A Configures the object to send multiple lines of text contained in a script file. See Serial Communication Script File Format for details on the script file format.

B The fully qualified path to the script file containing the strings to be transmitted. See Serial Communication Script File Format for details on the script file format.

C The control character \r will be added to the end of all string sent to the COM port.

D The control character \n will be added to the end of all string sent to the COM port.

E Create and save a script file by clicking this button.

F Edit an existing script file by clicking this button.

G Locate and insert a script file by clicking this button.

Configuring WinLase LAN to allow Serial Communication

1 From the Main menu, select System > Preferences.

2 Click on the COM Ports tab. The COM Ports page appears.
3 Select the Communication Objects line in the list with the mouse. The configuration settings appear.

![Communication Objects Page]

A Selecting this option will make a COM port available to the Communication Objects. When applying this change, an attempt to open the COM port is made. De-select the option to disable the COM port for the Communication Objects.

B The Windows assigned COM port.

C COM port setting.

D COM port setting.

E COM port setting.

F COM port setting.

G Click this button to apply any changes made in the Communication Objects page. If WinLase cannot open the specified COM port, an error message is displayed. If the COM port was opened successfully, the Status is updated to Connected.

**SERIAL COMMUNICATION SCRIPT FILE FORMAT**

During execution of a function using a script file, WinLase LAN will transmit the strings found in the file line by line in the order found. The following section describes the format of this file.
## COMMAND SET

The following list describes all the Script file commands and their intended use.

<table>
<thead>
<tr>
<th>Command</th>
<th>Purpose</th>
<th>Parameters</th>
<th>Comments</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>delimiter=&lt;delimiter&gt;</td>
<td>Sets the character to use to separate individual values within a single command string</td>
<td>delimiter: The delimiter character.</td>
<td>This command must appear in the list before a string that contains a delimiter. If no delimiter command is found in the list, the default &quot;,&quot; (comma) is used by WinLase to detect individual values within the command line.</td>
<td>Delimiter=;</td>
</tr>
<tr>
<td>delay=&lt;time&gt;</td>
<td>Creates a delay before the next line in the script file is transmitted.</td>
<td>time: The time, in milliseconds, to delay before processing the next line in the script file</td>
<td>Time must be greater than 0, or it is ignored.</td>
<td>Delay=10</td>
</tr>
<tr>
<td>&lt;command&gt;</td>
<td>A string to be transmitted. No response is expected with this command format.</td>
<td>command: The actual string to be transmitted.</td>
<td></td>
<td>ATTN</td>
</tr>
<tr>
<td>&lt;command&gt;&lt;delimiter&gt;&lt;response&gt;&lt;delimiter&gt;&lt;timeout&gt;</td>
<td>A string to be transmitted. A response is expected with this command format</td>
<td>command: The actual string to be transmitted. delimiter: The delimiter specified with the delimiter command. response: The response string expected. timeout: The period of time, in milliseconds, to wait for the response string.</td>
<td>A response is expected with this command format, and an error will be generated by WinLase if the expected response is not received within the timeout period.</td>
<td>ATTN,ACK,100</td>
</tr>
</tbody>
</table>
**SCRIPT FILE EXAMPLE**

The following example illustrates how to use all the commands available with the WinLase LAN Script File format.

`delimiter=;//Sets the delimiter for the following strings to ;`

`ATN; //Sends the string 'ATN', don't care about response`

`SQF;ACK;50; //Sends the string 'SQF', and waits 50 mS for the response 'ACK'`

`delay=500; //Pauses 500 mS before executing the next line`

`QUIT; //Sends the string 'QUIT'`
**SET I/O PORT**

Set I/O Port objects set the status of the specific output port either high or low depending on the settings.

**To modify Set I/O Port settings**

1. Click on the desired Set I/O Port Object in the Object Manager.
2. Right-mouse click and select “Properties...”. The Properties window displays the Set I/O Port property values.

![Set I/O Port Properties](image)

The Set I/O Port property page

**A** Specifies one of the following actions:
- **Set Port HIGH** - The selected port will switch to the HIGH state. The port will stay HIGH until changed by another Set Port Object.
- **Set Port LOW** - The selected port will switch to the LOW state. The port will stay LOW until changed by another Set Port Object.
- **Pulse Port (LOW-HIGH-LOW)** - The selected port starts LOW, will switch to HIGH for the indicated duration, and then switch back LOW. Note that the duration value is approximate.
- **Set WORD** - The WORD value is a 20-bit value, corresponding to the possible 20 output ports on the LEC-1 device. Each of the 20 output ports will switch to HIGH if the corresponding bit is set in the Word value. After the object executes, all ports will stay at their last signaled states.

**B** The specific I/O port that is signaled when the object has executed

**C** When the Set Word action is selected, Word value appears. Set this to a value from 0-1048576.
SHOW MESSAGEBOX
Use the Show Messagebox Objects to display an on-screen message during the execution of a job. The message must be acknowledged and closed before the process will continue.

NOTE • Not available in Stand-Alone mode

To modify Show Messagebox settings
1 Click on the desired Show Messagebox object in Object Manager.
2 Right-mouse click and select “Properties...”. The Show Messagebox Properties window appears.

The Show Messagebox property page
A The text that will appear in the title bar of the Messagebox.
B The string of text that will appear in the Messagebox.
**WAIT FOR EXTERNAL SIGNAL**

The Wait for External Signal Object polls an I/O port for an input and waits until that input is received before the process continues.

To modify Wait for External Signal settings

1. Click on the desired Wait for External Signal object in the Object Manager.
2. Right-mouse click and select “Properties...”. The Properties window displays the Wait for External Signal property values.

The Wait For External Signal property page

- **A** Select the port to wait for a signal on.
- **B** The window message displayed in WinLase LAN when the object is executing.
- **C** Select from the following Trigger mode options:
  - After transition from LOW -> HIGH - The LEC-1 device will trigger only when a transition from LOW to HIGH is detected. (Edge Detection)
  - After transition from HIGH -> LOW - The LEC-1 device will trigger only when a transition from HIGH to LOW is detected. (Edge Detection)
  - If port is LOW - The LEC-1 device will trigger if the port is LOW when checked, or if the port switches from HIGH to LOW. (Level Detection)
  - If port is HIGH - The LEC-1 device will trigger if the port is HIGH when checked, or if the port switches from LOW to HIGH. (Level Detection)
**XY TABLE**

The XY Table Object provides control over an external XY Table. An optional OMS PCIx-004 motor controller card is required to control the external XY Table.

**NOTE**
- Not available in Stand-Alone mode

**To modify XY Table settings**

1. Click on the desired XY Table object in Object Manager.
2. Right-mouse click and select “Properties...”. The XY Table Properties window appears.

---

**The XY Table property page**

**A** The units in which the “Move to” values are displayed, which can be one of the following:
- The units are in mm of travel along the parts surface.
- The units are in inches of travel along the parts surface.
- Displays only if the axis has been set up as a rotary axis. The units are in degrees of motor rotation.
- The units are in steps of motor rotation.

**B** The mode of the motor movement, which can be one of the following:
- Absolute - The motor will move to the actual absolute position indicated in “Move to”.
- Relative - The motor will move the amount in “Move to” from the current motor position.

**C** The current position count of the motor
JOB ENTITIES

Automation Objects

D Apply the current position value to the “Move to” value
E The amount to move the motor to when the object is executed. If the Moves are setting is Absolute, the motor will move to the absolute position indicated in “Move to”. If the Moves are setting is Relative, the motor will move the amount in “Move to” from its current position.
F The speed at which the motor will execute the move in steps/s.
G Executes the indicated “Move to” settings immediately on the axis
H Executes the Home command immediately on the axis.
I Immediately stops movement of the axis.
**XY MOTION**

The XY Motion object provides control over an external XY Table, and is synchronized with marking objects within the job.

**NOTE**
- Not available in Stand-Alone mode

**To modify XY Motion settings**

1. Click on the desired XY Motion Object in Object Manager.
2. Right-mouse click and select “Properties...”. The XY Motion Properties window appears.

The XY Motion Settings property page

- **A** Assign this motion object to a specific hardware axis. There must be the correct motion type configured in the Motion Configuration. See Understanding the Motion Types.
- **B** Select from the following Move modes:
  - Move to an absolute position - The axis will move to the actual absolute position indicated in "Move" when the object executes.
  - Move a relative amount - The axis will move the amount in "Move" from the current motor position when the object executes.
  - Perform a homing routine - The axis will perform a homing routine based on the home settings of the axis when the object executes.
• Stop the axis - The axis will be stopped if it was moving as a result of a previous motion object when the object executes.
• Move continuously in the positive direction - The axis will move towards the positive limit when the object executes. The axis will continue to move until either hitting a limit switch, or if stopped by another motion object.
• Move continuously in the negative direction - The axis will move towards the negative limit when the object executes. The axis will continue to move until either hitting a limit switch, or if stopped by another motion object.

C A reset condition can be configured so that after the specified number of cycles, the axis will perform a reset function. The reset modes are:
  • <disabled> - Disable the reset functionality
  • Move to an absolute position - The axis will move to the actual absolute position indicated in “Reset to” when the reset condition is met.
  • Move a relative amount - The axis will move the amount in “Reset to” from the current motor position when the reset condition is met.
  • Perform a homing routine - The axis will perform a homing routine based on the home settings of the axis when the reset condition is met.
  • Move continuously in the positive direction - The axis will move towards the positive limit when the reset condition is met. The axis will continue to move until either hitting a limit switch, or if stopped by another motion object.
  • Move continuously in the negative direction - The axis will move towards the negative limit when the reset condition is met. The axis will continue to move until either hitting a limit switch, or if stopped by another motion object.

D The amount to move the axis when performing a normal move
E The initial speed the axis moves at while accelerating to the slew speed
F The acceleration rate of the axis when changing from the initial speed to the slew speed
G The object can be configured to skip execution by setting this parameter greater than 1. For example, to execute the object every third job cycle, set this value to 3.
H The amount to move the axis when performing a reset move
I After the axis has completed the preprogrammed motion, wait for an amount of time before executing the next object in the job list.
J When the option is selected, all axis movement will be opposite normal movement
K The maximum speed the axis will attain when executing a move.
L The deceleration rate of the axis when changing from the slew speed to a stop at the end of the programmed travel.
M The number of cycles the object needs to execute before triggering a reset. When the reset is triggered, the axis will perform the action specified in “Reset move mode”.
N The radius of the part being marked. This value is useful to scale distances on the surface of the part.
O Change the display units for all values in the current window.
**TEMPLATE OBJECT**

A Template Object is a graphic that is displayed in the work area, but is not a marking object. A Template Object is created from a Mark Object and once converted, cannot be edited. To edit a Template Object, it must be converted back into a Mark Object, edited, and then converted back to a Template Object. Template Objects are useful for displaying alignment features, notes, or graphics of the actual part being processed.

**CREATING A TEMPLATE OBJECT**

Template objects are mark objects that have been converted to a Template object.

**To create a Template Object**

1. If the graphic used to make a Template Object is an external file, import the file. See “Importing Graphic files” on page 5-17.

2. If the graphic used to make a Template Object is a system object, add it to the Job by clicking the appropriate system object button. See “Adding a System Entity” on page 5-16.

3. Edit the position and size of the graphic within the work area.

4. Select the object by clicking it. Note that a group cannot be converted to a Template Object.

5. From the main menu, select Objects > Convert to Template, or right click the object, and select “Convert to Template”.

**EDITING OR REMOVING THE TEMPLATE OBJECT**

To edit the Template Object, it must be converted back to a mark object first. Removing a Template Object follows the same steps as editing, except the object is not converted back to a Template.

**To edit a Template Object**

1. From the Main menu, click Job Manager > Convert Template to Object.

2. The Template Object is removed from the Job Manager and is added to the end of the Object Manager list.

3. If removing the Template, simply delete the mark object from the Object Manager list.

4. If editing, make the desired changes, then follow the process above from Step 4 for creating a Template Object.
JOB ENTITIES

Template Object
MARKING JOBS

This chapter provides an overview of the laser marking of objects and groups of objects and Jobs. In this context, a marking object is any laser markable entity added to an active Job. In WinLase LAN, there is a fundamental difference between marking objects (Job > QuickMark) and running Jobs (Job > Run).

• When using the Job > QuickMark command, Automation objects do not execute. Any special run-time behavior that has been applied to an object, such as TextMerge, serialization, etc. will not be executed when marking the object using QuickMark.

• When using the Job > Run command, all Automation objects, as well as any special run-time behavior of marking objects, will be executed.

USING PREVIEWMARK

When the laser is equipped with a visible pointer and the laser driver file has enabled the visible pointer, PreviewMark is enabled. See “Enabling Visible Pointer control” on page 9-23. The PreviewMark feature provides a method of visually indicating the outline of an object or group of objects. This visual feedback is accomplished by rapidly tracing the bounding rectangle of the object or group of objects with the visible laser while keeping the marking laser turned off. The mark object can be easily moved around the marking field by using the Ctrl+Arrow key combination and when properly positioned, moved there with a press of the Enter key. Additionally, using the Alt+Arrow key combination can dynamically change the size of the object.

To Preview an object

1. Select an object or group of objects.
2. To start PreviewMark, do one of the following:
   • Right click on the object and select “PreviewMark...”.
   • Press the F4 function key.
   • From the main menu, select Job > PreviewMark.

NOTE

- There must be an active connection to an LEC-1 device, and the Job containing the object(s) to be previewed must be assigned to that device.
The PreviewMark window opens and the objects outline displays on the marking field.

To move the outline while it is displaying

1. To move the outline of the object on the marking field, do one of the following:
   - Click on the up/down/left/right arrows with the mouse. A single click moves the outline once. Holding the mouse button down on the direction arrow will move the outline across the mark field.
   - While holding the Ctrl key down, press the up/down/left/right arrow keys on the keyboard. A single press moves the outline once. Holding the arrow key down will move the outline across the mark field.
2. When the outline is in the desired position, press the Enter key on the keyboard or click the Apply button with the mouse. The object is repositioned on the screen to the new location.

To scale the outline while it is displaying

1. To scale the outline of the object, do one of the following:
   - Click on the scale arrows with the mouse. A single click scales the outline a small amount. Holding the mouse button down on the scale arrow will scale the outline continuously.
   - While holding the Alt key down, press the up/down/left/right arrow keys on the keyboard. A single press scales the outline a small amount. Holding the arrow key down will scale the outline continuously.
When the outline is scaled to the desired size, press the Enter key on the keyboard or click the Apply button with the mouse. The object is resized on the screen.

To adjust the outline refresh speed
1. Click the Settings button. The PreviewMark window expands to show additional controls.
2. With the mouse pointer, click the Display speed slider bar, and while holding the mouse button down, move the bar left or right to adjust the speed.

To calibrate the Visible Pointer
See “Calibrating the Visible Pointer” on page 9-24.
USING THE QUICKMARK FEATURE

Use the QuickMark feature to laser mark the selected object, or group of objects. QuickMark does not apply any special processing to the object such as serialization or TextMerge, etc.

To QuickMark objects

1. Select the object or group of objects to be laser marked. See “Selecting and Deselecting Objects” on page 5-21.

2. Do one of the following:
   • From the Main menu, select Job > QuickMark.
   • Press F8 on the keyboard.
   • Place the mouse pointer over a marking object, and right-click and select “QuickMark...”.
   • Click the QuickMark button.

3. Click the Selected button to mark the single object.

4. Click the All button to mark all objects currently in the Job.

NOTE
• There must be an active connection to an LEC-1 device, and the Job containing the object(s) to be marked must be assigned to that device.

WARNING
• Laser will turn on immediately. Check the beam path before proceeding.
5 To mark an object repeatedly, select the “Repeat” option. The object will mark continuously until the Stop button is clicked.

6 To stop the laser while marking, do one of the following:
   • Click the Stop button.
   • Press the ESC key.

CHECKING THE MARK TIME
When a mark is complete, the status bar at the bottom of the QuickMark window will display the mark time.

Mark time: 281 ms

The elapsed time to complete the last object marked with the QuickMark feature. If a group of objects are marked, the Mark Time is for the last object marked in the group.
RUNNING JOBS

When running Jobs, all Automation objects, as well as any special processing applied to an object will be executed. The three interface modes available in WinLase LAN also differ in the way a Job is executed. When running jobs, the process can be organized into four groups of events:

- Events that occur during Job loading
- Events that occur before a Job is executed
- Events that occur during Job Execution
- Events that occur at Job completion

THE JOB LOADING EVENTS

The following event fires when a job loads from file:

- Show the job Notes. The note can be shown automatically each time the Job is opened. Adding notes to a Job may be helpful when the Job first loads, as a reminder to do a task, etc. before running the Job.

To show a Note when the job loads

1. From the Main menu, select Job > Settings, then click the Notes tab. The Job Notes window appears.

   ![Job Notes Window]

   **Notes:**
   
   Place part in welding plate

   **Save Settings as Default**   **OK**   **Cancel**   **Help**
2 Type in the desired Note text.
3 Click OK. The Job Notes window closes.
4 From the Main menu, select System > Preferences. The Preferences window opens.
5 Click the Job Files tab. The Job File settings page appears.

- Select the “Show Job Notes when Job loads” option

**BEFORE A JOB IS EXECUTED EVENTS**

The following events fire, in the order listed, before a job is executed:

- *Out of Bounds check event*, which will show a warning message box if any marking objects are outside the marking field.

- *Enter Character String event*, which prompts the operator to enter a string before the job can continue

- *Home axes event* (intelligent motion only), which will prompt for a motion hardware homing sequence.
To check if any objects are out of bounds

1. From the Main menu, select System > Preferences.
2. Click on the Device tab. The Device page appears

   - Select the “Warn about out of bounds objects before marking” option

To respond to the Enter Character String dialog box

- The Enter Character String dialog appears before the job executes if a text object has been programmed to Supply string at start.

1. Enter the required value for the requested string, and click the OK button to continue.
2. Click Cancel to abort the current Job.
To respond to the Home motion axes event

- The Home Utility dialog appears before the job executes if the Motion axes have not been homed since the last power cycle. Once the axes have been homed once, the Home Utility will not automatically appear again until the axes have been power cycled.

The Home Utility
- The motion axis types that require homing
- When homing a XY motion device, select this option to move both axes at the same time
- Start the homing process
- Stops motor movement. If motor movement is stopped before the homing process completes, the motors will require homing at the next job execution cycle.

JOB EXECUTION EVENTS
The are a number of settings that control the behavior of WinLase LAN as it executes a Job and a number of events that can happen during the execution of a job:

- **Globals settings** which provide job-wide control of the laser power, mark speed, and mark object positions. WinLase LAN offers the ability to change the laser power, scan speed, and object position of a mark object from a single (global) location. This allows operators or engineers to make changes to all Jobs run with WinLase LAN from a single location. For example, if the laser power is slowly decreasing because of lamp life, the power setting for all marking objects can be slightly increased from the Global settings window.

- **Repeat Process settings**, which controls whether the Job process is run continuously, once, or a specified number of times before a message is displayed.

- **Step & Repeat settings**, which configures options for marking an object across the marking field in an array of rows and columns. The number of rows and columns, as well as the spacing can be saved with the job.

- **External Start settings**, to configure control of Job execution from external equipment.
MARKING JOBS

Running Jobs

- Mark on the Fly settings, which provides for the marking of moving parts.
- Alignment Files settings, which are text based files that describe offsets and rotation to be applied during the execution of the job. The name of the alignment file is saved with the job. Prior to the execution of the job, the alignment file is located and the changes within the file are applied to all objects in the job.
- String Value required event, which prompts the operator to enter a string before the job can continue
- TextMerge file event, which prompts for MergeFile information
- An Interlock event, which indicates that a system interlock has been signaled
- A System Error event, which indicates that an unexpected error event has occurred

To change the Global settings

1. From the main menu, select System > Globals. The Global Settings window appears.

The Global Settings page

A. The percent increase or decrease to apply to the laser power settings of all objects within a Job.
B. The percent increase or decrease to apply to the Mark speed settings of all objects within a Job.
C. Use these values to “nudge” (offset) all objects within a Job.
D. To save these settings from session to session, select this option. If the box is unchecked, the applied settings will be used for the current session only and will be lost when the application closes.
To change the Global settings from the Touch screen interface

1. From the Touch screen interface, click the OPTIONS button. The OPTIONS window appears.
2. Click the ADJUST button. The Global Settings window appears.

The Global Settings page

A. The percent increase or decrease to apply to the laser power settings of all objects within a Job.
B. The percent increase or decrease to apply to the Mark speed settings of all objects within a Job.
C. Use these values to “nudge” (offset) all objects within a Job.
D. Enter numerical values with these buttons
E. Click these buttons to edit a field.
To control how a job cycle repeats

1. From the Main menu, select Job > Settings, then click the Repeat Process tab.
2. The Repeat Process Properties window appears.

The Repeat Process property page

A. After the operator clicks Go, the Job will execute the objects in the Object Manager list once. The operator must click Go to execute the list again. This process will go on indefinitely.

B. After the operator clicks Go, the Job will execute the objects in the Object Manager list once. The operator must click Go to execute the list again. This process will stop after # cycles.

C. The number of cycles used in B

D. After the operator clicks the Go button, the Job will execute the objects in the Object Manager list repetitively. This option is usually used with an external start signal (Start Mark), otherwise the object list will execute continuously, with no break between successive cycles of the list.

E. After the operator clicks Go, the Job will execute the objects in the Object Manager list repetitively. This option is usually used with an external start signal, otherwise the object list will execute continuously, with no break between successive cycles of the list. The process will stop after # cycles and display a message.
To continuously save Dynamic string changes

During job execution, barcode and text objects may be changing their strings through automatic serialization. These changes can be saved to the job file automatically as the job is executing. The next time the job is loaded, text or barcode objects will use the last string value.

1. From the Main menu, select Job > Settings, then click the Repeat Process tab.
2. The Repeat Process Properties window appears.

The Repeat Process property page

After every job cycle completes, the job is saved to disk. This is useful, for example, when there is serialized text objects in a job and the job needs to be saved with the last used serial number.
To use Step and Repeat

1. From the Main menu, select Job > Settings, then click the Step & Repeat tab.
2. The Step & Repeat Properties window appears.

The Step and Repeat property page

A. Enables/disables step and repeat.
B. The number of columns in the pattern.
C. The spacing between each column of marks.
D. The number of rows in the pattern.
E. The spacing between each row of marks.
F. The Pattern offset X Axis and Y-axis will translate all objects in the rows and columns by the amount entered into the field.
G. The pattern preview
H. Updates the preview to show recent changes to the step and repeat parameters.
I. Resets all settings to default values.
To control the job with External I/O

1. From the Main menu, select Job > Settings, then click the External Start tab.
2. The External Start Properties window appears.

The External Start property page

A. If this option is selected, WinLase LAN will start a marking job immediately after the Go button is clicked in the Run Process dialog box. Note that if a job is being saved to the LEC-1 device to run in Stand-Alone mode, this option is not allowed.
B. If this option is selected, an external hardware signal (Start Mark) controls the start of a marking sequence. In the Run Process dialog, the Go button is clicked to start the process, and then WinLase LAN immediately streams the job to the LEC-1 device. The LEC-1 device will then wait for the Start Mark signal, and when received, will execute the job. Note that if a job is being saved to the LEC-1 device to run in Stand-Alone mode, this option MUST be selected.
C. The default port on the LEC-1 device is the Start Mark input.
D. Enter the message displayed in the Run Process dialog box while the LEC-1 device is waiting for the Start Mark signal.
E. Select from the following Trigger mode options:
   - After transition from LOW -> HIGH - The LEC-1 device will trigger only when a transition from LOW to HIGH is detected. (Edge Detection)
   - After transition from HIGH -> LOW - The LEC-1 device will trigger only when a transition from HIGH to LOW is detected. (Edge Detection)
   - If port is LOW - The LEC-1 device will trigger if the port is LOW when checked, or if the port switches from HIGH to LOW. (Level Detection)
• If port is HIGH - The LEC-1 device will trigger if the port is HIGH when checked, or if the port switches from LOW to HIGH. (Level Detection)

**F** Enter a timeout value in minutes to wait for the Start Mark signal. If the timeout expires before an external start signal is received, an error message is displayed. A value of 0 (zero) will wait indefinitely.
To enable marking on moving parts (Mark on the Fly)

| NOTE | Mark on the Fly is only available in Stand-Alone mode. |

1. From the Main menu, select Job > Settings, then click the Mark on the Fly tab.

2. The Mark on the Fly Properties window appears.

   - **A** Enable/disable mark on the fly for the current job.
   - **B** This option will add a specified delay, in distance, between when the Start Mark signal is received and when the LEC-1 device executes the marking vectors. Because this delay is based on distance in the part movement direction, as the part speed changes, the spacing stays constant. Enter 0 to disable the distance delay.
To dynamically control marking object alignment

1. From the Main menu, select Job > Settings, then click the Alignment tab. The Alignment page appears.

The Alignment property page

A. Check this option to select and configure an Alignment file

B. The alignment file

C. The X offset amount to apply to all objects in the job.

D. The Y offset amount to apply to all objects in the job.

E. The Z offset (defocus) amount to apply to all objects in the job. The scanning hardware must support 3-axis scanning for this value to have any effect.

F. A new Alignment file can be created by clicking the New button and choosing a file name and location. A new Alignment file with default settings is created.

G. An existing Alignment file that has already been loaded can be edited by clicking the Edit button. When editing is complete, the changes can be saved back to the file by clicking Save.

H. To load an existing Alignment file, click the Browse button to locate the Alignment file.

I. The amount of rotation to apply to all objects in the job.

J. The X center of rotation used when applying Angle. To rotate an object about the center of the field, the center of rotation would be X center = 0, Y center = 0. To rotate the object about its center, the center of rotation would be the coordinates of the center of the object.

K. The Y center of rotation used when applying Angle. To rotate an object about the center of the field, the center of rotation would be X center = 0, Y center = 0. To rotate the object about its center, the center of rotation would be the coordinates of the center of the object.
To respond to the Enter Character String dialog box

- The Enter Character String dialog appears at run-time if a text object has been programmed to Supply string every mark.

1. Enter the required value for the requested string, and click the OK button to continue.
2. Click Cancel to abort the current Job.

To respond to the TextMerge Event dialog box

- If a text object has been programmed to use the TextMerge feature, the TextMerge Event window appears when the Job is run. This window is used to control the start position in the merge file for the current marking session.

The TextMerge event dialog:

- A: The text object will start retrieving strings from the top of the file. Any group # and start line # settings will be preserved.
- B: The text object will start retrieving strings from the line number entered. The available line numbers are visible to the right of the line number edit box.
When a previous TextMerge Job is run, the last position in the merge file is automatically saved. When selecting this option, the text object will retrieve strings from the bookmark location. Note that this option is grayed out if there was no previous Job which used the merge file.

Click this button to view the TextMerge file

To view the current MergeFile

1. Click the View TextMerge file button. The TextMerge viewer appears.
2. To see the Bookmark line location, click the Go to Bookmark button.
3. Click the X to close the viewer and resume the Job.

**JOB COMPLETION EVENTS**

The following events fire, in the order listed, after a job has completed execution:

- *The Beam Home event*, which provides a means of controlling the position the laser spot takes at the end of a mark sequence. By default, the spot (mirror positions) remains at the end of the last vector that was marked.

- *Laser saver event*, which provides a means of shutting down the laser and/or reducing its power settings after a timeout period has elapsed. An optional error flag can be set as well.

**To change the Beam Home settings**

1. From the Main menu, select System > Preferences.
2. Click on the Beam Home tab. The Beam Home page appears.
The Beam Home page

A If this option is selected, at the end of a Run Process sequence, the laser beam will go to the home position.
B If this option is selected, at the end of a QuickMark sequence, the laser beam will go to the home position.
C The home position.
D The speed the spot will move from its current position to the home position.

To change the LaserSaver settings

1 From the Main menu, select System > Preferences.
2 Click on LaserSaver tab. The LaserSaver page appears.

The LaserSaver page

A Enables/disables the LaserSaver feature.
B If this option is selected, after the specified timeout period has elapsed, the power ports, which control the laser power, are set to their minimum settings.
C If this option is selected, after the specified timeout period has elapsed, a custom de-initialize script is sent to the laser via the RS-232 port.
D This feature is not available on the LEC-1 device.
RUNNING FROM THE WORKSPACE

There must be at least one executable object in the Object Manager list and an active connection to an LEC-1 in order to run a Job.

To run a Job from the Job Editing Workspace or Operator Interface

1. Do one of the following:
   • From the Main menu, select Job > Run
   • Press F12 on the keyboard.
   • Click the Run button.

2. Click Go. The Job begins execution.

To stop the Job

1. To stop a running Job, do one of the following:
   • Click the Stop button.
   • Press ESC on the keyboard.

WARNING

• Laser will turn on immediately. Check beam path before proceeding.
To run a Job from the Touch Screen Interface

1. To run a Job from the Touch Screen Interface, a Job must be loaded. To load a Job in the Touch Screen Interface, see Section 6.2.2 Loading Jobs in the Touch Screen Interface.

   **WARNING**

   • Laser will turn on immediately. Check beam path before proceeding.

2. From the Touch Screen Interface, click the RUN button. The system immediately starts the run Job process.

To stop the Job

- To stop a running Job, click the STOP button.

**SAVING THE JOB SETTINGS AS DEFAULT**

Whenever the New button on the tool bar is clicked, or the File > New menu item is selected, a new Job is created, and the Default Job Settings are applied. To customize the defaults, set all the Job parameters to desired values, then click the Save Settings as Default button. The current settings are saved as the default.

To set the default Job Settings

1. Do one of the following:
   - Select Job > Settings.
   - Click on the Settings icon in Job tool bar. The Job Settings Properties window appears.

2. Set all the values in the Job Settings pages to the desired settings.

3. Click the Save Settings as Default button. The current settings are immediately saved, and is confirmed by the following message.

   The Save Settings as Default Button
RUNNING STAND-ALONE JOBS

Stand-Alone jobs can be executed on an LEC-1 device by using a Pendant, or interacting with the LEC-1 using the Remote API over Ethernet or RS-232. Additionally, WinLase LAN can be used to interact with an LEC-1 in Stand-Alone mode. This feature allows the design and debug of Stand-Alone jobs to be done completely within the WinLase LAN user interface. Stand-Alone jobs can also be run from the WinLase LAN interface in production situations as well. Behind the scenes, WinLase LAN uses the Remote API command set exposed by the LEC-1 device to enable this functionality.

To remotely run the current Job

1. Do one of the following:
   - From the Main menu, select Job > Run Remotely.
   - Press F9 on the keyboard.
   - Right-click the Job in the Laser System Viewer and select “Run Remotely…”.

2. Click the Upload button to copy the current Job to the LEC-1, load it into RAM and make it the Active Job. The Job is copied to a special folder used only for this purpose and is not stored permanently. To copy the file into permanent memory, see “Saving Stand-Alone (LEC binary) Job files” on page 5-5.
The Remote Job Control page

A Select from the following Trigger mode options:
- After transition from LOW -> HIGH - The LEC-1 device will trigger only when a transition from LOW to HIGH is detected. (Edge Detection)
- After transition from HIGH -> LOW - The LEC-1 device will trigger only when a transition from HIGH to LOW is detected. (Edge Detection)
- If port is LOW - The LEC-1 device will trigger if the port is LOW when checked, or if the port switches from HIGH to LOW. (Level Detection)
- If port is HIGH - The LEC-1 device will trigger if the port is HIGH when checked, or if the port switches from LOW to HIGH. (Level Detection)

B Select this option to run the Job repeatedly.

C Instructs the LEC-1 device to run the job in cache mode.

D Enable Mark on the Fly (only available on LEC-1 devices with an Advanced license).

E Click the Go button to initiate Job execution.

F Stop job execution with this button.
To configure Mark on the Fly parameters for the current Job

- From the Run Job page, select the “Enable Mark on the Fly” option. The Mark on the Fly tab appears.

**NOTE**
- Mark on the Fly parameters are only available when connected to an LEC-1 device with an Advanced license.

**NOTE**
- Changes to Mark on the Fly parameters are not saved to the LEC-1 device or the Job, and are active only while the Run Remotely window is open.

- The number of counts the encoder outputs for every millimeter of part movement. When the LEC-1 device is in Simulate encoder mode, this control is disabled.

- Enter the actual part speed in mm/s. The system assumes a constant part speed during the marking process. When the LEC-1 device is in Encoder mode, this control is disabled.

- This option will add a specified delay, in distance, between when the Start Mark signal is received and when the LEC-1 device executes the marking vectors. Because this delay is based on distance in the part movement direction, as the part speed changes, the spacing stays constant. Enter 0 to disable the distance delay.

- Indicates the currently configured encoder mode of the LEC-1 device. The encoder mode cannot be changed from this tool. To change the encoder mode, see “To configure the Mark on the Fly settings” on page 4-33.

The Mark on the Fly parameter page

A The number of counts the encoder outputs for every millimeter of part movement. When the LEC-1 device is in Simulate encoder mode, this control is disabled.

B Enter the actual part speed in mm/s. The system assumes a constant part speed during the marking process. When the LEC-1 device is in Encoder mode, this control is disabled.

C This option will add a specified delay, in distance, between when the Start Mark signal is received and when the LEC-1 device executes the marking vectors. Because this delay is based on distance in the part movement direction, as the part speed changes, the spacing stays constant. Enter 0 to disable the distance delay.

D Indicates the currently configured encoder mode of the LEC-1 device. The encoder mode cannot be changed from this tool. To change the encoder mode, see “To configure the Mark on the Fly settings” on page 4-33.
To remotely run a Job stored on an LEC-1

1. Right-click the LEC-1 device in the Laser System Viewer and select “Interactive...”.

   ![Remote Job Control Page]

   A. Select the location on the LEC-1 to search for jobs
   B. Select the job to run. When the job is changed, the Load button becomes active and must be clicked to load the job into RAM.
   C. Select from the following Trigger mode options:
      - After transition from LOW -> HIGH - The LEC-1 device will trigger only when a transition from LOW to HIGH is detected. (Edge Detection)
      - After transition from HIGH -> LOW - The LEC-1 device will trigger only when a transition from HIGH to LOW is detected. (Edge Detection)
      - If port is LOW - The LEC-1 device will trigger if the port is LOW when checked, or if the port switches from HIGH to LOW. (Level Detection)
      - If port is HIGH - The LEC-1 device will trigger if the port is HIGH when checked, or if the port switches from LOW to HIGH. (Level Detection)
   D. Select this option to run the Job repeatedly.
   E. Instructs the LEC-1 device to run the job in cache mode.
   F. Load the job into RAM
   G. Click the Go button to initiate Job execution.
   H. Stop job execution with this button.
CONTROLLING WINLASE LAN REMOTELY

THE HOST INTERFACE
WinLase LAN was designed to be a full-featured laser marker user interface, with capabilities for editing, saving, opening and running “jobs” directly from the WinLase LAN interface. Although this interface is extremely powerful, it may not be desirable in all circumstances.

For this reason, WinLase LAN offers the Host Interface service. This service provides a remote program, written by the customer, the ability to take control of WinLase LAN. In addition, the Fieldbus interface provides a means for controlling WinLase LAN, and reading status back from WinLase LAN to the Master controller.

Although TCP/IP, RS-232 and Fieldbus interfaces are supported, only one may be active at a time for remote control.

Please refer to the Lanmark Controls Inc. document Remote Interface Manual for complete details on how to use this powerful interfacing technique.

RS-232 AND TCP/IP INTERFACE CONCEPTS
When using the RS-232 or TCP/IP interfaces, a remote program can load jobs, dynamically change the content of marking objects, run jobs, and receive status back from WinLase LAN after every command. While the remote program has control, the WinLase LAN User Interface is locked out, preventing the operator from making any changes to the running process. Although jobs that contain Motor Control objects can be loaded, the Remote Interface does not support executing motor control objects within the job.

In operation, the external program takes control of WinLase LAN, but does not initiate the actual marking cycle. This is done through the Start Mark input on the LEC-1. Once the Start Mark input is toggled, the mark cycle begins, the mark completes, and then WinLase LAN returns to wait for the Start Mark input to toggle again.

In addition to the control commands available, there are a number of status query commands that can be used to retrieve the current status of WinLase LAN. These queries can be made even if the remote computer has not taken control of WinLase LAN.

FIELDBUS INTERFACE CONCEPTS
Using the Fieldbus interface, a remote Master controller can load jobs by Index number, change the contents of two fixed memory buffers, run jobs, and receive status back from WinLase LAN after every command. While the remote Master has control, the WinLase LAN User Interface is locked out, preventing the operator from making any changes to the running process. Although jobs that contain Motor Control objects can be loaded, the Remote Interface does not support executing motor control objects within the job.
In operation, the external Master initializes WinLase LAN with a startup sequence, and then can go on to take control and load jobs. Once a job is loaded, the Master initiates the actual marking cycle. This is done through the StartMark input bit.
MARKING JOBS

Controlling WinLase LAN Remotely
THE MARKING FIELD AND LENS

Image field correction capability is provided to compensate for optical errors induced by all two-mirror laser beam systems. These optical distortions are caused by a number of factors, including the distance between each mirror, the distance between the mirrors and the image field, and the type of lens used in the laser system for focusing the laser beam. This section describes the issues encountered with flat field (f-theta) laser scanning and methods for correcting distortions inherent in this focusing technique. The issues are:

- Understanding and correcting Induced Field Distortions
- Correcting for Mechanical Alignment Tolerances by calibrating the marking field

UNDERSTANDING FIELD DISTORTIONS

Image field distortions are comprised primarily of:

- Mirror induced distortions
- F-theta Objective induced distortions

The following figure illustrates the geometrical relationship between the galvos, mirrors and work surface.

*Projection system layout*
MIRROR INDUCED DISTORTION

Projection of a laser beam via an X-Y mirror set controlled by galvanometers induces distortion in the X axis proportional to the tangent of the angle of the Y axis mirror and the distance from the focal plane to the center of the Y axis mirror. This distortion is also known as "pincushion" distortion.

![Pincushion distortion caused by X-Y mirror set](image)

F-THETA OBJECTIVE INDUCED DISTORTION

The addition of an F-theta objective in the laser field provides direct proportionality between the scan angle and the distance in the image field, as well as ensures that the focus lies on a flat surface. F-theta objective lenses, like all optical lenses, are not perfect and induce their own projection field distortions. This distortion, illustrated in the following figure, is called “barrel” distortion for what it does to a square image. Many projection lens vendors will provide these model coefficients, or measurement data from which these coefficients can be derived. For many applications, however, this distortion is negligible.

![Barrel distortion caused by F-theta lens](image)
DISTORTION CORRECTION

The two distortion components described previously combine to create a distorted image field similar to that shown in the following figure:

![Composite Image Field Distortion](image)

This distortion is automatically compensated for by the LEC-1 through the use of correction tables. Correction tables represent a 65x65 element grid covering the full addressable projection range of the system. Each grid element contains three correction components: one each for the X, Y and Z axes. The components represent an offset that if added to an ideal position command for that point, would alter the galvo positions such that the resulting projected point would fall onto a “perfect” grid, i.e. the point would be “corrected”.

During the micro-vectoring process at each update interval, the LEC-1 calculates the ideal position of the mirrors along the path. It compares this value to the correction table grid and accesses the four grid points that immediately surround the calculated point. The corrections at these four points are proportionally averaged depending on how close the ideal point is to each grid point. This process, called bi-linear interpolation, produces a correction that is applied to the ideal point, and the result is then sent to the system D/A converters and serial digital command outputs.

USING CORRECTION TABLES

Most scan head manufacturers provide correction tables for specific scan heads they manufacture. Most of these correction files are either already provided by WinLase LAN in the library of lens correction files, or are available from the scan head manufacturer. WinLase LAN provides a lens correction file conversion feature, which allows the use of any lens correction file from the major scan head vendors. See “To copy a Lens Correction file from the PC to the LEC-1” on page 4-19 and “To add a new Lens Correction file to WinLase LAN” on page 4-22 for more information on using correction tables. In some cases, however, a custom correction table must be created from scan head design data.
WinLase LAN provides the capability to create a new table “from scratch” using only the design data of the target scan head.

**To create a new Lens Correction file using scan head design data**

1. From the menu bar, select System > Preferences.
2. Click on the Hardware tab. The Hardware page appears.
3. Click on any installed lens in the tree view.
4. Click the Change button. The Select Correction File window appears.
5. Click the Install New File button. The Install New Correction File Wizard appears.
6. Click the Next button to start the Wizard. The Correction File page appears.

**NOTE**

- The Install New File button will be disabled if a hardlock license key is not detected.

7. Select the “Create new file” option and enter a filename (without extension) for the new correction file.
8. Click Next. The Lens Correction File Description page appears.
9. Enter a descriptive name for the new lens. This is the name that appears in the available lens list. Note that the name is truncated to 25 characters in length.
10. Click Next. The Lens Focus Type page appears. WinLase LAN can create correction tables only for f-theta lens systems, so f-theta is pre-selected.
11 Click Next. The Scan Head Parameters page appears.

   ![Image of Scan Head Parameters page]

12 Enter the maximum optical angle that the mirror will rotate for full field deflection. Enter the focal length of the lens system to be used with the scan head.

13 Click Next. The Maximum Field Size page appears.

   ![Image of Maximum Field Size page]

14 The wizard calculates and displays the theoretical maximum field size that can be attained given the galvanometer maximum angle and the focal length of the f-theta lens. If desired, a smaller field size can be specified to account for optical considerations. Enter the desired field size.

15 Click Next. The Scan head Clear Aperture page appears.
16 Enter the clear aperture of the Scan Head. This value is the maximum beam diameter that can be passed through the scan head without optical clipping.

17 Click the Next button. The final page appears confirming the changes. Click the Done button to close the Wizard.

To add a Lens Correction file supplied by a scan head vendor to WinLase LAN

1 From the menu bar, select System > Preferences.
2 Click on the Hardware tab. The Hardware page appears.
3 Click on any installed lens in the tree view.
4 Click the Change button. The Select Correction File window appears.
5 Click the Install New File button. The Install New Correction File Wizard appears.

**NOTE**

- The Install New File button will be disabled if a hardlock license key is not detected

6 Click the Next button to start the Wizard. The Correction File page appears.
7 Select the “Existing file” option and then click the the browse button. The Locate Correction file window opens. Select the correction file to be added to the list. The file name is entered in the file name edit box. If the lens already exists, a message similar to the following will appear:

![Image of Warning Dialog](image.png)

8 Click Next. The Lens Correction File Description page appears.
9 Enter a descriptive name for the new lens. This is the name that appears in the available lens list. Note that the name is truncated to 25 characters in length.
10 Click Next. The Lens Focus Type window appears.
11 Select the “f-theta” option. Most new lenses will be of the f-theta variety. If the lens system has an automatic z-axis, select “3-axis”.
12 Click Next. The Calibration Factor page appears.
13 Enter the calibration factor for the lens. This value is important, as it sets the scaling for all dimensions throughout WinLase LAN. The calibration factor is available from the
manufacturer of the Scan Head and lens assembly. Note that the units are always in
bits/millimeter (mm) regardless of the Units setting of WinLase LAN.

14 Click Next. The Focal Length page appears.

15 Enter the focal length of the lens being added. Note the units are always in millimeters (mm).

16 Click Next. The Scan head Clear Aperture page appears.

17 Enter the clear aperture of the Scan Head. This value is available from the Scan Head manufacturer.

18 Click the Next button. The final page appears confirming the changes. Click the Done button to close the Wizard.

USING GRID CORRECTION
All correction files included with WinLase LAN or supplied by scan head vendors have all the information necessary for scanning within a flat working area, and the field distortion caused by the two-mirror system is compensated. However, this compensation is based on an “ideal lens” and ignores two phenomena:

• All lenses differ slightly due to manufacturing tolerances, causing a distortion from the “ideal lens”.

• The galvanometer scanners, which rotate the mirrors, have a non-linearity in their positions resulting from manufacturing tolerances.

Usually, these errors are so small they can be ignored in most applications. There are some situations, however, where the errors are significant, and need to be corrected. A method is needed to manipulate the values in the standard lens correction file, compensating for the aforementioned errors. The method is called Grid Correction, and a program is available from Lanmark Controls Inc. to accomplish this task.

The Grid Correction algorithm allows calibrating a field at 9, 25, or 81 points. The Grid Correction Program changes the standard lens correction file, producing a new one, calibrated for the current mechanical and lens combination. Please consult the factory regarding Grid Correction tools.
CORRECTING FOR MECHANICAL ALIGNMENT TOLERANCES

Although inherent distortions in the lens can be corrected with a lens correction file, errors or tolerances in the mechanical fixturing of the Scan Head to its mounting surface may produce additional scanning errors. In order to correct for these mechanical alignment errors, WinLase LAN provides the following features in the Lens Calibration Wizard:

- Adjustment of X and Y position of scan field.
- Adjustment of X and Y scale of scan field.
- Adjustment of Rotation of the scan field.

WinLase LAN maintains separate calibrations for each unique lens correction file. When switching between correction tables, the appropriate calibrations are applied. If calibrations have been applied to a correction table, WinLase LAN indicates this by prepending ‘(*)’ to the lens correction table name in the Hardware manager.

To adjust the X and Y Field Scaling

- WinLase LAN must have an active connection to an LEC-1 device
- From the Main menu, select System > Preferences. The System Preferences window appears.
- Click on the Hardware Tab. The Hardware configuration page appears.
- From the Hardware tree view, highlight the lens underneath the LEC-1 being adjusted. If the lens is not visible, click on the + next to the LEC-1, then select the lens.
- Click the Calibrate button. The confirmation window appears to verify the selection.
- Click OK. The Calibration Wizard appears.
- Click the Next button to start the Calibration Wizard. The Scale marking field page appears.
- In the Scale Marking field page, select the “Yes” option.
- Click the Next button. The Place your sample page appears.
- Follow the on screen instructions for placing the marking sample.
10 Click the Next button. The Mark test pattern page appears.

<table>
<thead>
<tr>
<th>WARNING</th>
<th>Laser will turn on when the Mark test pattern button is clicked. Check the beam path before proceeding.</th>
</tr>
</thead>
</table>

11 Click the Mark test pattern button. The sample will mark with the test pattern square.

12 Click the Next button. The Measure the results page appears.

13 Measure the test sample with a precision measuring device, noting the orientation of the X and Y axes. Enter the measurements in the appropriate edit boxes.

14 Click the Next button. The Remark new sample page appears.

<table>
<thead>
<tr>
<th>WARNING</th>
<th>Laser will turn on when the Mark test pattern button is clicked. Check the beam path before proceeding.</th>
</tr>
</thead>
</table>

15 Place a clean sample in the center of the marking field. Click the Mark test sample button. The sample is marked with the laser.

16 Click the Next button. The Verify the calibration page appears.

17 If the newly marked test sample measurements agree with the value stated on the Verify the calibration page, select the “Yes” option. If the measurements do not agree, select the “No” option.

18 If Yes is selected, click the Next button until the Wizard completes.

To adjust the X and Y Field Offset

- WinLase LAN must have an active connection to an LEC-1 device
- From the menu bar, select System > Preferences. The System Preferences window appears.
- Click on the Hardware Tab. The Hardware configuration page appears.
- From the Scan Card tree view, highlight the lens correction file attached to the Scan Head being adjusted. If the lens is not visible, click on the + next to the Scan Head, then select the lens.
- Click the Calibrate button. The confirmation window appears to verify the selection.
- Click OK. The Calibration Wizard appears.
- Click the Next button until the Offset marking field page appears.
- In the Offset Marking field page, click the “Yes” option, and then click the Next button. The Enter field offsets page appears.
- Enter the amount to offset the marking field in the appropriate edit boxes.
- Click the Next until the Wizard completes.
To adjust the Scan Field Rotation

1. From the menu bar, select System > Preferences. The System Preferences window appears.
2. Click on the Hardware Tab. The Hardware configuration page appears.
3. From the Hardware tree view, highlight the lens correction file attached to the LEC-1 being adjusted. If the lens is not visible, click on the + next to the LEC-1, then select the lens.
4. Click the Calibrate button. The confirmation window appears to verify the selection.
5. Click OK. The Calibration Wizard appears.
6. Click the Next button until the Rotate marking field page appears.
7. In the Rotate field page, click the “Yes” option, and then click the Next button. The Mark rotation test sample page appears.
8. To verify the settings, click the Mark test pattern button. Repeat the process until the marking field is correctly aligned.
9. Click the Next button until the Wizard completes.

To manually enter calibration values

- WinLase LAN must have an active connection to an LEC-1 device
1. From the menu bar, select System > Preferences. The System Preferences window appears.
2. Click on the Hardware Tab. The Hardware configuration page appears.
3. From the Scan Card tree view, highlight the lens correction file attached to the Scan Head being adjusted. If the lens is not visible, click on the + next to the Scan Head, then select the lens.
4. Click the Calibrate button. The confirmation window appears to verify the selection.
5. Click OK. The Calibration Wizard appears.
6. Click the Next button until the Calibration Method page appears.
7 Select Manually and click Next. The Enter Calibration Data page appears.

The Analog servo page

- **A** Amount to change the X axis scaling, in percent. Maximum range is ± 20.00%.
- **B** Amount to change the Y axis scaling, in percent. Maximum range is ± 20.00%.
- **C** Amount to offset the X axis.
- **D** Amount to offset the Y axis.
- **E** Amount to rotate the entire field, in degrees. A positive value will rotate the field counter-clockwise.
- **F** Click this button to restore the calibrations to factory defaults.
THE MARKING FIELD AND LENS
Correcting for Mechanical Alignment Tolerances
**CONNECTING TO LASERS**

The LEC-1 provides very flexible laser control capability that is synchronized with galvo motion control. Six dedicated TTL compatible signals are provided at all times whose timing relationships are defined by the Laser Driver file. Not all signals may be required for a given customer laser configuration. An integrator need only select an appropriate subset of these signals, and configure them via the WinLase LAN laser configuration Wizard with appropriate timing parameters.

**WORKING WITH THE LASER DRIVER WIZARD**

When modifying an existing Laser Driver, or to create a new one, WinLase LAN provides a Laser Driver Wizard.

To configure an existing Laser Driver file

1. From the menu bar, select System > Preferences.
2. Click on the Hardware tab. The Hardware page appears.
3. Click on the laser in the tree view to be configured.
4. Click the Configure button. The Configure Laser Driver File confirmation window appears, verifying the request to change the current laser driver.
5. Refer to the sections that follow for details on configuring specific laser signals.

To add a new Laser Driver file

1. From the menu bar, select System > Preferences.
2. Click on the Hardware tab. The Hardware page appears.
3. Click on any laser in the tree view.
4. Click the Change button. The Select Laser Driver window appears.
5. Click the Install New Laser button. The Laser Configuration Wizard appears.

*NOTE* • The Install New Laser button will not be available if a hard lock license key is not detected
6 Click the Next button to start the Laser Configuration Wizard. The Laser Description page appears.

7 Enter a unique descriptive name in the edit box. This name will appear in the list of available laser drivers.

8 Refer to the sections that follow for details on configuring specific laser signals.

UNDERSTANDING THE LASER CONTROL SIGNALS

WinLase LAN uses a Laser Driver file, which controls the timing relationship between all of the laser control signals on the LEC-1. WinLase LAN ships with several pre-defined Laser Driver files and new Laser Driver files can be created as well.

TIMING DIAGRAM

The LEC-1 provides the following laser control signals:

- **Laser Modulation 1** - Provides a variable frequency and pulse width signal.
- **Laser Modulation 2** - Provides a variable frequency and pulse width signal that is phase shifted 180 degrees from Laser Modulation 1.
- **Laser On 1** - Provides a gate signal that switches HIGH at the start of a marking vector, and then LOW at the end of the marking vector.
- **Laser FPK** - Provides a pulse that is triggered at the beginning of a marking vector to provide a means of suppressing the first pulses on certain laser types.
- **Laser Enable** - Switched HIGH before a marking vector starts, and then switched LOW after a timeout has expired. This signal is used to allow certain lasers to enable their control circuitry.
• **Visible Pointer** - Provides a dedicated signal to control a guide laser

• **Laser Power Data 0 to 7** - An 8-bit (or optionally 7-bit with latch) signal which can be used to control the laser power, or for waveform control.

• **Laser Analog Power** - An analog signal, with a maximum range of 0 - 10 VDC, which can be used to control the laser power.

The following diagram illustrates the digital laser control signals and their relationship to one another.

*Digital laser signal timing relationships*
CONNECTING TO LASERS

Working with the Laser Driver Wizard

CONFIGURING THE LASER POWER CONTROL SIGNALS

Generally speaking, there are two ways in which the output power of a laser is controlled:

- **Pulse Width Modulation (PWM)** control, where the power of the laser is controlled by a single laser modulation signal. The frequency and pulse width of the drive signal is variable, and the Duty Cycle of the signal controls the power of the laser. CO2 lasers are typical of the PWM type. The following partial screen shot of an Object Profile illustrates the Laser power and the Frequency parameters. When either the Laser power value, or the Frequency value is changed, the Pulse Width (which is not shown) is calculated automatically. For lasers that require a limited range of duty cycles, the maximum and minimum Duty Cycle can be configured in the Laser Driver file.

```
Laser power: 10.000 %  
Frequency: 2.00 kHz
```

*The Laser power and Frequency fields control power in a PWM laser*

- **Discrete** control, where individual signals for power (analog or digital), laser gate and modulation may all be required to control different aspects of the lasers output. Additional signals, such as first pulse suppression, and an enable signal may be required as well. When using this type of control, WinLase LAN offers a *Power Change Delay*, which automatically compensates for the time it takes the laser to change from one power setting to the next. The following partial screen shot of an Object Profile illustrates the Laser power, Frequency, and Pulse width parameters. The Laser Power parameter controls both the Laser Power Analog signal and the 8-bit Digital power signals. The Frequency and Pulse width signals control the Laser Modulation 1 signal.

```
Laser power: 92.126 %  
Frequency: 2.00 kHz  
```

*Laser power is controlled independently of Frequency and Pulse width in a Discrete input laser*
To configure the Laser Power Type

1. Open the Laser Driver Wizard. See "Working with the Laser Driver Wizard" for details on how to open the Wizard.

2. Press the Next button until the "Laser Type" page appears.

Selecting what type of laser to configure
A. Configure the Laser Driver for a PWM type laser
B. Configure the Laser Driver for a Discrete power control type laser
To select analog or digital power control

**NOTE** • These settings only apply to lasers with discrete laser power control.

1. Open the Laser Driver Wizard. See “Working with the Laser Driver Wizard” for details on how to open the Wizard.

2. Press the Next button until the “Power control interface” page appears.

Selecting analog or digital power control

_A_ The laser requires an analog signal to control the power

_B_ The laser requires a digital signal to control the laser power

_C_ In some lasers, both the analog and digital outputs are controlled separately. Select this option to have independent control over the analog and digital outputs
To configure the analog drive voltage range

**NOTE**
- These settings only apply if the laser uses an analog input to control the laser power.

1. Open the Laser Driver Wizard. See "Working with the Laser Driver Wizard" for details on how to open the Wizard.
2. Press the Next button until the "Analog drive voltage" page appears.

### Configuring the analog drive voltage range

**A** Specify the voltage input required to achieve maximum laser power. When any Laser power field in WinLase LAN is set to 100%, the analog output will be at this level.

**B** Specify the voltage input required to achieve minimum laser power. When any Laser power field in WinLase LAN is set to 0%, the analog output will be at this level.
**CONNECTING TO LASERS**

*Working with the Laser Driver Wizard*

To configure the digital (8-bit) control range

| NOTE | These settings only apply if the laser uses an 8-bit digital input to control the laser power. |


2. Press the Next button until the "Digital power control range" page appears.

![Digital Power Control Range](image)

Configuring the digital power control range

**A** Specify the 8-bit value required to achieve maximum laser power. When any Laser power field in WinLase LAN is set to 100%, the 8-bit Laser Power Data outputs will be at this level.

**B** Specify the 8-bit value required to achieve minimum laser power. When any Laser power field in WinLase LAN is set to 0%, the 8-bit Laser Power Data outputs will be at this level.

**C** Specify the 8-bit value that the Laser Power Data outputs will be set to when the LEC-1 device powers up.

**D** Some lasers require a signal to latch the Laser Power Data bits. Selecting this option will configure the LSB (Laser Power Data 1) to produce a pulse (LOW-HIGH-LOW) whenever the power has changed.
To set the Duty Cycle range

1. Open the Laser Driver Wizard. See “Working with the Laser Driver Wizard” for details on how to open the Wizard.

2. Press the Next button until the “Modulation Duty cycle” page appears.

Configuring the duty cycle range for PWM laser types

A. Specify the maximum duty cycle that is allowed on the laser. When any Laser power field in WinLase LAN is changed, this maximum will be validated.

B. Specify the minimum duty cycle that is allowed on the laser. When any Laser power field in WinLase LAN, this minimum will be validated.

NOTE • These settings only apply if the laser is a PWM type.
Overriding the power settings with the laser controller

**NOTE**

- These settings only apply if the laser uses an 8-bit digital input to control the laser power.

1. Open the Laser Driver Wizard. See “Working with the Laser Driver Wizard” for details on how to open the Wizard.
2. Press the Next button until the “Manual laser power control” page appears.

![Lumera Laser Configuration Wizard](image)

Configuring the manual override feature

- To use a panel control to manually control the laser power, select the Yes option.
To configure the Power Change Delay

1. Open the Laser Driver Wizard. See “Working with the Laser Driver Wizard” for details on how to open the Wizard.

2. Press the Next button until the “Power Change Delay” page appears.

Configure the power change delay

A When the Laser power changes during marking, a delay can be specified to allow the laser to reach the new power value. This delay is inserted after the Laser power command has changed, but before any marking vectors are processed.

NOTE • This setting only applies to lasers with discrete laser power control.
To control how the laser power is displayed in WinLase LAN

**NOTE**

This setting only applies to lasers with discrete laser power control.

1. Open the Laser Driver Wizard. See “Working with the Laser Driver Wizard” for details on how to open the Wizard.

2. Press the Next button until the “Laser power display units” page appears.

- **A** The Laser power field in the Object Profile is displayed as a percentage of total available power.
- **B** The Laser power field in the Object Profile is displayed in watts.

Configuring the power display units

Click Next to continue.
CONFIGURING THE LASER MODULATION SIGNAL

The Laser Modulation signal provides a programmable pulse stream where both frequency and pulse width can be controlled. Two Hardware frequency ranges are available to suit most laser types. The Laser Modulation signal has two modes:

- **Stand-By** - Also known as a tickle signal. Provides a programmable frequency and pulse width stream when the laser is OFF. The Stand-By settings are configured in the Laser Driver file.

- **Active** - Provides a programmable frequency and pulse width stream when the laser is ON. The Frequency and Pulse width are configured in the Object Profile, as shown in the following screen shot. Either or both of these fields can be hidden in the Object Profile page if the laser does not support them.
To select the Hardware frequency range

1. Open the Laser Driver Wizard. See "Working with the Laser Driver Wizard" for details on how to open the Wizard.
2. Press the Next button until the "Hardware Frequency Range" page appears.

Setting the LEC-1 hardware frequency range

**A** Configure the LEC-1 device to output a frequency range of 20 Hz to 900 kHz. The pulse width resolution will be 1 µs in this mode, and all laser signal parameters will have their full range available.

**B** Configure the LEC-1 device to output a frequency range of 200 Hz to 5 MHz. The pulse width resolution will be 100 ns in this mode, but reduces the range of the laser signal parameters by a factor of 10.
To configure the polarity of the Laser Modulation signal

1. Open the Laser Driver Wizard. See “Working with the Laser Driver Wizard” for details on how to open the Wizard.

2. Press the Next button until the “Laser Modulation delay and polarity” page appears.

Configuring the polarity

A. When set to High Active, the Laser Modulation output switches to TTL +5VDC when the laser is ON.

B. When set to Low Active, the Laser Modulation output switches to TTL GND when the laser is ON.
CONNECTING TO LASERS

Working with the Laser Driver Wizard

To show or hide the Frequency and Pulse width fields

1. Open the Laser Driver Wizard. See “Working with the Laser Driver Wizard” for details on how to open the Wizard.
2. Press the Next button until the “Frequency and Pulse Width control” page appears.

Controlling the visibility of the frequency and pulse width fields

A. Select Yes to show the Frequency field in the Object Profile, select No to hide the field.
B. Select Yes to show the Pulse width field in the Object Profile, select No to hide the field.

The Pulse width field is hidden

The Pulse width field is available
To set the allowable range of frequencies

1. Open the Laser Driver Wizard. See "Working with the Laser Driver Wizard" for details on how to open the Wizard.

2. Press the Next button until the "Laser Modulation Frequency Range" page appears.

Controlling the frequency range

A. Specify the maximum frequency that can be used to control the laser. When any Frequency field in WinLase LAN is changed, this value is used to validate the change.

B. Specify the minimum frequency that can be used to control the laser. When any Frequency field in WinLase LAN is changed, this value is used to validate the change.
To set the allowable range of pulse widths

1. Open the Laser Driver Wizard. See "Working with the Laser Driver Wizard" for details on how to open the Wizard.

2. Press the Next button until the "Pulse Width Range" page appears.

Controlling the pulse width range

A Specify the maximum pulse width that can be used to control the laser. When any Pulse width field in WinLase LAN is changed, this value is used to validate the change.

B Specify the minimum pulse width that can be used to control the laser. When any Pulse width field in WinLase LAN is changed, this value is used to validate the change.
To set the Stand-by frequency and pulse width

1. Open the Laser Driver Wizard. See "Working with the Laser Driver Wizard" for details on how to open the Wizard.

2. Press the Next button until the “Standby (Tickle) signal” page appears.

The Standby signal page

A. Select Yes to enable a Stand-By pulse stream. Select No to disable.
B. Specify the pulse width of the Stand-By pulse stream.
C. Specify the frequency of the Stand-By pulse stream.
CONFIGURING THE LASER ON SIGNAL

The Laser On (Gate) signal is asserted when the laser is ON.

To configure the polarity of the Laser On (Gate) signal

1. Open the Laser Driver Wizard. See "Working with the Laser Driver Wizard" for details on how to open the Wizard.

2. Press the Next button until the “Laser Modulation delay and polarity” page appears.

When set to High Active, the Laser On (Gate) output switches to TTL +5VDC when the laser is ON.

When set to Low Active, the Laser On (Gate) output switches to TTL GND when the laser is ON.
CONFIGURING THE LASER ENABLE SIGNAL

The Laser Enable signal is asserted a programmable time before the Laser On (Gate) signal, and is de-asserted after a programmable period of laser inactivity.

To modify Laser Enable signal settings
1. Open the Laser Driver Wizard. See "Working with the Laser Driver Wizard" for details on how to open the Wizard.
2. Press the Next button until the “Laser Enable signal” page appears.

The Laser Enable signal page
A. Specify the amount of time before the Laser Modulation 1 signal to turn ON the Laser Enable signal.
B. Specify the Enable Timeout. After the Laser Modulation 1 signal has been inactive for longer than the Laser Enable Timeout, the Laser Enable signal is turned off.
C. When set to High Active, the Laser Enable output switches to TTL +5VDC when ON.
D. When set to Low Active, the Laser Enable output switches to TTL GND when ON.
CONFIGURING THE FIRST PULSE KILLER SIGNAL

To modify Laser FPK (First Pulse Killer) signal settings

1. Open the Laser Driver Wizard. See “Working with the Laser Driver Wizard” for details on how to open the Wizard.

2. Press the Next button until the “First Pulse Suppression signal” page appears.

   ![FPK Signal Configuration Wizard](image)

The FPK signal page

A. Specify the start position of the FPK signal. The start position of the FPK signal is measured from the leading edge of the Laser On (Gate) signal. For the FPK signal to start before the Laser On (Gate) signal, use a negative value.

B. Specify the pulse width of the FPK signal.

C. When set to High Active, the Laser FPK output switches to TTL +5VDC when ON.

D. When set to Low Active, the Laser FPK output switches to TTL GND when ON.

NOTE

- These settings only apply to lasers with discrete laser power control.
USING A VISIBLE POINTER

WinLase LAN provides features for controlling a visible (Guide beam) laser to assist in aligning object marking to the actual part.

ENABLING VISIBLE POINTER CONTROL

WinLase LAN supports the integration of a visible pointer laser (sometimes referred to as a Guide beam). The Visible Pointer option is turned on in the Laser Driver file, which then enables the Visible Pointer controls in WinLase LAN.

To enable the Visible Pointer option

1. Open the Laser Driver Wizard. See "Working with the Laser Driver Wizard" for details on how to open the Wizard.

2. Press the Next button until the “Visible pointer” page appears.

   - Select Yes to enable the Visible Pointer controls in WinLase LAN, select No to disable them.
CALIBRATING THE VISIBLE POINTER

Because of the difference in the wavelengths between the Visible Pointer laser and the marking laser, the Visible Pointer beam will not always indicate the true position of the marking beam. WinLase LAN provides a calibration routine to align the Visible Pointer laser with the marking laser. The Laser Driver file must have the Visible Pointer option enabled.

To calibrate the Visible Pointer

1. From the Main menu, select System > Preferences.
2. Click the Hardware tab. The Hardware page appears.
3. Select the Visible pointer item in the Hardware list. The Calibrate button becomes enabled.
4. Click the Calibrate button. The Visible Pointer Calibration Wizard appears.
5. Click the Next button to start the Wizard. The Place your sample page appears.
6. Place a marking sample in the marking area and click the Next button. The Mark test pattern page appears.

**WARNING**
- Laser will turn on when the Mark test pattern button is clicked. Check the beam path before proceeding.

7. The test pattern is a square centered in the field. The size of the test square can be set with the Test pattern size value. Enter a value, or accept the default.
8. Click the Mark test pattern button to mark the sample. After the sample is marked, click the Next button. The Align visible pointer page appears.
Using the Object position arrow buttons and the Object size arrow buttons, move the visible pointer beam until it lies exactly on top of the laser mark. After the visible pointer beam is aligned correctly with the laser mark, click the Next button until the Wizard completes.
CONNECTING TO LASERS

Laser Diagnostics

LASER DIAGNOSTICS

WinLase LAN provides a tool window to turn the laser on and off from the user interface. Scan Head beam position can be selected, laser parameters can be set, and the laser manually fired, for example, in alignment operations.

To use the Laser Diagnostics Tool

1. From the Main menu, select Tools > Laser Diagnostics. The Laser Diagnostics window appears.

The Laser Diagnostics window

A. The X and Y coordinates of the beam position in the current units.
B. The power at which the laser will be set when the Fire button is pressed.
C. The frequency of the laser modulation signal, in kHz.
D. The pulse width of the laser modulation signal, in µs.
E. On some laser types, the laser power can be controlled from the front panel of the laser controller.
F. Turns the laser ON immediately.
G. Turns the laser OFF immediately. The following operations also stop the laser:
   - Clicking the Done button
   - Pressing the ESC key on the keyboard
Marking systems are often required to control one or more motors or actuators to execute complex production sequences. Typical uses of motion in a laser marking environment are:

- Adjust XY table to implement step and repeat marking or locate parts with respect to the marker lens.
- Adjust rotary axis to locate parts with respect to the marker lens.
- Adjust height of marker head to pre-programmed static positions to accommodate marking surfaces at different heights above the tooling plane.
- Rotate a circular cylindrical part while marking to ensure mark completely wraps around part with no distortion or areas out of focus. This feature can be used with a basic 1 to 1 gearing, or more advanced implementations which includes a stage with gearing and index (home) sensor.

WinLase LAN provides two methods for motion control:

- Using Intelligent motion motors with integrated controller/drivers
- Using a Prodex OMS dedicated motion controller card that installs in the PC.

Both solutions cannot be used simultaneously. If WinLase LAN detects an OMS card, it will disable the Intelligent motion solution. Likewise, if no OMS card is detected, the Intelligent motion solution will be available.

Using a supported intelligent motion solution, WinLase LAN allows the user to control up to 32 individual motion axes, with any combination of linear, rotary and XY motion devices. The intelligent motion devices are characterized by their ability to daisy chain multiple devices connected to a single RS-232 COM port. The solution consists of two major components - WinLase LAN, which is responsible for issuing serial commands to the individual motors, the motors themselves with integrated serial communication hardware, encoders, cabling and sensor inputs, and the motor power supply. The motors selected are from the Schneider Electric MDrivePlus family, and communication between motors and WinLase LAN is conducted using the MDrivePlus communication protocol. WinLase LAN supports the concept of Motion Configurations, where combinations of different motion axes are saved in a configuration file.
QUICK START GUIDE

In general, use the following steps to set up your motion hardware:

• Connect the motion hardware to the LEC-1 device using the appropriate cabling. See “Connecting the Motion Hardware”.

• Create a new Motion Configuration in WinLase LAN. In a Motion Configuration, you add individual motion axes, which are then made available to WinLase LAN when programming motion Automation objects. See “Working with Motion Configurations”.

• Program each individual axis contained in the Motion Configuration. See “Programming a motion axis”.

• Configure the individual axis parameters, such as accelerations and speeds, homing and limit parameters, etc. within the Motion Configuration to adapt the axis to the specific hardware. See “Configuring the Axis Types”.

• Test the configuration using the Motion Manager. See “Motion Manager” on page 3-16.

• Add motion based Automation objects to a job to automate the use of the Motion Configuration. See “Linear Motion” on page 6-95.

CONNECTING THE MOTION HARDWARE

In most applications, the motion hardware will be connected through the appropriate cabling to one of the available RS-232 COM ports on the LEC-1 device. Since some motion hardware uses RS-485 communication, it may be necessary to provide an adapter between the LEC-1 device and the motion hardware. Please refer to the documentation supplied with the motion hardware for instructions on proper cabling, etc. The communications settings for the LEC-1 COM port can be configured for proper communication with the motion hardware.
To configure the LEC-1 COM port

1. Create a connection to the LEC-1 device to configure. See “Making a Connection” on page 4-6.

2. In the Laser System Viewer, right-click on the connected LEC-1 device, and select Settings.

3. Click the COM Ports tab. The COM ports page appears.

   ![LEC-1 COM Ports settings page]

   The LEC-1 COM Ports settings page
   
   A Configure which COM port to use on the LEC-1 device for motion control.
   B Configure the port speed (default = 9600).

**WORKING WITH MOTION CONFIGURATIONS**

Similar to the laser and lens configuration files, a Motion Configuration describes the particular hardware setup so WinLase LAN can properly interact with the hardware. Additionally, since intelligent motion devices communicate on a common bus, each device needs to have a unique name so that WinLase LAN can identify and send instructions to the device. Part of the process of creating a new motion configuration involves programming each motion device with a unique name.
To create a new Motion Configuration

1. From the Main menu, select System > Preferences.
2. Click the Hardware tab. The Hardware page appears.
3. Select a current Motion Configuration, either under the “Offline Configuration”, or under an LEC-1 device.
4. Click the Change button. The Select Motion Configuration dialog appears.
5. Click the Install New Motion... button. The Motion Configuration dialog appears. See Adding an axis type.
To modify an existing Motion Configuration

1. From the Main menu, select System > Preferences.
2. Click the Hardware tab. The Hardware page appears.
3. Select the Motion Configuration to modify under an LEC-1 device.
4. Click the Configure button. The Motion Configuration dialog appears. See “To add a Motion type to a Motion Configuration”.

UNDERSTANDING THE MOTION TYPES

When a motion type is added to a Motion Configuration, a logical connection is made to a specific motion device. Adding a motion type to the list tells WinLase LAN that a particular motion hardware device is available for use in a corresponding Automation object. For example, to use a Linear motion Automation object, there must be at least one Linear motion type in the Motion Configuration. See Linear Motion, Rotary Motion or XY Motion for details on configuring motion Automation objects.

Left: A Linear motion type as it appears in the Motion Configuration
Right: The same motion type is now available in a Linear motion Automation object
MOTION CONFIGURATION
Intelligent motion control

To add a Motion type to a Motion Configuration
1 From the Motion Configuration tool, select a Motion type from the Available Motion types list.
2 Click the Add button. The Motion type is added to the Motion Configuration.

To remove a Motion type from a Motion Configuration
1 From the Motion Configuration tool, select a Motion type in the Current Configuration list.
2 Click the Remove button. The Motion type is removed from the Current configuration.

CONFIGURING AXIS PARAMETERS
Each Motion type in the Motion Configuration must be logically linked to an actual hardware device. This linking is done by giving the each motion axis within the Motion type a unique name, and linking it to a specific hardware driver type.

PROGRAMMING A MOTION AXIS
Each axis must be programmed before use. Once the motion configuration is completed, use the “Program Axis” button from the Provisioning window to store the configuration to the motors. Each motor will receive a letter name (A-Z) during this process.

Motors MUST be programmed individually, using a primary communication cable with only a single motor connected at a time. It is not possible to program correctly with multiple motors connected with a “daisy chain” cable.

Because a unique name is generated for each motion axis, all of the Motion types should be added to the Motion configuration before the axes programming process is started.
To program a Motion axis

1. From the Main menu, select System > Preferences.
2. Click the Hardware tab. The Hardware page appears.
3. Select the Motion Configuration to be modified.
4. Click the Configure button. The Motion Configuration tool appears.
5. From the Motion Configuration tool, select the Motion type from the Current configuration list. The motion axis settings panel appears.
6. Click the Provisioning tab. The Provisioning page appears.

A The current configuration to program
B This button starts the hardware programming wizard used to download configuration data into IMS Md rive motors.

* After selecting the Hardware driver and display name, click the Program Hardware... button. The Program Axis Controller Wizard appears. Follow the Wizard instructions to complete the programming of the axis.
CONFIGURING AXIS SETTINGS
Each axis has speed, acceleration, limits, homing and encoder settings that need to be configured.

To change the Provisioning settings
1. From the Main menu, select System > Preferences.
2. Click the Hardware tab. The Hardware page appears.
3. Select the Motion Configuration to be modified.
4. Click the Configure button. The Motion Configuration tool appears.
5. From the Motion Configuration tool, select the Motion type from the Current configuration list. The motion axis settings panel appears.
6. Click the Provisioning tab. The Provisioning page appears.

The Motion Configuration Provisioning page
A. The number of microsteps per motor revolution is displayed. This value is calculated differently based on the motor's encoder setting. If the encoders are disabled (open loop mode), the microsteps per revolution are the (Microstep Resolution)*200 steps/rotation. This gives 52,100 microsteps per revolution at the highest microstep resolution setting. If the encoders are disabled there is a fixed value of 2048 microsteps/rev based on the encoder resolution.
**B** This value selects the level of microstepping in open loop mode. Acceptable values are 2, 4, 5, 8, 10, 16, 25, 32, 50, 64, 100, 128, 200, 250, 256. Other special values are:
- 18 = .01 degrees / µstep
- 108 = 1 arc minute / µstep

**C** This parameter selects the number of microsteps per unit distance at the part. It will be in units of µsteps/degree, µsteps/mm, µsteps/inch, etc. This multiplier is used to accommodate for any gearing changes and calibrate the system to the specific motion stage setup. For a typical 1:1 rotary stage, for example, this value will be the same as the number of microsteps/revolution divided by 360, or 142.2 µsteps/degree. A 20:1 high-precision stage would require this value to be multiplied by 20 to get the correct calibration factor. Verify the calibration factor is correct by moving the stage a given distance and measuring the actual traveled distance.

**D** This parameter sets the motor hold current as a percentage of total current. Hold current is the amount of current that the motor uses to keep the motor static between movements. A stage which loads the motor at idle (like a Z-axis stage with a marker head attached) requires more current to maintain its current position, and thus a higher hold current value than a stage with lower load. A higher hold current uses more electricity and causes the motor to heat up, so it is important to balance the need for a stiff motor against the additional heat introduced into the system and the movement duty cycle. At high hold current values the motor can become hot to the touch.

**E** This parameter sets the motor run current as a percentage of total current. Run current is the amount of current the motor uses during movements. Faster movements, higher accelerations, and high stage loads increase the necessary run current. Set the run current to a setting that allows the desired speeds and accelerations to run without stalling, but do not set the run current higher than is necessary to prevent the motor from becoming unnecessarily hot. It is important to balance the speeds and accelerations with the run current and duty cycle to find the optimal setting.

**F** This parameter reverses the direction the motor traverses with respect to the positive axis of the WinLase LAN mark field. This setting is determined by the stage configuration.
To change the Encoder settings

1. From the Main menu, select System > Preferences.
2. Click the Hardware tab. The Hardware page appears.
3. Select the Motion Configuration to be modified.
4. Click the Configure button. The Motion Configuration tool appears.
5. From the Motion Configuration tool, select the Motion type from the Current configuration list. The motion axis settings panel appears.
6. Click the Encoder tab. The Encoder page appears.

The Motion Configuration Encoder page

- **A** Enables the built-in encoders on equipped drives. Choose drives with the “-EQ” option to get the built-in 2048 line encoder.
- **B** This parameter sets the number of counts that determine the width of the “dead band”. In closed loop feedback mode the motor will compare the requested position with the encoder position and automatically make adjustments to ensure that the motor is in the correct place. The dead band is the zone around the requested point at which the motor considers it “close enough”. It is important to balance the desire for a tight tolerance against the physical parameters of the stage and the extra current required to maintain a location against static load. This value is only meaningful when “Enable position maintenance” is checked.
C The stall factor sets the number of counts required for a stall error to be reported to the laser marker. If the motor's current position is different from the current requested position by greater than the number of counts set in this stall factor the motor will error out and stop moving. This is useful to minimize damage in the case of motor crashes, part jams, or other issues. It is also useful in position maintenance mode because it causes a fault if the maintenance is unable to maintain the desired position.

D Select this option to enable the closed-loop position maintenance algorithm. The motor will compare the requested position with the current position reported by the encoders and make any movements necessary to correct errors within the tolerance of the dead band. If the position errors are so great that they exceed the stall factor an error will be reported and the motor will stop moving if Stop on Stall is checked. When position maintenance is enabled it is important to properly set the dead band and stall factor to reasonable values, and ensure that the run current is high enough to allow the stage to move if position maintenance is required.

E This option causes detected stalls to stop the motor from moving until the motor is reset. Use this option to protect the system from damage in the case of stage crashes or part jams.
To change the Homing settings

1. From the Main menu, select System > Preferences.
2. Click the Hardware tab. The Hardware page appears.
3. Select the Motion Configuration to be modified.
4. Click the Configure button. The Motion Configuration tool appears.
5. From the Motion Configuration tool, select the Motion type from the Current configuration list. The motion axis settings panel appears.
6. Click the Homing tab. The Homing page appears.

The Motion Configuration Homing page in slew mode

A. The Homing style pull down menu selects the homing behavior from a number of different options as described below. In all cases, if the high or low limit is reached before the home limit is reached the slew direction will reverse, but the creep direction will remain the same

- Slew in Minus direction, then creep in Plus direction - The stage will slew in the negative direction until the limit switch is found, then creep in the minus direction across the length of the switch until the edge of the switch is found
- Slew in Plus direction, then creep in Minus direction - The stage will slew in the positive direction until the limit switch is reached, then creep in the negative direction until the edge of the limit switch is found.
• Slew in Plus direction, then creep in Plus direction - The stage will slew in the positive direction until the limit switch is found, then creep in the positive direction across the length of the switch until the edge of the switch is found.
• Run to Plus Limit Switch - The stage will run to the positive limit switch, then set the home position
• Run to Minus Limit Switch - The stage will run to the negative limit switch, then set the home position

B Select from the following options:
• Home input is floating - This selection causes the system to interpret the I/O pin entering a floating state as activation. This option is available in both sinking and sourcing modes.
• Home input is pulled HIGH (or LOW) - This selection causes the system to interpret the limit input as transitioning from Low to High (sourcing) or High to Low (sinking) as activation. This is the most common setting when using solid state optical limits.
• On Encoder Index Mark - This selection causes the system to determine it has reached its home when the motor encoder reaches a built-in index mark. This is very useful for direct drive rotary systems without limit switches. It is important not to use this setting on systems with alternative gearing since there is one home index every motor revolution, which may not correspond to the same home location every time on an arbitrary system

C This parameter sets the “creep” velocity in steps/seconds. The homing stage first slews until it finds the appropriate limit, then creeps in a manner determined by the setting of the “Homing Style” pull down menu. Set this value to a low setting for accurate homing.

D This parameter sets the offset position from the home flag in steps. This value can be positive or negative. When the stage has reached home it will move the desired number of steps at the home creep speed. This function is particularly useful when trying to execute the same WinLase LAN job on two different machines. Each machine will have a different necessary home offset, which can be corrected using this parameter.

E The sensor debounce is a time in milliseconds required from when a limit switch is activated until the homing routine continues to the next phase. This is intended to compensate for switches with a lot of electrical “bounce” or instability on transition. Most mechanical switch systems require a debounce. 0 ms is a typical setting for solid state optical sensors.

F This parameter sets the “slew” velocity in steps/seconds. The homing stage first slews until it finds the appropriate limit, then creeps in a manner determined by the setting of the “Homing Style” pull down menu. Set this value to a slow to medium setting for accurate homing. Slower home slews slow homing time, while longer home slews require increased creep distances due to stage inertia.

G This parameter sets the deceleration rate of the stage during the homing process in units of steps/s². This is the rate at which the stage will decelerate when it finishes its slew and creep movements. Select a high value for accurate and quick homing.

H This pull down menu is where the wiring style of the limit sensors is configured. Changing this option will change some choices in the “At home when” pull down menu to accommodate the differing polarity of sinking and sourcing modes. Select the following options:
• Sinking - where the limit I/O pin at 24V is pulled down to 0V to activate,
**MOTION CONFIGURATION**

**Intelligent motion control**

- **Sourcing** - where the limit I/O pin at 0V is pulled up to 24V to activate.

The Motion Configuration Homing page in Run to limit mode

This parameter sets the acceleration rate of the stage during the homing process in units of steps/s². This is the rate at which the stage will start its move to the limit switch. Select a high value for accurate and quick homing.
To change the Limits settings

1. From the Main menu, select System > Preferences.
2. Click the Hardware tab. The Hardware page appears.
3. Select the Motion Configuration to be modified.
4. Click the Configure button. The Motion Configuration tool appears.
5. From the Motion Configuration tool, select the Motion type from the Current configuration list. The motion axis settings panel appears.
6. Click the Limits tab. The Limits page appears.

The Motion Configuration Limits page

A. Select from the following options:
   - Limit is floating - This selection causes the system to interpret the I/O pin entering a floating state as activation. This option is available in both sinking and sourcing modes.
   - Home input is pulled HIGH (or LOW) - This selection causes the system to interpret the limit input as transitioning from Low to High (sourcing) or High to Low (sinking) as activation. This is the most common setting when using solid state optical limits.
   - Ignore limits - Ignores limit switches. Commonly used for direct drive rotary stages with no limit switches.

B. Soft limit of hardware travel in the negative direction. This value can be set precisely by moving the hardware to the minus limit switch and noting the value of the position counter. Enter a value
greater than the position counter for WinLase LAN to limit the travel. For the limit switch to limit
the travel, enter a value less than the position counter.

C Soft limit of hardware travel in the positive direction. This value can be set precisely by moving the
hardware to the plus limit switch and noting the value of the position counter. Enter a value less
than the position counter for WinLase LAN to limit the travel. For the limit switch to limit the travel,
enter a value greater than the position counter.

D The sensor debounce is a time in milliseconds required from when a limit switch is activated until
the limit is considered activated. This is intended to compensate for switches with a lot of electrical
“bounce” or instability on transition. Most mechanical switch systems require a debounce. 0ms is a
typical setting for solid state optical sensors.

E Use this option to decelerate the motor using a ramp profile instead of a constant profile. This
setting is used for stages with high inertia that do not respond well to rapid deceleration.

F This pull down menu is where the wiring style of the limit sensors is configured. Changing this
option will change some choices in the “At home when” pull down menu to accommodate the
differing polarity of sinking and sourcing modes. Select the following options:
- Sinking - where the limit I/O pin at 24V is pulled down to 0V to activate,
- Sourcing - where the limit I/O pin at 0V is pulled up to 24V to activate.
PRO-DEX OMS MOTION CONTROLLER

Using the OMS PCIX series motion controller, WinLase LAN provides a full 4-axis motor controller capability. With this controller, WinLase can interface to 4 individual motor axes, for applications such as rotary indexers, XY tables, linear slides, etc.

INSTALLING THE MOTOR CONTROLLER CARD

| NOTE | • Not supported on Windows Vista or Windows 7. |

Before using the motor controller card, it must be properly installed and configured. Make sure that WinLase LAN is already installed on the target machine before installing the motor controller card. If WinLase is not installed, see Getting Started > Software Installation.

To install the Motor Controller Card

| WARNING | • Turn OFF the power to the computer and disconnect the power cord. |

1. Discharge any static electricity build-up before handling the Motor Controller Card by touching a grounded metal object (like the exposed metal parts on the back of the computer).
2. Remove the cover from the computer. (Refer to the computer manual for instructions on removing the cover).
3. Locate an unused PCI slot. Remove the expansion slot cover. Save the slot cover screw for use in Step 5.
4. Remove the motor controller card from its antistatic packaging. Always handle the card by its edges.
5. Insert the motor controller card into the PCI expansion slot. Press down firmly until the card clicks into place and then replace the slot cover screw. The motor controller card installed in a PCI slot is shown below.
6. Replace the computer cover.
7. Reconnect the power cables to the computer.

To install with Plug and Play

1. Power up the computer. After logging in, Windows will detect the new hardware and show the Files Needed dialog (Windows 2000).
2. Click the Browse button, and browse to the \marker\oms folder. Click OK to close the browse dialog.
3. Click OK to close the Files Needed dialog. Windows completes the installation of the OMS drivers.
CONFIGURING THE MOTOR CONTROLLER SETTINGS

To configure the Motor Controller Settings
1. From the menu bar, select System > Preferences.
2. Click on the Motor Control tab. The Motor Control page appears.
3. Click the Configure button. The OMS Motor Controller setup appears.
4 Click the Controller Settings tab. The Controller Settings page appears.

The Controller Settings page

A Select the current axis to edit.
B Set the base velocity for the current axis. Note that setting a nonzero base velocity provides a means to accelerate through resonance as fast as possible.
C Set the maximum velocity the user will be allowed to enter throughout the WinLase LAN application.
D Enter the minimum velocity the user will be allowed to enter throughout the WinLase application.
E Changes the direction the motor turns when given a move command.
F Define the switch contact state when at the limit position.
G This feature is always enabled. The motor controller will monitor the forward and reverse limit switches while executing moves.
H This feature is always enabled. The motor controller will stop an axis after a limit switch is signaled using a deceleration profile.
I Select from the following options:
   • Absolute
   • Relative
J Select the acceleration ramp for the current axis.
K Set the maximum acceleration rate for the current axis.
L Select the number of steps in the acceleration ramp.
M Define the switch contact state when at the home position.
When homing, approach the home switch moving in the direction selected in this control.

LEARNING THE HOME AND LIMIT POSITIONS
Before using your motor controller card, the Home, Forward and Reverse limits must be learned so WinLase LAN knows what the mechanical limits for each axis are. The setup of the Home and Limits are in the XY Table, Custom Axis or Rotary pages.

| NOTE | The Controller Settings should be set up before setting the Home And Limits. In the Controller Settings page, the Direction selection should be based on how this axis is generally moved. If you usually leave the motor on the positive side of home then you should use the negative edge (direction) for detection |

Homing the axis
Homing is performed at 90 percent of the maximum speed for the axis. This value is set in the Controller Settings page for each axis. Start at the highest practical axis speed and adjust down until homing and carriage movement is acceptable. To offset the Home position (for example so that Home equals 1000 steps), enter 1000 in the edit box next to the Home button. Click the Apply button then click the Home Button for this offset to take effect. Changing the Sensor Direction or Home Position Offset probably requires changes to axis position values in currently saved jobs. Therefore it is suggested that home be established and kept with the same parameters once installed. It is also suggested that upon starting WinLase LAN the motor position(s) should be between the limit sensors for best results.

A Motor Home Menu is called upon entering WinLase LAN. This window (see below) is used to force all axes to home when WinLase LAN is first started.

The Home axes dialog
It is also available from an axis automation object's Properties menu. In addition, the Motor Manager also allows homing of the selected axis. If a job is selected to run and an axis has not been homed then the operator will enter the Motor Home Menu. If one finds that they need to home continually then they may consider how to better use the axis automation functions in their jobs. If they believe the correct position is being lost then they need to consider having their machine serviced because this is not normal functioning of the device.

Finding the forward and reverse limits

It is suggested that the home position is found before setting the limits. It is not possible to set a limit when on the limit switch. If an axis is in this condition, then click Stop and either click Home or Move Relative to move to a position where the motor is off the sensor. Note that when automatic Forward or Reverse Limit sensing is accomplished (by clicking the appropriate buttons), the current position will not equal the limit value because WinLase will move the motor off the limit switch, in case you want to perform another limit movement. The limit movement speed is based on the value in the Motor Properties window. The limit value changes slightly due to speed. One may want to find the limit and maximum speed then find the limit a second time at a slightly slower speed such as half of the maximum or what the person typically uses in their jobs. This is a very minor difference and most designs allow a margin between the limit switch and maximum travel needed for normal operation. In all cases the OK button must be used to save settings. Once the limits are set then only upon changing the Home position should the limits need to be reset.
**CONFIGURING THE AXIS TYPES**

To edit the XY Table Settings

1. From the menu bar, select System > Preferences.
2. Click on the Motor Control tab. The Motor Control page appears.
3. Click the Properties button. The OMS Motor Controller setup appears.
4. Click the XY Table tab. The XY Table page appears.

The XY Table page:

- **A** Enables/disables the axis. When an axis is disabled, it is not accessible from the WinLase LAN user interface.
- **B** The name WinLase LAN displays within dialogs and controls to represent the axis.
- **C** Click this button to home the axis. In the edit box to the right of the Home button, enter the step count to assign to the home position. When an axis is homed, it will have this position value at home. The units are in motor steps.
- **D** Use this button to find the forward limit stop switch. After the axis has found the forward limit stop, the position count is saved and displayed in the edit box to the right of the Fwd button. The forward limit is used to warn the user of the physical limits of the axis.
- **E** The calibration factor for the axis, in steps/millimeter (mm).
**F** Use this button to find the reverse limit stop switch. After the axis has found the reverse limit stop, the position count is saved and displayed in the edit box to the right of the Rev button. The reverse limit is used to warn the user of the physical limits of the axis.

**G** Immediately stops execution of a motor move.

**H** The current position count of the motor.

**I** The position to move the motor to when the Go button is clicked. If the Moves are setting is Absolute, the motor will move to the absolute position indicated in Move To. If the Moves are setting is Relative, the motor will move the amount in Move from its current position.

**J** The speed at which the motor will execute the move, in steps/Sec.

**K** Executes a motor move based on the value in Move to.

**To edit the Custom Axis Settings**

The Custom Axis is provided to allow configuring a motor axis to be either linear or rotary, depending on the application.

1. From the menu bar, select **System > Preferences**.
2. Click on the **Motor Control** tab. The **Motor Control** page appears.
3. Click the **Properties** button. The **OMS Motor Controller** setup appears.
4. Click the **Custom Axis** tab. The **Custom Axis** page appears.

The Custom Axis page
**MOTION CONFIGURATION**

*Pro-Dex OMS motion controller*

A. Enables/disables the axis. When an axis is disabled, it is not accessible from the WinLase LAN user interface.

B. The name WinLase LAN displays within dialogs and controls to represent the axis.

C. Click this button to home the axis. In the edit box to the right of the Home button, enter the step count to assign to the home position. When an axis is homed, it will have this position value at home. The units are in motor steps.

D. Use this button to find the forward limit stop switch. After the axis has found the forward limit stop, the position count is saved and displayed in the edit box to the right of the Fwd button. The forward limit is used to warn the user of the physical limits of the axis.

E. Select the type of motion device:
   - Rotary - Select this radio button to represent the axis within WinLase LAN as a rotary device.
   - Linear - Select this radio button to represent the axis within WinLase LAN as a linear device.

F. The calibration factor for the axis, in steps/millimeter (mm).

G. Use this button to find the reverse limit stop switch. After the axis has found the reverse limit stop, the position count is saved and displayed in the edit box to the right of the Rev button. The reverse limit is used to warn the user of the physical limits of the axis.

H. Immediately stops execution of a motor move.

I. Current motor position counter

J. The position to move the motor to when the Go button is clicked. If the Moves are setting is Absolute, the motor will move to the absolute position indicated in Move To. If the Moves are setting is Relative, the motor will move the amount in Move from its current position.

K. The speed at which the motor will execute the move, in steps/Sec.

L. Executes a motor move based on the value in Move to.
To edit the Rotary Axis Settings

1. From the menu bar, select System > Preferences.
2. Click on the Motor Control tab. The Motor Control page appears.
3. Click the Properties button. The OMS Motor Controller setup appears.
4. Click the Rotary tab. The Rotary page appears.

The Rotary page

A Enables/disables the axis. When an axis is disabled, it is not accessible from the WinLase LAN user interface.
B The name WinLase LAN displays within dialogs and controls to represent the axis.
C Click this button to home the axis. In the edit box to the right of the Home button, enter the step count to assign to the home position. When an axis is homed, it will have this position value at home. The units are in motor steps.
D Use this button to find the forward limit stop switch. After the axis has found the forward limit stop, the position count is saved and displayed in the edit box to the right of the Fwd button. The forward limit is used to warn the user of the physical limits of the axis.
E The calibration factor for the axis, in steps/degree.
F Use this button to find the reverse limit stop switch. After the axis has found the reverse limit stop, the position count is saved and displayed in the edit box to the right of the Rev button. The reverse limit is used to warn the user of the physical limits of the axis.
G Immediately stops execution of a motor move.
MOTION CONFIGURATION

Pro-Dex OMS motion controller

**H** The current position count of the motor.

**I** The position to move the motor to when the Go button is clicked. If the Moves are setting is Absolute, the motor will move to the absolute position indicated in Move To. If the Moves are setting is Relative, the motor will move the amount in Move from its current position.

**J** The speed at which the motor will execute the move, in steps/s.

To view the OMS Card Properties

1. From the menu bar, select System > Preferences.
2. Click on the Motor Control tab. The Motor Control page appears.
3. Click the Properties button. The OMS Motor Controller setup appears.
WARRANTY

Lanmark Controls Inc. warrants to the Customer that the product is free from defects in workmanship and materials for a period of 12 months from the delivery date.

Lanmark Controls Inc.'s obligation under this warranty is limited to repair, replacement or service, at its option, of any part of the product, which within the warranty period and upon Lanmark Controls Inc.'s examination shall disclose to its satisfaction not to have conformed to this Agreement or to have been defective. Defective parts or products are to be returned to Lanmark Controls Inc. place of shipment.

The above warranties do not apply (i) to defects or failure of product or parts caused by accident, alteration, abuse, misuse, corrosion or improper installation or operation, or (ii) to alterations or modifications made by Customer in any way so as in Lanmark Controls Inc.'s judgment to affect the products reliability, or (iii) to installation not performed pursuant to Lanmark Controls Inc.'s factory authorized protocol, or (iv) in the case of custom software designed to interact with other Customer-supplied software, in the event of any change, upgrade or reprogramming of such Customer-supplied software so as to create an incompatibility with Lanmark Controls Inc. software.

Authorization to return products purchased from Lanmark Controls Inc. must be obtained by Customer. Returns should always be carefully packed and sent freight prepaid. Unless otherwise agreed, return shipment freight and duty charges shall be borne by Customer. Customer shall bear all charges for freight and handling of products returned which are not defective.

THIS WARRANTY IS EXPRESSLY MADE IN LIEU OF ANY AND ALL OTHER WARRANTIES EXPRESSED OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, EXPRESSED OR IMPLIED.
# Index

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>Align Tool 5-53</td>
<td>Alignment Tool 6-86</td>
<td>Configuring a Direct Connection 4-5</td>
</tr>
<tr>
<td>Automation Objects 6-85</td>
<td></td>
<td>Connecting the Motion Hardware 10-2</td>
</tr>
<tr>
<td></td>
<td>Barcodes</td>
<td>Connectivity</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Checking the Connection Status 4-12</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Closing an active connection 4-10</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Connecting automatically 4-10</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Connecting manually 4-7</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Connecting through a Local Area Network 4-5</td>
</tr>
<tr>
<td></td>
<td></td>
<td>IP Addressing Schemes 4-4</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Making a Connection 4-6</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Selecting the default Network Adapter 4-5</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Connectivity Options 4-1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Controlled by Remote API 6-74</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Controlling WinLase LAN Remotely 7-28</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Copyright Information 1-2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Correction Files 8-3</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Add an existing file 8-4</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Adjust the Scan Field Rotation 8-10</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Adjust the X and Y Field Offset 8-9</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Adjust the X and Y Field Scaling 8-8</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Calibrating 8-8</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Create a new file 8-4</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Grid Correction 8-7</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Custom Axis 6-90</td>
</tr>
<tr>
<td></td>
<td>Bitmap Graphic 6-25</td>
<td></td>
</tr>
<tr>
<td>B</td>
<td></td>
<td>D</td>
</tr>
<tr>
<td>Barcodes</td>
<td></td>
<td>Dimension Tool 5-46</td>
</tr>
<tr>
<td></td>
<td></td>
<td>E</td>
</tr>
<tr>
<td></td>
<td></td>
<td>External Control 6-5</td>
</tr>
<tr>
<td></td>
<td></td>
<td>F</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Fieldbus Interface Concepts 7-28</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Fill (Hatching) 6-7</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Understanding Closed Paths 6-9</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Fonts 6-9</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Add a new Laser font to an LEC-1 device 5-40</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Add a new Laser font to WinLase LAN 5-40</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Add a new TrueType font 5-38</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Creating a new Laser Font 5-38</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Dot Matrix Laser Fonts 6-75</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Managing 5-38</td>
</tr>
<tr>
<td></td>
<td></td>
<td>F-theta Objective Induced 8-2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Distortion 8-2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>G</td>
</tr>
<tr>
<td>Getting Started with WinLase LAN 2-1</td>
<td></td>
<td>Grid and Guidelines 5-54</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Guideline Presets 5-58</td>
</tr>
<tr>
<td></td>
<td></td>
<td>H</td>
</tr>
<tr>
<td>Host Interface 7-28</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>I</td>
</tr>
<tr>
<td>I/O Job Selection 4-30</td>
<td></td>
<td>Importing DXF and DWG files 6-84</td>
</tr>
<tr>
<td></td>
<td>Mapping Table 4-30</td>
<td>Importing Graphics at actual size 6-83</td>
</tr>
<tr>
<td></td>
<td>Timing 4-32</td>
<td>Insert Time Delay 6-92</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Installation Software 2-1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Intelligent motion control 10-1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Interactive tool 4-42</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Introduction 1-1</td>
</tr>
<tr>
<td></td>
<td>COM Automation Server Library 1-3</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Host Programming Interface 1-3</td>
<td></td>
</tr>
<tr>
<td></td>
<td>System Architecture 1-2</td>
<td></td>
</tr>
<tr>
<td></td>
<td>System Elements 1-2</td>
<td></td>
</tr>
<tr>
<td></td>
<td>TCP/IP Test Client 1-4</td>
<td></td>
</tr>
<tr>
<td></td>
<td>WinLase LAN Graphical User Interface 1-2</td>
<td></td>
</tr>
<tr>
<td></td>
<td>J</td>
<td></td>
</tr>
<tr>
<td>Job</td>
<td></td>
<td>External Start 7-15</td>
</tr>
</tbody>
</table>

v 1.5 en  WinLase LAN User Guide 1-1
INDEX

Job Editing 5-1
Job Entities 6-1
    Adding Notes 6-4
    Changing the Name 6-2
Job Events
    Before a Job is Executed 7-7
    Job Execution 7-9
    Job Loading 7-6
Jobs
    Adding a System Entity 5-16
    Creating, Opening and Closing 5-4
    Cut, Copy, and Paste Job Entities 5-18
    Default Open and Save Behavior 5-10
    Default settings 7-23
    Deleting Objects 5-20
    Editing Objects in the Workspace 5-22
    Exporting Entities 5-20
    Importing another Job 5-18
    Importing Graphic files 5-17
    Locking/Unlocking Objects 5-26
    Moving to a new location 5-9
    Pasting a Graphic file 5-17
    Saving 5-5
    Saving Stand-Alone (LEC binary) Job files 5-5
    Selecting and Deselecting Objects 5-21
    Undoing Actions 5-27
    Using Select All 5-20
Jobs Tab 3-13

L
Language 3-2
Laser Control 6-93
Laser font
    Adding to an LEC-1 device 5-40
    Adding to WinLase LAN 5-40
    Creating 5-38
Laser System Viewer 3-13
LaserSaver settings 7-21

LEC-1
    Assigning Jobs 5-11
    Changing strings at run-time 5-14
    Choosing Laser, Lens and Motion Settings 4-13
    Configuring External Start Settings 5-15
    Control Signal Options 4-35
    Controlling Remotely 4-28
    Device Name 4-2
    Diagnostic Tools 4-39
    Firmware Updates 4-43
    I/O Job Selection 4-30
    I/O Job Selection timing 4-32
    Managing Files 4-28
    Stand-Alone Job Considerations 5-14
    Understanding how WinLase LAN uses laser, lens and motion Settings 4-13

Linear Motion 6-95

M
Managing Fonts 5-38
Manufacturer 1-5
Mark on the Fly 4-33, 7-17
Mark Time 6-13
Marking Jobs 7-1
MergeFile View 7-20
Micro-vectoring and Delays 6-13
Mirror Induced Distortion 8-2
Motion
    Intelligent Motion 5-42
    Prodex OMS Controller 5-45
    Runtime Errors 5-44
    Motion Configuration 10-1
    Motion Manager 3-16, 5-42

Object Manager 3-14

P
Passwords
    Changing and Deleting 3-24
Point Array 6-27
Polygon Object 6-28
PreviewMark 7-1
Printing Jobs 5-62
Profiles 6-9
    Adding 5-31
    Applying to Objects 5-33
    Creating and Organizing 5-30
    Importing and Exporting 5-36
    Managing 5-28
    Modifying Existing 5-35
    Moving 5-32
    The Default Profile 5-28
Profiles Panel 3-15

Q
Quick Start Guide 10-2
Software 3-1
QuickMark
    Mark Time 7-5
    QuickMark Feature 7-4

R
Rectangle Object 6-29
Rotary Indexer 6-97
Rotary Motion 6-99
Rounded Rectangle Object 6-30
RS-232 and TCP/IP Interface Concepts 7-28
Run Application 6-101
Run jobs remotely 7-24
Running Jobs 7-6
    From the Workspace 7-22
    Running Stand-Alone Jobs 7-24

S
Safety Considerations 2-4
Security
    Controlling Access Level at Startup 3-26
    User Access 3-25
    Security Settings 3-21
INDEX

Serial Communication 6-103
Script File Format 6-105
Serializing Text 6-67
Set I/O Port 6-108
Show Messagebox 6-109
Snap to Grid 5-54
Snap to Guidelines 5-55
Software Tools
LEC Remote Admin Tool 1-4
TCP/IP Test Client 1-4
Status Icons, LEC-1 4-11
Step and Repeat 7-14
Strings
AutoDate > Shift Code option 6-65
AutoDate option 6-63
Automatically reset the serial number 6-69
Changing the String at Run time (Dynamic Strings) 6-59
Custom String feature 6-71
Get String from Memory Buffer option 6-70
Serialize options 6-67
Supply String at Start option 6-66
Supply String Every Mark option 6-66
Text Merge option 6-61
Subnet mismatch 4-7
T
Technical Support 1-4
Template
Creating 6-115
Editing or Removing 6-115
Template Object 6-115
The Marking Field and Lens 8-1
TrueType font
Adding to Windows 5-38
U
Understanding Field Distortions 8-1
V
Vector Graphic Objects 6-82
W
Wait for External Signal 6-110
Warranty 11-1
Working with Motion Configurations 10-3
Working with the LEC-1 4-1
Workspace 5-1
Coordinate System
Conventions 5-1
Customizing the Page Size 5-2
Job Editor 3-4
Left Toolbar 3-9
Operator Interface 3-17
Rulers 3-11
Top Toolbar 3-8
Touchscreen Interface 3-18
X
XY Motion 6-113
XY Table 6-111
Z
Zoom Tools 5-60